Pavé numérique au démarrage Debian 10

Tags: #<Tag:0x00007feddc7e8a70>

Bonjour,

Je viens de faire une instal complète de Debian 10 Buster.
Je démarre en Gnome Xorg (Wayland, je galère trop pour finaliser mon paramétrage).

Je n’arrive pas à fixer que le pavé numérique soit active au démarrage (j’ai installé numlockx et j’ai aussi fait un rc.local, mais ni l’un ni l’autre ne fixe cela).

Une idée de ce que je pourrai faire ?

Merci

Bonjour,

Pardon ? Mais, tu as fait quoi exactement dans ton rc.local ?

J’ai créé un fichier rc.local dans /etc (comme j’ai trouvé sur un site du net, mais entre temps, j’ai rédemarré le PC donc, je te le retrouverai pas vite).
Il disait de mettre ça dedans :

#!/bin/bash
for tty in /dev/tty[1-6]; do
/usr/bin/setleds -D +num < $tty
done

puis après de faire un chmod pour les droits
(pour info, j’ai pas de led à mon clavier… je suis donc pas convaincu de ce que j’ai écrit plus haut pour mon cas).
Je suppose que si je fais un rm de ce rc.local qui n’existait pas de base, ça va pas casser mon instal ? :wink:

C’est comme ça qu’on utilise ce programme ?

Que retourne ls -l /etc/rc.local ?
Que retourne sudo systemctl status rc.local.service ?

Aucune idée, s’il n’y a que ça dans ce fichier, ça devrait passer…

Je n’avais pas de rc.local au départ, c’est moi qui ait créé le fichier.
J’ai supprimé le fichier, puisque je sais pas ce qu’il fait au final.

Je ne fais que sudo systemctl status rc.local.service

rc-local.service - /etc/rc.local Compatibility
   Loaded: loaded (/lib/systemd/system/rc-local.service; enabled-runtime; vendor
  Drop-In: /usr/lib/systemd/system/rc-local.service.d
           └─debian.conf
   Active: active (exited) since Wed 2020-11-11 19:44:37 CET; 24min ago
     Docs: man:systemd-rc-local-generator(8)
  Process: 686 ExecStart=/etc/rc.local start (code=exited, status=0/SUCCESS)

nov. 11 19:44:36 SaLu-PC-87350 systemd[1]: Starting /etc/rc.local Compatibility.
nov. 11 19:44:37 SaLu-PC-87350 systemd[1]: Started /etc/rc.local Compatibility.

Oui, alors, pour revenir à ton sujet, il n’y pas une option dans les paramètres du clavier pour activer le verrouillage numérique au démarrage, il y en a un dans KDE, je me disais que GNOME aussi…

Mais, comment tu sais que ça ne fonctionne pas alors ?

Ben parce que j’ai besoin de chiffre dans mon mot de passe et que soit si je fais attention, je vois que ça tape rien quand je saisi, soit il me dit que j’ai pas mis le bon mot de passe :-p

Ah, ben, voilà, il ne faut pas utiliser le pavé numérique quand on tape un mot de passe. Je ne sais pas pourquoi les gens font ça, c’est un coup à obtenir un résultat imprévisible.

1 J'aime

d’ailleurs, dans le monde de la sécuroté, on éviote toujrosu le pavé numérique à cause de ça. Si un mot de passe peut etre locked pour des echecs successif ca peut etre violent (ce qui est le cas chez moi, avec pam_tally2, si on se trompe, au bout de 5 c est locked)

salut
pour gnome il existe 2 clés à vérifier avec dconf-editor ou en commande

il faut qu’elles soient à la valeur true

~$ gsettings get org.gnome.desktop.peripherals.keyboard numlock-state
true
~$ gsettings get org.gnome.desktop.peripherals.keyboard remember-numlock-state
true

pour modifier la valeur

~$ sudo gsettings set org.gnome.desktop.peripherals.keyboard numlock-state true

-$ sudo gsettings set org.gnome.desktop.peripherals.keyboard remember-numlock-state true

Pour numlockx il faut configurer la valeur par defaut dans le fichier

/etc/default/numlockx

# Configuration file for numlockx

# State of numlog on start of X session

# Accepts following options:

# auto - turns numlock on unless ran on laptop

# on - turns numlock on

# off - turns numlock off

# keep - does not change numlock state

# toggle - toggles numlock state

NUMLOCK=on
1 J'aime

J’ai le même retour pour
~$ gsettings get org.gnome.desktop.peripherals.keyboard numlock-state
et
~$ gsettings get org.gnome.desktop.peripherals.keyboard remember-numlock-state

La clé « numlock-state » n’existe pas ou La clé « remember-numlock-state » n’existe pas

Que je sois en user ou en superutilisateur.

Mais j’ai pu modifier le fichier /etc/default/numlockx ou la valeur était à auto et non on.

c’est que tu n’es pas en gnome-shell 3.38

$ gnome-shell --version
GNOME Shell 3.38.1

sans doute. Je trouve où la version de mon gnome shell ? (j’utilise Terminal, je suppose que ce n’est pas pareil)

houps, j’avais pas vu la suite :
Effectivement, je suis pas dans la version 3.38

$ gnome-shell --version
GNOME Shell 3.30.2

(et je comprends pas pourquoi j’aurais pas la dernière version, j’ai fait plusieurs apt update et apparement, je suis à jour pour Debian 10)

je suis en Debian 11 (testing)

utilise l’outil dconf-editor

sudo apt install dconf-editor

puis lance
Applications->outils systeme -> Editeur dconf

en mode graphique tu cherches numlock,

Capture d’écran du 2020-11-12 12-30-19

il doit etre dans un autre chemin pour gnome 3.30

1 J'aime

OK, ça me donne ça comme retour
Capture d’écran de 2020-11-12 12-32-14

org.gnome.settings-daemon.peripherals.keyboard remember-numlock-state true

et
org.gnome.settings-daemon.peripherals.keyboard numlock-state 'on'

Je pensais avoir compris quoi faire, mais voilà ce que ça me retourne :

sudo gsettings set org.gnome.settings-daemon.peripherals.keyboard numlock-state true
La valeur donnée est en dehors du domaine de validité

(parce que quand je fais
sudo gsettings get org.gnome.settings-daemon.peripherals.keyboard numlock-state
il retourne
'unknown' et pas ‹ on › comme dans dconf-editor)

il se peut que les valeurs soient différentes en gnome 30
par dfonf-editor tu double-click sur la clé et tu en sauras plus

ceci dit si avec on ça marche…

J’ai repassé à on et pas true.
Par contre dconf dit bien que remember-numlock-state conserve l’état d’activation de la led du clavier… Vu que j’ai pas de led forcement qu’il se souvient qu’elle est toujours non allumée :-p
Enfin je suppose qu’il doit y avoir un truc de ce coté à corriger

la question c’est surtout de savoir si après le bbot le pavé numérique est actif et parmets de saisir des chiffres.