Pb au montage d'un disque externe (NTFS je crois ?)

Tags: #<Tag:0x00007f78b3f18f00> #<Tag:0x00007f78b3f18e10>

Bonjour
Je viens de brancher mon disque externe, comme d’ordinaire.
Et il ne se monte pas :frowning:
La commande dmesg retourne :

    [88723.486220] usb 1-2: USB disconnect, device number 4
    [88735.763090] usb 2-1: new SuperSpeed Gen 1 USB device number 4 using xhci_hcd
    [88735.784249] usb 2-1: New USB device found, idVendor=0bc2, idProduct=2320, bcdDevice= 1.00
    [88735.784254] usb 2-1: New USB device strings: Mfr=2, Product=3, SerialNumber=1
    [88735.784257] usb 2-1: Product: Expansion
    [88735.784259] usb 2-1: Manufacturer: Seagate
    [88735.784261] usb 2-1: SerialNumber: NA47S38Q
    [88735.790351] scsi host0: uas
    [88735.791975] scsi 0:0:0:0: Direct-Access     Seagate  Expansion        060E PQ: 0 ANSI: 6
    [88735.792934] sd 0:0:0:0: Attached scsi generic sg0 type 0
    [88735.793106] sd 0:0:0:0: [sda] Spinning up disk...
    [88736.818954] ...ready
    [88738.864868] sd 0:0:0:0: [sda] 976773167 512-byte logical blocks: (500 GB/466 GiB)
    [88738.959629] sd 0:0:0:0: [sda] Write Protect is off
    [88738.959635] sd 0:0:0:0: [sda] Mode Sense: 4f 00 00 00
    [88738.959997] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
    [88738.960396] sd 0:0:0:0: [sda] Optimal transfer size 33553920 bytes
    [88738.998565]  sda: sda1
    [88739.015863] sd 0:0:0:0: [sda] Attached SCSI disk

Qu’est-ce que je peux faire pour analyser le problème ?
Merci d’avance

Grâce au propositions faites auto-magiquement par le forum, j’ai trouvé la commande ntfsfix. Ce qui a donné (avec -n pour ne pas faire d’opération) :

    # **ntfsfix -n /dev/sda1**
    Mounting volume... Corrupt index root in MFT record 65.
    Corrupt attribute list entry in MFT record 5
    Index root attribute missing in directory inode 5: Input/output error
    Failed to open $Secure: No such file or directory
    FAILED
    Attempting to correct errors... 
    Processing $MFT and $MFTMirr...
    Reading $MFT... OK
    Reading $MFTMirr... OK
    Comparing $MFTMirr to $MFT... OK
    Processing of $MFT and $MFTMirr completed successfully.
    Setting required flags on partition... OK
    Going to empty the journal ($LogFile)... OK
    Corrupt index root in MFT record 65.
    Corrupt attribute list entry in MFT record 5
    Index root attribute missing in directory inode 5: Input/output error
    Failed to open $Secure: No such file or directory
    Remount failed: No such file or directory

J’avoue avoir un peu peur de lancer la commande, sans analyser plus loin, avec le risque de ne plus récupérer ce qu’il y a sur le disque.

et, bien sûr ;
# mount -t ntfs /dev/sda1 /tmp/DDseagate/
Corrupt index root in MFT record 65.
Corrupt attribute list entry in MFT record 5
Index root attribute missing in directory inode 5: Erreur d’entrée/sortie
Failed to open $Secure: Aucun fichier ou dossier de ce type
Failed to mount ‹ /dev/sda1 ›: Aucun fichier ou dossier de ce type

salut
A vue de nez aucune idée, jamais vu
essaie de changer le fil

Rien d’anormal dans les messages du noyau. Il s’agit probablement d’une corruption du système de fichiers NTFS.
Si tu ne fais pas confiance à ntfsfix, utilise chkdsk ou autre sous Windows.
Si tu as peur de perdre le contenu à ce point, fais-en une image disque d’abord.

Bon, bin … pas moyen de récupérer le disque de sauvegarde (et de débordement)
:frowning:
Je touille le café et me décide à appeler mon ami gparted…