Pb avec l'UDMA


#1

salut,

N’ayant plus d’idée (et google non plus) pour résoudre mon pb, je vous poste celui ci.
Le probleme à resoudre et l’activation de l’Ultra DMA.

J’ai une debian (sid) avec un kernel 2.4.21 compilé maison.
Je precise que je n’ai jamais reussi a faire fontionner UDMA sous linux depuis que j’ai cette machine au boulot.

hdparm:

hdparm -d 1 /dev/hda

/dev/hda:
setting using_dma to 1 (on)
HDIO_SET_DMA failed: Operation not permitted
using_dma = 0 (off)

et pourtant:

hdparm -I /dev/hda

/dev/hda:

ATA device, with non-removable media
Model Number: WDC WD400BB-00DEA0
Serial Number: WD-WCAD15844745
Firmware Revision: 05.03E05
Standards:
Supported: 5 4 3 2
Likely used: 6
Configuration:
Logical max current
cylinders 16383 16383
heads 16 16
sectors/track 63 63

CHS current addressable sectors: 16514064
LBA user addressable sectors: 78165360
device size with M = 10241024: 38166 MBytes
device size with M = 1000
1000: 40020 MBytes (40 GB)
Capabilities:
LBA, IORDY(can be disabled)
bytes avail on r/w long: 40 Queue depth: 1
Standby timer values: spec’d by Standard, with device specific minimum
R/W multiple sector transfer: Max = 16 Current = 16
Recommended acoustic management value: 128, current value: 254
DMA: mdma0 mdma1 mdma2 udma0 udma1 *udma2 udma3 udma4 udma5
Cycle time: min=120ns recommended=120ns
PIO: pio0 pio1 pio2 pio3 pio4
Cycle time: no flow control=120ns IORDY flow control=120ns
Commands/features:
Enabled Supported:

  • READ BUFFER cmd
  • WRITE BUFFER cmd
  • Host Protected Area feature set
  • Look-ahead
  • Write cache
  • Power Management feature set
    Security Mode feature set
    SMART feature set
  • Device Configuration Overlay feature set
    Automatic Acoustic Management feature set
    SET MAX security extension
  • DOWNLOAD MICROCODE cmd
  • SMART self-test
  • SMART error logging
    Security:
    supported
    not enabled
    not locked
    not frozen
    not expired: security count
    not supported: enhanced erase
    HW reset results:
    CBLID- above Vih
    Device num = 0 determined by the jumper
    Checksum: correct

Au démarrage:

(j’ai coupé quand meme pour pas noyer le poisson)
Linux agpgart interface v0.99 © Jeff Hartmann
agpgart: Maximum main memory to use for agp memory: 203M
agpgart: Detected Intel i845 chipset
agpgart: AGP aperture is 64M @ 0xf8000000
Uniform Multi-Platform E-IDE driver Revision: 7.00beta4-2.4
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
hda: WDC WD400BB-00DEA0, ATA DISK drive
hdc: SONY CD-RW CRX220E1, ATAPI CD/DVD-ROM drive
hdd: MATSHITADVD-ROM SR-8588, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: attached ide-disk driver.
hda: host protected area => 1
hda: 78165360 sectors (40021 MB) w/2048KiB Cache, CHS=4865/255/63
hdc: attached ide-scsi driver.
hdd: attached ide-scsi driver.
Partition check:
hda: hda1 hda2 hda3 hda4 < hda5 hda6 hda7 >

Vous remarquerez la ligne ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx

Le Chipset:

lspci -v

(j’ai aussi couper)
00:1f.1 IDE interface: Intel Corp. 82801DB ICH4 IDE (rev 01) (prog-if 8a [Master SecP PriP])
Subsystem: Asustek Computer, Inc.: Unknown device 8089
Flags: bus master, medium devsel, latency 0, IRQ 10
I/O ports at
I/O ports at
I/O ports at
I/O ports at
I/O ports at f000 [size=16]
Memory at 10000000 (32-bit, non-prefetchable) [size=1K]

Je rajoute les données de la carte reseau intégré, car je n’arrive pas a la faire detecter (je m’en fou j’ai une 3COM sur la becane mais bon ca pourrai etre utile un jour de l’avoir a disposition)
02:08.0 Ethernet controller: Intel Corp. 82801BD PRO/100 VE (LOM) Ethernet Controller (rev 81)
Subsystem: Asustek Computer, Inc.: Unknown device 8071
Flags: bus master, medium devsel, latency 32, IRQ 9
Memory at f3000000 (32-bit, non-prefetchable) [size=4K]
I/O ports at b400 [size=64]
Capabilities: [dc] Power Management version 2

Pour les caractéristiques de ma Carte Mère: c’et une ASUS P4B533 avec un Intel 845E, j’ai une TNT2 dessus en plus, un graveur et un DVD-ROM.
Le disque dur est un Western Digital 40Go 7200 rpm.
Le proc est un P4 1.8 GHz

Voila si j’ai oublié des infos dites le moi je complerai, merci d’avoir lu mon pb dans tout les cas :slightly_smiling:

Yann Richard


#2

Tu as été voir les commentaires de cette news ?
http://linuxfr.org/2003/06/13/12863.html
Ca ressemble à un bug du noyau…

Personnellement, j’ai presque perdu ma partition avec le nouveau noyau…
En gros, j’attends un paquet Debian…