Pb connexion internet


#1

slt a tous,

je viens d’installer Debian pour la enieme fois et j’ai un pb pour me connecter a internet.

je suis sur un reseau avec routeur SMC/barricade.

j’ai indiqué à Debian que ma passerelle est 192.168.1.1
j’ai mis mes serveur DNS (primary et secondary wanadoo) dans /etc/resolv.conf.

“ifup -a” repond: interface lo already configured et interface eth0 already configured.
je peux pinger les postes du reseau, je peux pinger la passerelle.

pas de ping vers l’exterieur

Si quelqu’un à une idée ??
Merci d’avance.


#2

Tu as configurer ton routeur pour qu’il puisse acceder au net via ton fai est ce qu’il fonctionne sous un autre os?


#3

et si tu ping, par exemple, yahoo.fr, soit le 217.12.3.11, est ce que ca ping (d’abord avec le nom, puis avec l’adresse) ?
que donne la commande “route” ?


#4

re,

pas de pb avcec le routeur les autres poste sous windows accedent sans pb au net.
pas de ping vers l’exrterieur, ni avec le nom, ni avec l’IP

route:

destination    gateway         genmask         flags    metric    Ref    use iface
localnet       *               255.255.255.0   U        0         0      0 eth0
default        192.168.1.1     0.0.0.0         UG       0         0      0 eth0 

#5

ce ne serait pas un probleme de configuration de firewall iptables ou autres


#6

j’ai essayer :
/etc/init.d/iptables stop et start
reponse : aborting iptables load: unknown ruleset, “inactive”.

m^m resultat en DHCP!


#7

iptables n’est donc pas installé.
ca ne marche pas mieux en dhcp…
ta table de routage est bonne pourtant…
Une chose est sure, si tu ping en interne, c’est que le probleme est sur le routeur.
Il n’est pas limité en nombre d’adresse ip NATées ?
C à D si tu éteinds tes autres clients, et que tu redémarres ton linux en dhcp, ca ne marche toujours pas ?
:question: :question: :question: :question: :question: :question: :question: :question:


#8

ok ca passe en DHCP (apres avoir redemarer :open_mouth: )

en m^m temps DHCP c’est pas trop c ki me faut je dois monter un server web.

merci a tous
suis connecter c deja tres bien

ad’taleur


#9

tu peux peut etre faire de l’attribution dynamique “statique” :slightly_smiling:
tu récupères la mac adresse de ta carte: c’est sans doute comme ca que ton routeur identifies ses clients dhcp. Tu dois avoir une page qqpart sur ton routeur, ou une option de CLI (interface en ligne de commande sur ton routeur), qui doit te permettre d’attribuer toujours la même adresse IP à une mac adress donnée… tu peux donc tabler sur cette adresse pour ta configuration de serveur.

sinon, je crois qu’on peut faire cohabiter à la fois une adresse statique et une dynamique sur une même carte, mais je ne suis pas sur…
en tout cas, plusieurs statiques, c’est certain, mais je crois qu’une dynamique et plusieurs statiques, c’est aussi possible.
si tu as installé iproute2, essayes:
ip addr add eth0 192.168.1.xxx/32 dev eth0
(la même en ‘ip addr del’ pour revenir en arrière)
tu devrais avoir une deuxieme adresse sur eth0 (en plus de ton adresse dhcp). je l’ai mis en /32 sur ton LAN pour ne pas “tout casser”, mais il faudrait sans doutes ajuster.
au passage tu peux récup ta mac address avec ‘ip link’, c’est un truc du genre 7a:6a:25:64:a4:9f brd ff:ff:ff:ff:ff:ff

PS: tu devrais installer le paquet “resolvconf”. il entretien automatiquement ton résolv.conf en fonction des infos dhcp et ppp (et part de ta config actuelle).