Pb de clavier avec sarge


#1

bonjour à tous,
j’ai un petit pb avec la sarge et je n’ai pas trouvé de reponse ailleurs et comme il vaut mieux s’adresser au bon dieu qu’a ses saints, voilà j’ai installé la sarge récement et le clavier est qwerty pourtant à l’install pas de soucis avec clavier fr, j’ai donc configuré Gnome et kde avec le bon clavier et je n’ai que le promt en qwerty donc pas de soucis jusqu’a ce que je decide d’installer xfce et là pas moyen de configurer le clavier. Je suppose donc qu’il doit utiliser la config du noyau.
Pour info j’ai fait 3 install, 1) dvd de linux+, 2) iso et http et 3) le cd du livre debian et http et tj le même pb.
J’ai vraiment besoin d’un wm léger sur ma machine et je veux debian alors si qq a une idée ce serait sympas.
merci


#2

il faudrait faire un dpkg-reconfigure du paquet concernant le clavier, mais je ne suis plus sur duquel c’est, peut etre console-tools, ou console-data ?
En tout cas, si tu refais un ‘base-install’ il va te redemander ta config clavier…


#3

salut,
console-data je confirme, j’ai deja fait et je mets azerty comme à l’install d’ailleurs mais le pb persiste alors j’essaie qwerty et toutes sortes de clavier mais rien n’y fait.
J’aimerais savoir si qq a le clavier francais dans la sarge, je pourrais au moin mieux cerner le pb.
MattOTop j’ai vu que tu habites a caen, je me permet de te souhaiter le bonjour du havre.
A+


#4

j’ai vu aussi un paquetage kbd…
Bonjour de CAEN !


#5

kbd? tu peux etre plus précis


#6

non, en fait, aprés investigation, c’est un vieux paquetage, remplacé par kbd-compat (un wrapper de compatibilité pour console-tools).
Fausse piste.
La, je suis sec :confused:


#7

mais pour info, je suis en sarge avec clavier français (remarque la cédille), et aucun probleme sur les diverses machines que j’ai installées en sarge récemment…
personnellement, je fais toutes mes installs en ligne, soit avec debootstrap, soit en netinst.
Je n’ai jamais eu à réinstaller une machine, sauf en cas de plantage en cours d’install pour passer en mode expert sur un PII mmx 166 (qui tourne en 2.6.8 sarge, donc)
Pour info toujours, sur ma machine perso, j’ai du downgrader et purger ma distrib en woody en enlevant presque tout y compris certains paquetages obligatoires, une fois, avant de réupgrader (je ne sais plus pourquoi) et même ca, ca me laisse une machine stable et clean (mais j’avoue j’en ai bavé pas vous… :slightly_smiling: )


#8

question qui vient de mon nez qui frise: est ce que tu es en framebuffer sur ta console ?


#9

ok, merci
j’ai cru lire qqpart qu’il fallait remettre la config d’origine avec dpkg-reconfigure mais je ne la connait pas, dommage, car apparement ça a fonctionné donc si tu as une idée!!!


#10

il voulait peut etre dire qu’il fallait refaire un ‘base-install’ comme je te le disais au tout début de ce post :slightly_smiling:


#11

Non, pas de blagues, ne lui trouvez pas de boulot car il ne sera plus dispo pour ns aider :wink:
Vu ton site et lu ton cv : oops !
Tu as au moins deux points communs avec mon fils aîné : l’âge (1966 : bonne année pour le Bordeaux) et les études : il a fait l’N7 à Toulouse et en 3ème année il a fait “intelligence artificielle”. Maintenant, il a changé de cap, il est commercial ds l’infrastructure GSM.
Je te souhaite de trouver rapidement une place à ta valeur.
Ricardo


#12

et encore, je cache la partie Mathématiques, parceque ca m’a valu des places d’intello, alors que je ne réve que d’un job avec les mains dans le cambouis (ou au moins la tete dans le réel)… :wink:


#13

bonjour
bon, ça ne fonctionne tjrs pas même après l’install sur une autre machine.Je me demande s’il n’est pas possible de modifier le clavier dans xfce, je me demande aussi si je ne me plante pas à l’install pourtant j’ai 3 claviers standard en azerty, ps2 et je met les locales fr, euro etc… autre chose, il me semble que j’ai installé le noyau 2.6 est-ce qu’il y aurait un rapport?
si qq a une bonne idée…
a+


#14

tu veux dire que tu as fait une install à blanc sur une autre machine, et que tu te retropuves avec un clavier qwerty en console sans pouvoir reconfigurer ?
tu dois etre passé plusieurs fois à coté de quelquechose de simple…
tu as bien fait dpkg-reconfigure console-data sur les deux ?
tuas bien console-tools, -data, et -common sur les deux ?
je ne vois pas…


#15

je sais pas si c’est ca mais si tu fais un dpkg-reconfigure xserver-xfree86, à un moment on te demande quelle disposition de clavier tu veux utiliser…


#16

:laughing: :laughing: :laughing:
le probleme est sur la console !


#17

bonjour,
ça marche, j’ai trouvé ce matin en bidouillant une énieme install, matha68 a raison il faut reconfigurer le serveur x ,MattOTop je me suis mal expliqué: a l’install tout était en us et j’ai configuré Gnome et KDE de l’intérieuret quand j’ai parlé de prompt je parlais du prompt graphique debian, ou je tape le login, alors lorsque j’ai installé xfce je me suis retouvé avec un bureau us que l’on ne peut modifier qu’a travers le serveur x, désolé donc! mais ne te sauve pas, j’ai windows et linux en réseau avec freebox et il faut que je configure samba, j’essaierai d’être plus précis cette fois ci dans et un autre post.
merci à tous a+