Pb de serveur de messagerie


#1

Salut,

Depuis 3 jours mon serveur de messagerie qmail ne reçoit plus rien de l’extérieur au bout de 24h, alos que celui-ci fonctionner depuis belle lurette.

aucune trace de problème tout les procéssus tourne, mais les mail provenant d’autres serveur n’arrrive pas et je suis obligé de rebooter le serveur pour que ça reparte !

lors qu’il fonctionne bien, j’ai ceci :
tail -f /var/log/syslog

tout les process de qmail tourne, rien en queue !

Je ne vois vraiment pas d’où celà peut venir ?!!!
Tous les matins obligé de faire reboot !


#2

Avez vous une idée pour trouver la panne ?


#3

slt,

Essaie de désactiver ton antispam, peut-etre du a un probleme de spam, comme ca tu laisse tourner ton serveur de mail a nue, (sans anti-spam) sinon jette un oeuil du coté des logs "/var/log/{mail.warn,mail.err,mail.log}, as tu fait des modifications ces derniers temps ? as tu fait des mise a jours ?


#4

Je suis de retour !

Là le problème c’est accrus, ça ne repard pas après reboot, reçoit seulement les messages envoyé en local

Le wget ne fonctionne plus : connexion ver …:80… (et rien ne se passe)

le ping passe, mon reseau a du net au travers de la passerelle linux

SOS


#5

quand tu dis que le ping passe, c’est avec le nom, ou juste l’adresse ?
Parceque ça peut provenir d’un pb de résolution, peut être…


#6

le DNS resous bien les adresses.

Je pense que le problème vient de là :

echo “1” > /proc/sys/net/ipv4/conf/eth0/rp_filter # Pas de spoofing
echo “0” > /proc/sys/net/ipv4/conf/lo/rp_filter
echo “1” > /proc/sys/net/ipv4/tcp_syncookies # Pas de synflood

c’était le dernier ajout depuis que celà ne fonctionne plus
j’essaye de faire un vi /proc/sys/net/ipv4/conf/eth0/rp_filter
pour effacer les données, mais le système ne veut pas que j’enregistre mes modifications !

Avez vous une idée ?


#7

bon, tes flags kernel, tu devrais les mettre dans /etc/sysctl.conf, alors rajoutes les:

[quote="/etc/sysctl.conf"]
net/ipv4/conf/eth0/rp_filter=1
net/ipv4/conf/lo/rp_filter=0
net/ipv4/tcp_syncookies=1[/quote]
aprés, tu joues avec les on/off, et tu regardes si ça s’applique bien quand tu redémarres.

En fait, tu ne peux pas modifier ces choses là (/proc/sys/*) avec vi, ce ne sont pas des fichiers, mais des accés directs au noyau.
Si tu veux les modifier à la volée, tu fais des
echo 1 >/proc/sys/[le chemin de ton flag]
(ou echo 0)


#8

entre temps je me suis un peu énervé avec :
echo 0 ou 1 sur ces différents fichiers et maintenant ça refonctionne !

Je regarderai ce qu’il y a dans mon /etc/sysctl.conf, maintenant que je connais son utilité

Dans le coup tout est reparti, même la messagerie (pour cb de temps ?)

merci pour l’info