Pb de son et de clé usb


#1

Bonjour à tous,
j’ai installé la dernière version stable de Debian sur mon ordi mais il y a des trucs que je comprend pas :smiley:
Je tiens à préciser que je suis totalement débutant :laughing:

D’abord au niveau du son. J’entends les son de Linux quand j’ouvre ou ferme une fenêtre etc… j’entends aussi quand je lis un mp3. Mais dès que j’ai envie de lire un CD audio ça ne marche pas. Je lance le Lecteur de Cd KsCD, j’appuie sur lecture et je vois le temps qui défile mais toujours pas de son dans mes oreilles. Donc je ne sais pas si il y a un réglage que j’ai raté…
J’ai donc été dans “Centre de configuration KDE” puis “Son et multimédia” puis “Systeme de son”. Lorsque je fais “tester le son” j’entends quelque chose mais si je fais “Tester le MIDI”, je n’entends rien.
Voila en gros ce que j’ai fait… est-ce qu’il y a une âme charitable pour m’aider ?

Et pour la clé usb j’ai essayer avec KwikDisk mais il me dit "couldn’t determine the filesystem type"
et j’ai essayer en faisant mount /media/usb0 et il me met à peu près le même message… :confused:

Donc voila ça doit pas être bien compliquer à régler mais je galère vraiment

Merci


#2

Bonsoir,
pour le lecteur de Cd KsCD il me semble qu’il lui faut un cable partant du lecteur et raccordé à la carte mére. Pour eviter cela utilise, xmms, kafféine, totem, mplayer, …, tu as le choix.
pour ta clef usb inspire toi de ceci, (à adapter à ta config):
$ lsusb pour verifier que le peripherique est detecté.

mkdir /mnt/clefusb pour créer un repertoire

pour montagne automatique # vi /etc/fstab
rajouter /dev/sdb1/ /mnt/clefusb vfat defaults,rw,users,noauto,0 0


#3

n8zfm.com/sound/Sound-HOWTO.html


#4

Merci beaucoup pour ton aide
xmms me dit :
"impossible d’ouvrir l’audio
Veuiller vérifier que:

  1. Votre carte son est correctement configurer
    2)Vous avez sélectionné le greffon de sortie correct
    3)Aucun autre programme ne bloque la carte son"

Donc je pense que c’est un problème de driver non ? pour le son j’ai un truc qui s’appelle AC’97.

Voila et pour la clé usb je vais essayer ça et je reviens te dire si ça marche :d


#5

pour le son verifie que les paquets asla-base et alsa-utils soient installés; ensuite fait un #alsaconf s’ils n’étaient pas presents.


#6

vérifies l’option 2/ que t’indique xmms: tu va dans les preferences changer le plugin de sortie, et ça devrait marcher.
Ah et il faut aussi que tu appartiennes au group “audio” pour avoir les droits sur les périphériques audio:
adduser ton_user audio


#7

lsusb me sort ça donc je crois que la 3ème ligne correspond bien à ma clé usb :smiley:

Bus 005 Device 001: ID 0000:0000 Bus 005 Device 002: ID 0aec:3260 Neodio Technologies Corp. 7-in-1 Card Reader Bus 005 Device 005: ID 0ea0:2168 Ours Technology, Inc. Transcend JetFlash 2.0 / Astone USB Drive Bus 004 Device 001: ID 0000:0000 Bus 003 Device 001: ID 0000:0000 Bus 002 Device 001: ID 0000:0000 Bus 001 Device 001: ID 0000:0000 Bus 001 Device 003: ID 04a9:1094 Canon, Inc.

et le /etc/fstab ressemble à :

proc /proc proc defaults 0 0 /dev/hdb1 / ext3 defaults,errors=remount-ro 0 1 /dev/hdb3 /home ext3 defaults 0 2 /dev/hdb2 none swap sw 0 0 /dev/hdc /media/cdrom0 iso9660 ro,user,noauto 0 0 /dev/hdd /media/cdrom1 iso9660 ro,user,noauto 0 0 /dev/fd0 /media/floppy0 auto rw,user,noauto 0 0 /dev/sde /media/usb0 auto rw,user,noauto 0 0 /dev/sdb1/ /mnt/cleusb vfat defaults,rw,users,noauto,0 0

Ensuite je fais quoi pour accéder à ma clé usb??? (désolé c’est sans doute une question con mais je vois pas :confused: )

Et pour le son alsa n’était pas installé en effet :smiley:
Donc je l’installe mais il me dit :

Si je met oui, il me met:

Donc j’ai quand même mis oui mais au final il me met:

debian:/usr/local/bin# alsaconf modinfo: snd: no module by that name found modinfo: snd: no module by that name found modinfo: snd: no module by that name found Unloading ALSA sound driver modules: (none loaded). Building card database... modinfo: snd-opl3sa2: no module by that name found modinfo: snd-cs4236: no module by that name found modinfo: snd-cs4232: no module by that name found modinfo: snd-cs4231: no module by that name found modinfo: snd-es18xx: no module by that name found modinfo: snd-es1688: no module by that name found modinfo: snd-sb16: no module by that name found modinfo: snd-sb8: no module by that name found
Et quand je lance XMMS il me met la même erreur alors que j’ai sélectionné le plugin de sortie alsa


#8

Essaie ça:
montage manuel #mount /dev/sdb1/ /mnt/cleusb
demontage manuel # umount /mnt/cleusb


#9

pour ta clé, maintenant, l’usage normal, doit être mount /mnt/cleusb

par contre, pour alsa, c’est normal que ça ne marche pas si tu n’as pas de pilote correspondant. c’est un peu bizarre, car alsa gère plein de cartes.
tu as quoi comme carte son ?
tu utilises quel noyau ? (uname -r devrait te le dire).

Tu peux aussi essayer de compiler alsa:

aptitude update aptitude install module-assistant m-a a-i alsa
mais bon…


#10

J’ai compiler alsa et là… ça marche!!!
J’arrive à lire mes mp3 avec XMMS ( ce que je n’arrivais pas à faire…) :smiley: :smiley: :smiley:
Mais par contre je galère pour lire les CDs. Est-ce qu’il y a une manipulation particulière à faire ?
Si j’essaie de le monter avec KwikDisk, il me met un message d’erreur:

Appelé : mount /dev/hdc mount: wrong fs type, bad option, bad superblock on /dev/hdc, missing codepage or other error In some cases useful info is found in syslog - try dmesg | tail or so

j’ai essayé de lire le cd avec cdcd un lecteur en mode console mais ça ne marche pas non plus

Donc voila je sais pas trop quoi faire :smiley:

Et pour la clé usb ça ne marche pas non plus mais ça c’est moins grave

En tout cas merci beaucoup puisque ça commence à marcher :wink:

edit: En fait j’avais oublié d’installer xmms-cdread donc maintenant ça marche :smiley: du coup il ne reste plus que la clé usb à faire marcher :stuck_out_tongue:


#11

essaie kaffeine ou totem pour lire tes cd-audio.


#12

Apperemment j’ai édité mon message au moment où tu écrivais le tien donc je remet ici ce que j’ai dit: En fait j’avais oublié d’installer xmms-cdread donc maintenant ça marche.

Je peux lire les CD audio avec totem aussi mais kafféine semble avoir du mal… mais bon je m’en fout je sent que j’ai déja adopté XMMS :smiley:

Sinon il ne reste plus que le petit problème de la clé usb

En tout cas merci beaucoup à yo4 et à MattOTop :wink:


#13

non non. Pas de kaffeine: bluenote n’est pas là !

titizebioutifoul: idikoi quand tu fais ‘mount /cleusb’ ? tu n’as pas dit ?


#14

non non. Pas de kaffeine: bluenote n’est pas là !
[/quote]

excellent, Matt.


#15

Au secours!!
Je viens d’essayer de lire un CD audio avec XMMS mais il ne veut plus :imp:
Je crois que je comprend plus rien… Avec totem il lit les CD audio mais pas avec XMMS c’est bizarre! pourtant j’ai vérifié le plugin de sortie et c’est bien alsa. Je vois le temps qui défile mais je n’entends rien :confused:

Pour la clé usb j’ai fait ‘mount /mnt/cleusb’ et il me sort :

mount: special device /dev/sdb1/ does not exist (a path prefix is not a directory)


#16

reouvre ta session X et ne lances QUE xmms, pour voir s’il lit les cd quand tu n’as pas encore lancer d’autre utilitaire de son.

enleves le / avvant /dev/sdb1 dans fstab pour la cle usb