Pb d'upgrade


#1

voilà depuis quelques temps je tente de faire dist-upgrade mais c’est toujours les paquets:
Les paquets suivants seront mis à jour
python python2.3 python2.3-doc
qui doivent être mis à jour.
en essayant de les mettre à jour, j’obtient une erreur que vraisemblablement personne n’obtient.
(Lecture de la base de données… 182443 fichiers et répertoires déjà installés.)
Préparation du remplacement de python 2.3.2-4 (en utilisant …/python_2.3.2-6_all.deb) …
Dépaquetage de la mise à jour de python …
dpkg : erreur de traitement de /var/cache/apt/archives/python_2.3.2-6_all.deb (–unpack) :
tentative de remplacement de « /usr/share/doc/python2.3/python-policy.html », qui appartient aussi au paquet python2.3
dpkg : retirer python en faveur de python2.3 …
dpkg : non, impossible de retirer python (voir --auto-deconfigure) :
knewsticker-scripts dépend de python
python doit être supprimé.
dpkg : concernant …/python2.3_2.3.2-6_i386.deb contenant python2.3 :
python2.3 entre en conflit avec python (<= 2.3.2-5)
python (version 2.3.2-4) est installé.

dpkg : erreur de traitement de /var/cache/apt/archives/python2.3_2.3.2-6_i386.deb (–unpack) :
paquets en conflit - python2.3 non installé
dpkg : concernant …/python2.3-doc_2.3.2-6_all.deb contenant python2.3-doc :
python2.3-doc entre en conflit avec python2.3 (<< 2.3.2-6)
python2.3 (version 2.3.2-4) est installé.
dpkg : erreur de traitement de /var/cache/apt/archives/python2.3-doc_2.3.2-6_all.deb (–unpack) :
paquets en conflit - python2.3-doc non installé
Des erreurs ont été rencontrées pendant l’exécution :
/var/cache/apt/archives/python_2.3.2-6_all.deb
/var/cache/apt/archives/python2.3_2.3.2-6_i386.deb
/var/cache/apt/archives/python2.3-doc_2.3.2-6_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Je voudrais savoir si quelqu’un pouvais m’aider c’est vraiment génant.

merci d’avance.


#2

C’est un bug référencé : http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=221944

Lis le, ca va être réglé avec les nouvelles versions des paquets concernés.


#3

Merci beaucoup
…^_^…


#4

J’ai le même problème…et ca fait un ptit moment que ça dure ce problème… et je me demande s’il a pas été corrigé et que c’est sur mon pc que ça continue à merder.

LeLaulauPC:/home/lelaulau# apt-get dist-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
  python2.3-tk: Dépend: python2.3 (= 2.3.2-6) mais 2.3.2-4 est installé
E: Dépendances manquantes. Essayez d'utiliser l'option -f.

Et je peux rien installer non plus. Quelqu’un pourrait m’expliquer comment bidouiller pour que ça marche temporairement et pour remettre tout en place quand ça sera réparé?


#5

Je crois que le bug a été réparé sur le serveur…mais ça continue à merder chez moi, serait ce normal?


#6

Eh bien moi c’est toujours pareil!
quand je fais un upgrade j’ai aucun paquets de nouveau et j’ai toujours ces trois santanés paquets python!!!

Attendons que les serveurs de bugs soient opérationnels conformément aux dernières news concernants la compromission de certains serveurs debian centraux.


#7

J’ai réussi à réparer chez moi en désinstaller tout ce qui me posait problème :slightly_smiling:)
Puis en réinstallant. Et ça marche