Pb geforce 6200


#1

bonjour,
qqn sait comment faire fonctionner une carte graphique MSI Nvidia GeForce NX6200AX-TD128 avec debian, sincerement je n’entend rien du tout à ces bêtes la.
Après quelques recherches j’ai vaguement compris…pas grand chose en fait alors si qqn peut éclairer ma lanterne ce serai sympas car en vesa avec un 21" c’est gravement plantogène quelque soit la distrib.
merci pour tout,


#2

Il te faut récupérer le driver à l’adresse suivante:
http://www.nvidia.com/object/linux_display_ia32_1.0-7676.html

L’installation est facile et c’est bien documenté.
Surtout, ne t’em… pas avec les packages debian…


#3

salut jabba,
j’ai deja vu ca dans mes recherches sans trop bien saisir donc d’après toi on suit le readme et la carte fonctionne correctement mais est-ce valable pour toutes les distrib car j’ai lu des histoires de compilation de kernel pour mandriva 2005 par ex; Une autre question rapidement j’ai une autre carte mmx 440 je crois et je n’ai jamais eu de soucis avec aucune distrib et il y en a eu pourtant et des pas jeunes;
A+


#4

Bonjour à tous, je despere ça fait depuis le début de l’apres midi que j’essai d’installer cette meme carte video ( celle de mon ordinateur portable) … sur ma debian.
Absoluement pas moyen … avec le script nvidia il me répond qui lui manque les headers et quand je lui précise au lancement du script ou sont les headers correspondant à mon noyau, il lui manque nvidia.ko…
je ne sais absolument plus quoi faire… et je commence à avoir un besoin urgent d’un linux en état de marche… ( projet C++ à rendre bientot … )
Si quelqu’un avait la solution ce serait le rêve !
merci


#5

home.comcast.net/~andrex/Debian- … ebian.html


#6

BGon, comme je te le disais en messager, comme tu es sur un portable, tu n’as peut etre pas besoin d’une qualité optimale tout de suite, d’autyant plus que ce qui te faut, c’est juste qqchose qui marche.
Alors tu peux essayer de configurer ta carte avec un framebuffer.
comme disait Jabba:

[quote=“Jabba”]xdebconfigurator -diklr
et ensuite:
dexconf

Ca régènere le fichier XF86Config-4 avec toutes les valeurs supportées par ton matos.
[/quote]
Lors de la config, tu choisis ton framebuffer ‘vesafb’ ou 'nvfb’
je precise qu’xdebconfigurator est ds le pkt du même nom.


#7

Problème toujours par résolu… avec bien du mal et grâce à l’aide de Mattotop j’ai réussi à mettre à jour mon kernel en 2.6.8, à installer le script nvidia, et à installer nvidia-glx, et j’ai ensuite reconfiguré xfree86, mais lorsque je veux lancer x, il me retourne le message d’erreur suivant :
no screen found

je sais vraiment pas quoi faire…


#8

Tu as bien remplacé “nv” par “nvidia” dans ton XF86Config-4 ?

Ne sais plus de mémoire ou ca se trouve …


#9

[quote=“Jabba”]Tu as bien remplacé “nv” par “nvidia” dans ton XF86Config-4 ?

Ne sais plus de mémoire ou ca se trouve …[/quote]

on voit ceux qui viennent de la old school :wink:

XF86Config-4 est dorenavant remplacé par xorg.conf

sinon, pour l’installation des drivers nvidia, j’ai suivi ce tuto et tout s’est bien déroulé (il y a même quelques étapes que j’ai sauté car déjà ok):

[quote]Simple instructions on how to install nVidia drivers for X11 on
Debian written by Len Sorensen.
(LSorensen on irc.debian.org, lsorense -at- csclub.uwaterloo.ca)

Last updated September 7 2005.
Feel free to email reports on this information working or not working
and any suggestions you have on making it better.

Note:
At this time these are the debian versions:
sarge: Debian 3.1 stable release
etch: Debian testing release (will be next stable release when done)
sid: Debian unstable (will never be released, but provides packages for
testing after they have been tested for a while.)

Step 0: Cleaning up the mess from nvidia’s installer (if you used it first)

Make sure to remove all the garbage created by the nvidia installer,
since it places files in different locations, and may cause problems
even after following these instructions. It is supposed to have an
uninstall option. Something like: nvidia-installer --uninstall should
do it. I have not used it myself, since doing it this way is so simple
and works very well, and of course: It is `The Debian Way’. The
–uninstall option should remove everything it installed (At least I
hope so.)

Do NOT try to mix and match with the debian packages and the nvidia
installer. They do not get along, they don’t agree on where files should
go or how just about anything should be done. It’s one way or the other.
To do it right the Debian way, all traces of the nvidia installer has
to go. In fact the nvidia installer doesn’t agree with where Debian
installs files.

Step 1: Preparing your package sources

Ensure you have main contrib non-free in your /etc/apt/sources.list since
the nvidia drivers are in non-free and some of the helpers are in contrib.

Step 2: Ensure your kernel is the right version.

The nvidia driver requries a 2.4 or 2.6 kernel at the moment. This should
not be a problem since all current Debian releases use either 2.4 or
2.6 kernels.

Please make sure you are running an up to date kernel so that the headers
matching it can be installed. The simplest way to do this is to do:

apt-get install kernel-image-2.4-686
or
apt-get install kernel-image-2.4-k7
or
apt-get install kernel-image-2.6-686
or
apt-get install kernel-image-2.6-k7

That will keep you running the latest kernel released (either 2.4.x
or 2.6.x). If the command to install kernel-headers fails later, you
didn’t do this step right.

Remember to reboot after installing a new kernel so that you are running
the right one. If you already had the current kernel, you can just
continue.

Step 3: Installing needed packages for building the nvidia kernel module.
Install a few packages needed:

apt-get install nvidia-kernel-common module-assistant

If you are running a debian kernel do this:

m-a -i prepare
If you built your own kernel, just make sure you know where the source
for it is located so you can pass the location to m-a.

Step 4: Building and installing the nvidia kernel module
Build the kernel module package:

m-a a-i -i -t -f nvidia-kernel
depmod -a
or if using your own kernel build:
m-a a-i -i -t -f -k /usr/src/kernelsourcepath nvidia-kernel
depmod -a
Where /usr/src/kernelsourcepath is the location of your kernelsource

Step 5: Installing and configuring the nvidia glx X driver
Install the last few packages:

apt-get install nvidia-glx nvidia-glx-dev xserver-xfree86

Now you are ready to change X to use the new driver. Configure X
normally using:

dpkg-reconfigure xserver-xfree86
And configure the monitor, resolution, mouse, etc settings as you need
and select nvidia instead of nv as your driver. If you ever edited the
XF86Config-4 file manually, the simplest way to overwrite it with one that
has the new values is to run ‘dexconf’. If you never edited it yourself,
it should just auto update with the new settings.

Note: Any user that wants to run 3D code must be in the video group.
To add a user to the video group do this:

adduser youruser video
The next time they login to X they will have 3D access.

That’s it. You should be running the new X. You should see the nvidia
logo when X starts if you are succesfully running the new driver.

Notes:
Keep in mind that whenever a new version of the nvidia driver comes out,
or whenever you upgrade to a newer kernel, you will have to repeat step
4 again to build the nvidia kernel module to match the new driver and/or
new kernel. One potential solution to part of this (at least for a new
kernel version) would be to have something in the boot up scripts do:
modprobe nvidia || m-a a-i -i -t -f nvidia-kernel && depmod -a && modprobe nvidia
That should load the nvidia driver and if it fails, run the rebuild
command and then load it again. It won’t help if a new nvidia glx driver
is installed, since the old module will load fine, but the driver won’t
get along with it, and the boot scripts can’t detect the cause of X not
started (it probably won’t even know X failed to start).

If the nvidia modules doesn’t load automatically and the X server
complains about it, add ‘nvidia’ to /etc/modules to make it auto load
on boot.

When upgrading, the simplest is to reboot afterwards to make sure X and
the kernel module are using the same version. You could also stop X;
modprobe -r nvidia; modprobe nvidia; start X again.[/quote]

source: tinyplanet.ca/~lsorense/debian/d … -howto.txt

et voici mon fichier /etc/X11/xorg.conf:

[quote]# xorg.conf.dpkg-new (Xorg X Window System server configuration file)

This file was generated by dexconf, the Debian X Configuration tool, using

values from the debconf database.

Edit this file with caution, and see the xorg.conf.dpkg-new manual page.

(Type “man xorg.conf.dpkg-new” at the shell prompt.)

This file is automatically updated on xserver-xorg package upgrades only

if it has not been modified since the last upgrade of the xserver-xorg

package.

If you have edited this file but would like it to be automatically updated

again, run the following commands as root:

cp /etc/X11/xorg.conf.dpkg-new /etc/X11/xorg.conf.dpkg-new.custom

md5sum /etc/X11/xorg.conf.dpkg-new >/var/lib/xfree86/xorg.conf.dpkg-new.md5sum

dpkg-reconfigure xserver-xorg

Section “Files”

FontPath “unix/:7100” # local font server

# if the local font server has problems, we can fall back on these
FontPath	"/usr/lib/X11/fonts/misc"
FontPath	"/usr/lib/X11/fonts/cyrillic"
FontPath	"/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath	"/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath	"/usr/lib/X11/fonts/Type1"
FontPath	"/usr/lib/X11/fonts/CID"
FontPath	"/usr/lib/X11/fonts/100dpi"
FontPath	"/usr/lib/X11/fonts/75dpi"

EndSection

Section "Module"
Load "bitmap"
Load "dbe"
Load “ddc”

Load “dri”

Load	"extmod"
Load	"freetype"
Load	"glx"
Load	"int10"
Load	"record"
Load	"type1"
Load	"v4l"
Load	"vbe"

EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option “XkbRules” "xorg"
Option “XkbModel” "pc105"
Option “XkbLayout” "be"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option “Device” "/dev/input/mice"
Option “Protocol” "ExplorerPS/2"
Option “Buttons” "7"
Option “ZAxisMapping” "6 7"
EndSection

Section "Device"
Identifier "NVIDIA Corporation NV34 [GeForce FX 5200]"
Driver "nvidia"
BusID "PCI:1:0:0"
Option “UseFBDev” "true"
Option "NoLogo"
EndSection

Section "Monitor"
Identifier "CPD-E430"
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "NVIDIA Corporation NV34 [GeForce FX 5200]"
Monitor "CPD-E430"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes “1280x1024” “1024x768” “800x600” "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes “1280x1024” “1024x768” “800x600” "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes “1280x1024” “1024x768” “800x600” "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes “1280x1024” “1024x768” “800x600” "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes “1280x1024” “1024x768” “800x600” "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes “1280x1024” “1024x768” “800x600” "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

#Section “DRI”

Mode 0666

#EndSection
[/quote]


#10

J’ai un excellent principe que j’applique depuis des années: je laisse les téméraires débugger pour moi, c’est pour ça que je ne suis pas encore pas passé à Xorg :laughing:
Donc c’est bien, tu travailles pour moi :laughing:

PS: Ceci dit, je vais bientôt y passer, Xorg semble solide :wink:


#11

salut a tous,
jabba, moi aussi je suis sous xfree86 ca marche bien pour l instant alors pkoi changer :unamused:
sinon petite question vite fait:
Xorg apporte koi en plus (reellement :p) ?


#12

XFree a décidé de passer sur une license qui n’a pas été jugé compatible avec la GPL (sur laquelle est basée la debian), et donc il a été créé un “fork” de XFree, nommé Xorg, qui remplacera XFree dans les prochaines debian.
Qu’apporte Xorg ? Pour l’instant, je crois qu’il est en retard sur Xfree sur pas mal d’aspects, mais qu’il gère mieux les transparences (sic.).
A vérifier dans le concret.


#13

humm merci mat donc je bouge pas
pas bouger, pas faire de gaffe :>


#14

J’ai un excellent principe que j’applique depuis des années: je laisse les téméraires débugger pour moi, c’est pour ça que je ne suis pas encore pas passé à Xorg :laughing:
Donc c’est bien, tu travailles pour moi :laughing:

PS: Ceci dit, je vais bientôt y passer, Xorg semble solide :wink:[/quote]

ce qui est important pour les puristes :wink:

et je suis donc fier et honoré de faire parti des “testeurs”!
je confirme que Xorg tourne parfaitement bien chez moi.

mais peut-on encore parler de “testing”?

a vrai dire ça fait plus de 8 mois que j’utilise Xorg (Mandriva, Ubuntu et maintenant Debian) :wink:

nous sommes donc certainement plus de la majorité (en utilisateurs particuliers tout du moins) à utiliser Xorg à la place de Xfree (qui n’est plus vraiment “free” en fait :wink: ).

c’est comme continuer à encoder en “mp3” au lieu de “ogg” ou encore en “divx” au lieu de “xvid” pour moi … quelques soient nos raisons de s’être tourné à un moment ou un autre vers l’open source, soyons le à fond (au possible tout du moins) tant qu’à faire! ce n’est que contribuer soit même (et ce n’est pas grand chose) à ce mouvement - capital à mes yeux.

idem pour l’opendocument … d’ici à quelques mois, je vous invite à favoriser l’opendocument au lieu de continuer à jouer le jeu des .doc, .xls & compagnie …

débat large et passionant comme vous pouvez le constater …

may the force be with you :stuck_out_tongue:


#15

C’étais bien de le préciser, je m’apprêtais à te répliquer que si tu faisais de l’informatique en entreprise, tu comprendrais un peu mieux ma prudence de sioux … :laughing:
Et forcément, ca à un peu tendance à “déteindre” sur mon usage personnel des outils informatiques. :wink: