PB installation Discord

Tags: #<Tag:0x00007fb986e91050>

Salut,

I Installation de Discord. J’ai récupéré le paquet .deb et voici la suite :

root@Boganathar:~# dpkg --install /home/clematis/Téléchargements/discord-0.0.15.deb
Sélection du paquet discord précédemment désélectionné.
(Lecture de la base de données... 301181 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../discord-0.0.15.deb ...
Dépaquetage de discord (0.0.15) ...
dpkg: des problèmes de dépendances empêchent la configuration de discord :
 discord dépend de libappindicator1 ; cependant :
  Le paquet libappindicator1 n'est pas installé.
 discord dépend de libc++1 ; cependant :
  Le paquet libc++1 n'est pas installé.

dpkg: erreur de traitement du paquet discord (--install) :
 problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour mailcap (3.69) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.36.0-1) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.26-1) ...
Des erreurs ont été rencontrées pendant l'exécution :
 discord
root@Boganathar:~# 
root@Boganathar:~# apt install libappindicator1 libc++1
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Aucune version du paquet libappindicator1 n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « libappindicator1 » n'a pas de version susceptible d'être installée

Que faire ?

Merci d’avance pour votre aide,
Clé

Bonjour,

D’abord, évite de mettre deux sujets différents dans le même fil, c’est confusant.

Pour le cas de Discord, tu peux utiliser la commande qui répare les dépendances non satisfaites :

apt install -f

Pour le cas de Telegram, j’ai une question idiote :

Pourquoi lances-tu ça en tant que root ?

Bonjour,

Merci pour ta réponse. Voilà ce que ça donne pour discord (lol) :

root@Boganathar:~# dpkg --install /home/clematis/Téléchargements/discord-0.0.15.deb
(Lecture de la base de données... 301266 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../discord-0.0.15.deb ...
Dépaquetage de discord (0.0.15) sur (0.0.15) ...
dpkg: des problèmes de dépendances empêchent la configuration de discord :
 discord dépend de libappindicator1 ; cependant :
  Le paquet libappindicator1 n'est pas installé.
 discord dépend de libc++1 ; cependant :
  Le paquet libc++1 n'est pas installé.

dpkg: erreur de traitement du paquet discord (--install) :
 problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour mailcap (3.69) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.36.0-1) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.26-1) ...
Des erreurs ont été rencontrées pendant l'exécution :

discord

root@Boganathar:~# apt install -f
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Correction des dépendances... Fait
Les paquets suivants seront ENLEVÉS :
  discord
0 mis à jour, 0 nouvellement installés, 1 à enlever et 0 non mis à jour.
1 partiellement installés ou enlevés.
Après cette opération, 181 Mo d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] n

Telegram s’est finalement mis à jour. Généralement c’est moi qui pose les questions bêtes : Pourquoi pas en root ?
Ben j’étais en root, et mon utilisateur n’est pas sudoer. Voiloù. Fallait pas ?

Bonne journée !

Ah oui, effectivement, je n’avais pas pensé à ça.
Le paquet libappindicator1 ne semble pas exister.
Après, je ne sais pas quel est ton besoin dans Discord, mais tu peux envisager le faire tourner ça dans un navigateur.