Pb installation paquet mysql-server sur sid


#1

Bonjour,

j’ai un pb d’installation lorsque je fais mes apt-get update et apt-get upgrade quotidiens, le paquet mysql-server_4.0.21-6_i386.deb plante toujours.
J’ai beau chercher sur le net, je n’ai pas trouvé de réponse me satisfaisant jusqu’à présent et c’est pourquoi je demande ici à quelqu’un de m’aider.
Voici le message d’erreur :

Preparing to replace mysql-server 4.0.20-3 (using .../mysql-server_4.0.21-6_i386.deb) ...Stopping MySQL database server: mysqld. ERROR: There's not enough space in /var/lib/mysql/ dpkg: error processing /var/cache/apt/archives/mysql-server_4.0.21-6_i386.deb (--unpack): subprocess pre-installation script returned error exit status 1 Stopping MySQL database server: mysqld. Errors were encountered while processing: /var/cache/apt/archives/mysql-server_4.0.21-6_i386.deb E: Sub-process /usr/bin/dpkg returned an error code (1)

Pour info, je suis sur debian Sid.
Apparemment, si je comprends bien, l’erreur provient d’un problème de place dans /var/lib/mysql mais en faisant un du -sh, j’obtiens 260Mo. Mon DD fait 40 Go et est plein à 45%, pas de partition (je sais, c’est pas bien…)

Est ce que quelqu’un aurait une idée??? Une info pouvant m’aider ?

Merci d’avance pour vos réponses


#2

pistes:
1/as tu bien un /var/lib/mysql/ (le nouveau paquetage ne travaille peut etre pas avec la même arbo) ?
2/as tu arrèté mysql avant de faire ton upgrade (ca a resolu qques installs pour moi) ?
3/je ne sais pas comment s’installent les nouveaux paquetage en apt-get upgrade, ni ce qu’il fait des fichiers de confidg d’origine lors de l’update (j’utilise dselect qui permet de choisir entre le nouveau et l’ancien, ou de visualiser le diff des deux) dc, tu peux sauver tes fichiers mysql (bases et config), purger le tout, réinstaller, et reintegrer ta config et tes données aprés. Non ?