Pb installation sur hp pavillon zv5000


#1

Bonjour,

j’ai installer le cd de la debian sarge sur mon portable j’ai le systeme de base mais lorsque je lance le telechargement de package de gnome, j’utilise une connexion internet par carte reseau.
J’ai un message d’erreur:
NETDEV WATCHDOG: eth0: transmit time out
eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
et j’aimerai savoirt quoi faire pour installer la debian
J’ai pense installer le dernier kernel, mais lorsque je fais un lspci je ne vois pas tout a l’ecran.

Merci de votre aide


#2

je comprends pas tout.
Ta carte réseau, aprés install, ne fonctionne pas, ce qui t’empêche de faire des mises à jour en ligne pour tester un autre noyau ?
Si tu as fait une install de base, tu dois avoir ça sur ton CD. Que donne
apt-cache search kernel-image
et
apt-cache search linux-image
?


#3

apres install la carte reseau fonctionne mais au bout d’un certain temps ou je telecharge des donnees via apt-get j’ai ce code erreur :
NETDEV WATCHDOG: eth0: transmit time out
eth0: link up, 100Mbps, full-duplex, lpa 0x45E1

et je ne sais pas koi faire pour que cela fonctione

apt-cache search linux-image me donne :
rien
et
apt-cache search kernel-image me donne plusieur ligne sur :
Ndiswrapper en noyau 2.6.8-2-k7 et 2.4.27.2-586tsc et 2.4.27-2-386
PCMCIA
acx100-source et ipw2200 et ipw2100

J’ai sur mon portable une carte wifi BCM4306
est-ce la carte wifi qui fait que ma carte ethernet perd le reseau

merci


#4

OOOOooh, si ca ne pose pas de problême avec un autre OS, peu de chance qu’il ya iat un prob de conflit de ressource coté linux.
Par contre, tu dis que tu n’as pas de [kernel|linux]-image en 2.6 ? Je m’attendais à ce que tu aies au moins une image 2.6.8.
En fait, il faudrait que tu regardes la version de ton noyau (uname -r), puis que tu en choisisse un autre, pour voir si ta carte réseau est plus stable…
Bon, je dois aller m’occuper du diner.
++


#5

Lorsque je fais uname -r
cela m’affiche que j’ai la version 2.6.8-2-386 du noyau


#6

[quote=“andarius40”]apres install la carte reseau fonctionne mais au bout d’un certain temps ou je telecharge des donnees via apt-get j’ai ce code erreur :
NETDEV WATCHDOG: eth0: transmit time out
eth0: link up, 100Mbps, full-duplex, lpa 0x45E1[/quote]
Bon, à priori, ç’est juste un message de deconnection (ça peut aussi venir du cablage), mais en attendant, est ce que tu es tout de même en mesure d’arriver au bout d’un ‘apt-get update’, quitte à recommencer l’opération plusieurs fois ?
Parceque “un certain temps ou je telecharge des donnees”, ça manque de précision.
L’idée, ça serait de préparer un sources.list sid minimal, juste le temps d’installer un noyau 2.6.15, et de voir si ta carte réseau est déjà mieux gèrée.
Donc voilà le contenu que tu va temporairement mettre dans ton /etc/apt/sources.list:

deb http://ftp2.fr.debian.org/debian/ sid mainCa devrait suffire.
Tu fais un ‘apt-get update’, ‘apt-get install linux-image-2.6.15-1-486’, en répètant l’opération si ça plante.
Aprés, tu remettras ton sources.list.
C’est un portable ? Ta carte réseau, c’est quoi ?


#7

J’ai un portable la carte reseau est une a base de chipset rtl-8139
J’ai du le faire en 2 fois pour telecharger le linux-image-2.6.15-3-486
Au redemarrage j’ai une erreur : /dev/hda7 n’existe pas.
J’ai lancer une reinstallation a partir du cd netinstall
et je vais essayer de compiler le dernier kernel stable pour voir


#8

J’ai essayer de reinstaller a partir du cd net install de la stable et il veut meme pas installer le system de base par internet, alors je vais essayer avec la testing


#9

J’ai installer la testing pas de souci de carte reseau mais lorsque je fais :
apt-get install gnome
Il m’affiche qu’il y a un tas de dependance mais qu’il ne les installera pas.

Il devrait installer les dépendances pareils pour kde.

Je dois avoir un pb de serveur apt.

Serait il possible de me donner des serveurs apt pour pouvoir installer gnome

Merci


#10

C’est normal (chi#{[ mais normal):
forum.debian-fr.org/viewtopic.php?t=2297
Maintenant, il va falloir faire des mises à jour répetées en alternant les upgrade, les dist-upgrade, et les dselect-upgrade.
Maintenant, si tu veux une sarge, ça peut être le moment de downgrader, c’est faisable, et je peux t’indiquer comment.


#11

Je veux bien,
j’ai trouver sur le forum quelqu’un qui avait la meme erreur :
forum.debian-fr.org/viewtopic.php?t=2290

Mais comme lorsque je lance la net install de la sarge il ne peut telcharger les packages standard, je ne sais pas comment faire pour configurer mon reseau car ma carte est eth0 et il me met une eth1(firewire je pense)

mais je veux bien essayer le downgrader


#12

bon, alors tu mets ce premier fichier (j’ai laissé les sources sid et etch en commentaire, pour que tu les ait sous la main, mais si tu veux les activer pour pouvoir taper dans les paquets sid et etch en cas de besoin, il faudra d’abord que tu comprenne ce que c’est que le fichier “preferences” cf. plus bas):

[quote="/etc/apt/sources.list"]## sarge
deb ftp2.fr.debian.org/debian/ sarge main contrib non-free
deb-src ftp2.fr.debian.org/debian/ sarge main contrib non-free
deb ftp2.fr.debian.org/debian-non-US/ sarge/non-US main contrib non-free
deb-src ftp2.fr.debian.org/debian-non-US/ sarge/non-US main contrib non-free

etch

#deb ftp2.fr.debian.org/debian/ etch main contrib non-free
#deb-src ftp2.fr.debian.org/debian/ etch main contrib non-free

sid

#deb ftp2.fr.debian.org/debian/ sid main contrib non-free
#deb-src ftp2.fr.debian.org/debian/ sid main contrib non-free

volatile

deb ftp://ftp2.de.debian.org/debian-volatile stable/volatile main contrib non-free

deb-src ftp://ftp2.de.debian.org/debian-volatile stable/volatile main contrib non-free

security

deb security.debian.org/ sarge/updates main contrib non-free
deb-src security.debian.org/ sarge/updates main contrib non-free
#deb security.debian.org/ etch/updates main contrib non-free
#deb-src security.debian.org/ etch/updates main contrib non-free
[/quote]
ensuite, tu mets ce fichier là le temps de la migration:[quote]Package: *
Pin: release o=Debian,a=stable,l=Debian-Security
Pin-Priority: 1005

Package: *
Pin: release o=volatile.debian.net,a=stable,l=debian-volatile
Pin-Priority: 1004

Package: *
Pin: release o=Debian,a=stable,l=Debian
Pin-Priority: 1003
[/quote]
ça va remplacer tous les paquets etch par des sarge, et si tu veux enlever/désinstaller les paquets etch non remplacés et compatible, il faut rajouter:

Package: * Pin: release o=Debian Pin-Priority: -1
aprés apt-get update,
ensuite, tu fais des apt-get upgrade, dist-upgrade, et dselect-upgrade, jusqu’à ce qu’il n’y ait plus de modif en cours.
Il va te désinstaller des paquets: c’est normal.
Surtout, ne pas redémarrer. Et ne t’inquiètes pas si ta machine te parait “grave plantée”, elle est toujours récupèrable.
si tu boucles sans que plus rien ne s’installe, essayes des apt-get un à un sur les paquets annoncés comme “CONSERVES”(=kept, si tu es en anglais).
Et sinon, tu peux utiliser ‘dselect’ que j’aime bien, mais qui installe un peu trop de choses inutiles par défaut. Si tu l’utilises, ne passes pas par la première étape (0. [A]ccéder Choisir la méthode d’accès à utiliser).
Des questions ? Au boulot :wink:


#13

merci, je me lance


#14

Cette partie la:
Package: *
Pin: release o=Debian,a=stable,l=Debian-Security
Pin-Priority: 1005

Package: *
Pin: release o=volatile.debian.net,a=stable,l=debian-volatile
Pin-Priority: 1004

Package: *
Pin: release o=Debian,a=stable,l=Debian
Pin-Priority: 1003

je la met dans mon fichier sources.list a la suite?

merci encore


#15

j’ai trouver pour ma question il faut creer un fichier preferences

lorsqeu je lance apt-get update j’ia le message:
Impossible de localiser la liste des pacquets sources ftp2.fr.dfebian.org sarge/non-US/main Packages (/var/lib/apt/lists/ftp2.fr.debian.org_debian-non-US-dists_sarge_non-US_main_binary-amd64_Packages) - stat (2 aucun fichier ou repertoire de ce type)
et si je les mets en commentaire le s2 nonUS j’aile meme probleme pour les 2 autres stables


#16

J’ai remarque que la testing ne me mettait pas le multiboot avec xp donc,
J’ai reinstaller la sarge, puis j’ais redemarrer avec le kernel en recovery et j’aimerai installer le kernel du cd de la testing
comment faire?

merci


#17

[quote=“andarius40”]J’ai remarque que la testing ne me mettait pas le multiboot avec xp donc,
J’ai reinstaller la sarge, puis j’ais redemarrer avec le kernel en recovery et j’aimerai installer le kernel du cd de la testing
comment faire?

merci[/quote]sais tu qu’il existe autre chose que des bombes atomiques pour tuer une mouche ? :laughing:
quel besoin de reinstaller alors que c’est quelques lignes de conf à taper ?
quel besoin de redémarrer en “recovery” ?
Enfin… Maintenant, pour accèder aux paquets testing en etant en stable, le plus simple c’est de rajouter temporairement les sources etch, d’installer ce qui t’interresse, puis de supprimer les lignes.
Tu trouveras les éléments un peu partout sur le forum: le problême est ultra recurrent.


#18

Ou est ce que je peux telecharger un kernel tel que:
linux-image-2.6.15-1-486
et l’installer a partir d’un cd.

merci encore