Pb mise à jour


#1

Bonjour à tous et bonne année :smiley:

J’ai un petit souci pour mettre à jour ma debian, l’update se fait sans problème mais lorsque je fait l’upgrade j’ai le message d’erreur suivant:

sudo apt-get dist-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
  vim: Dépend: vim-runtime (= 1:6.4-004+2) mais 1:6.4-004+1 est installé
  vim-gtk: Dépend: vim-runtime (= 1:6.4-004+2) mais 1:6.4-004+1 est installé
E: Dépendances manquantes. Essayez d'utiliser l'option -f.

L’option -f me fait un peu peur, alors j’aimerais avoir l’avis d’un spécialiste avant de forcer l’installation.

Bonne journée :smiley:


#2

l’option -f ne force pas l’install. Elle force la résolution en premier des problemes de dépendances.
Enfin. C’est une commande faite pour CORRIGER apt quand il y a un problême, dc tu peux y aller les yeux fermés.
Ceci étant dit, je pense que ca ne corrigera rien.
Peux tu dire ce que donne ‘apt-cache policy vim vim-runtime vim-gtk’
?


#3

Salut Matt,

voici le résultat de la commande apt-cache

im:
  Installé : 1:6.4-006+1
  Candidat : 1:6.4-006+1
 Table de version :
 *** 1:6.4-006+1 0
        500 http://ftp2.fr.debian.org unstable/main Packages
        100 /var/lib/dpkg/status
vim-runtime:
  Installé : 1:6.4-006+1
  Candidat : 1:6.4-006+1
 Table de version :
 *** 1:6.4-006+1 0
        500 http://ftp2.fr.debian.org unstable/main Packages
        100 /var/lib/dpkg/status
vim-gtk:
  Installé : 1:6.4-006+1
  Candidat : 1:6.4-006+1
 Table de version :
 *** 1:6.4-006+1 0
        500 http://ftp2.fr.debian.org unstable/main Packages
        100 /var/lib/dpkg/status

J’ai également lancé la commande apt-get -f install et tous les problèmes ont été résolus, j’ai pu mettre à jour ma debian ensuite :smiley:

Par contre je n’a pas vraiment pigé le problème de version avec vim :question:

Merci pour ton aide