Pb mutliboot


#1

voila j’ai voulu mettre sarge sur un dd avec win xp dessus, j’ai fait partition magic 8 , et donc mis 20Go en nouvelle partition

mais apres que l’install se passe bien grub ou lilo n’arrive pas a booter, ce qui fait que l’on ne peut acceder a rien

message erreur : grub : grub loading stage 1.5
grub loading, please wait …

                             lilo : L

comment resoudre le pb ? soit avoir linux sur le DD qui foire, soit remettre windo en place pour install sarge sur un autre DD ?

svp ca urge :imp:

merci bien


#2

Tant qu’à faire puisque tu utilises partition magic, tu peux créer une petite partition de 25 mega sur lequel tu installes le programme de boot de partition magic (boot magic je crois). Tu peux le faire directement àpd windows dans le programme Partition magic (et donc au démarrage tu auras le choix entre windows et Linux). Perso c’est ce que j’utilise et ça marche très bien :smiley:


#3

explication approfondie du pb :
etat actuel :
1er DD = 120Go, mais install partiel de linux ( net install ) avec lilo qui bug ( no boot, meme delire avec grub ), donc on ne peut acceder a windo
2eme DD = 1OGo , install de sarge fonctionne

mon pb est comment faire repartir la DD sous windows ?

car j’avais fais un partitionnement sur le 1er DD mais lilo bug et comme pas choix du multiboot, ca bloque.
donc y faudrait pouvoir reecrire la partition de boot pour windows, comment faire cela ? ( j’ai essayer avec les 6 disquettes win XP pro, d’ou fixboot, il dit c’est ecrit et apres on reboot mais lilo bug encore, d’ou comment se sortir de cela ?

merci


#4

Le plus simple c’est de réinstaller lilo (ou grub) avec ton cd d’install de Debian: tu bootes avec et tu passes direct à l’étape Rendre mon système amorçable (normalement il te dira qu’il à détecté un autre système d’exploitation et te demandera si tu veux qu’il le gère, évidemment tu mets oui)

edit: tu peux néanmoins utiliser partition magic comme indiqué dans mon premier post


#5

je reprecise ; lilo ou grub deconne a chaque fois ( pres de 20 essais ) et je n’ai plus acces a windows, donc je ne sais pas comment faire

au secours :cry:


#6

Lilo ou grub, euh t’as installé les 2 ??? parce que si c’est le cas ça doit sûrement créer un conflit.
Sinon sous Dos tu peux faire restormbr ou restorrmbr je sais plus trop (vérifie dans le répertoire windows) et normalement ça devrait rendre windows amorçable, par contre linux…


#7

ba j’ai essayer les 2 et aucun n’a booter directement donc la je ne sais quoi faire


#8

y’a pas moyen d’ecraser l’amorce de linux pour mettre celle de win ?


#9

T’as essayé fdisk àpd de ta Sarge?


#10

oué mais cela supprimera la partition linux mais ne reecrira pas l’amorce windows


#11

svp coment reecrire l’amorce windows ?


#12

Dans l’ancien temps … :slightly_smiling: , quand j’utilisais encore windows :open_mouth:
Il suffisait de booter avec une disquette dos et de taper:

fdisk /MBR

Maintenant, avec WinXP on peut récupérer le secteur de boot du HD en bootant avec les disquettes de récup. ou le CD d’install et taper un truc dans le genre:

FIXMBR

Je ne suis pas tout à fait sûr de la commande, alors vérifie avant !

Prépares une disquette de boot lilo ou grub avant la manoeuvre, parce que ca te restaure le boot windows mais ton lilo ou grub est viré !


#13

Ah voilà, je ne retombais plus sur la commande exacte :smiley:


#14

Ça peut ptet te dépanner ?

[quote]6. Restauration de Grub en mode rescue :

Vous avez par mégarde effacé votre grub ? aucun problème, il vous suffit de démarrer en mode console pour le restaurer. Voici comment le faire grâce au CDROM de votre distribution :
» Pour Debian :

* Au prompt tapez : rescue root=/dev/hdxx

Pour restaurer grub dans le mbr, tapez simplement :
/tmp/linux/usr/sbin/grub --config-file=/tmp/linux/boot/menu.lst
grub> root (hd0,3)
grub> setup (hd0)[/quote]


#15

donc a l’invite de commande je choisi le disque puis tape fdisk /MBR ?

j’espere que cela va fonctionner, mais reste un sacre faceur que win boot sur le cd, car y boot quand ca lui fait plaisir