Pb page web ac firefox


#1

Salut,

J’ai créer un serveur web .Le pb c’est qu’avec le navigateur firefox et mozilla je pense les pages ne s’affiches pas (certaines) alors que ac IE ou autre cela fonctionne.
UNe ptite précision d’inportance:
Si je vais sur mon site depuis son emplacement soit /var/www la aucun pb mais si j’y vais depuis tir.ath.cx pb mais pk?

Autre tite question, sur ce site justement j’ai fais des frames.
Mais je n’arrive pas a enlever les deux trais gris qui séparent les liens et le titre:

<frameset cols="22%,*">
		<frame name="ancres" src="ancres.html" scrolling="no" noresize frameborder=0 framginwidth="0">
		<frame name="texte" src="texte.html" frameborder=0 framginwidth="0">
	</frameset>

Merci


#2

Essaye ca<frameset framespacing="0" frameborder=NO noresize border="0" cols="15%,85%">


#3

[quote=“rjcb”]Salut,

J’ai créer un serveur web .Le pb c’est qu’avec le navigateur firefox et mozilla je pense les pages ne s’affiches pas (certaines) alors que ac IE ou autre cela fonctionne.
UNe ptite précision d’inportance:
Si je vais sur mon site depuis son emplacement soit /var/www la aucun pb mais si j’y vais depuis tir.ath.cx pb mais pk?

Autre tite question, sur ce site justement j’ai fais des frames.
Mais je n’arrive pas a enlever les deux trais gris qui séparent les liens et le titre:

<frameset cols="22%,*">
		<frame name="ancres" src="ancres.html" scrolling="no" noresize frameborder=0 framginwidth="0">
		<frame name="texte" src="texte.html" frameborder=0 framginwidth="0">
	</frameset>

Merci[/quote]
salut,
dans quel sens “ls pages ne s’affichent pas”??il te renvoie une erreur?ou alors c’est une page blanche?ou seulement certaine partie de la page ne sont pas présente?

sinon pour ton probleme de bordure avec tes frames, je te conseille de remplacer frameborder=0 par border="0"

voila
A+


#4

Merci bcp. LA sol marche impek. :laughing:


#5

Lorsque tu codes ta pages web, il faudrait que tu verifie qu’elle soit conforme avec les recommandations du W3C.
a cet adresse http://validator.w3.org/.
Ca te permettra d’etre sur de la compatibilité avec firefox et IE(normalement).
voila et pouvoir afficher afficher un beau lien comme quoi ta page à ete validé. :slightly_smiling:
voila


#6

Bon ba pour l’instant c’est pas top :cry:


#7

J’ai un autre gros pb.

J’ai fais un site web et il fonctionne bien lorsque je l’ouvre a partir du HDD.
Par contre si je l’ouvre a partir du site http:\XXXXXX.cx il y a des pages ou les fotos ne s’affiche pas alors que d’autres s’affiche et c’est la meme méthode.
Ptite précision: c’est moi qui héberge mon site.

Merci


#8

Peux tu nous fournirs les codes qui ne fonctionnent pas car sans c’est un peu dur de diagnostiquer le probleme

Regarde au niveau des droits d’acces au repertoire et au niveau des src des images si c’est des urls relatives ou absolues ?


#9

Salut!!

voici un site pr exemple ou les images ne s’affichent pas.
http://divers.ath.cx

Ce site est stocké sur mon serveur apache 2.0 dans:
/var/www/html/divers.ath.cx/
Dans ce repertoire il y a un mon index.htm et mes 6 images.

[code]

Divers

<body bgcolor=#0000007FF text="white" link="yellow" alink="green" vlink="grey">
	
		<center> <table>
			<tr>
				<td><img src="./IMG_6129.jpg" height="800" title="Photo" border="1"></p></td>
				<td><img src="./IMG_6130.jpg" height="400" title="Photo" border="1"></p></td>
			</tr>

		</table> </center> 

		<center> <table>
			<tr>
				<td><img src="./IMG_6131.jpg" height="800" title="Photo" border="1"></p></td>
				<td><img src="./IMG_6132.jpg" height="800" title="Photo" border="1"></p></td>
			</tr>
		</table> </center>
		<center> <table>
			<tr>	
				<td><img src="./IMG_6133.jpg" height="800" title="Photo" border="1"></p></td>
				<td><img src="./IMG_6134.jpg" height="800" title="Photo" border="1"></p></td>
			</tr>

		</table> </center>

</body>
[/code]

NB: je ne sais pas ceque c’est des urls relatives ou absolues

Merci


#10

voici deux exemples

url absolue

url relative

En ce qui concerne ton code met tout en minuscule ton erreur doit venir de la internet n’aime pas trop les majuscules

??? tu doit avoir une erreur la car c’est un code de couleur codé en hexa decimal suivant les 3 couleurs rvb rouge vert bleu tu doit donc avoir 6 caracteres
bgcolor=#0000FF >affiche le fond en bleu

[quote=“rjcb”]<td><img src="./IMG_6129.jpg" height="800" title="Photo" border="1"></p></td> [/quote]Rajoute la balise alt elle est normalement obligatoire


#11

Je viens de faire tes modis mais tjs le meme pb.
Par contre j’ai pris une autre image j’ai mis le meme nom et le cela s’affiche.
Les images ont les memes caractéristiques : 400*500 # 60Ko JPEG

Merci


#12

[code]

Divers

<body bgcolor=#0007FF text="white" link="yellow" alink="green" vlink="grey">
    <center>
        <table>
            <tr>
                <td><img src="./img_6129.jpg" height="800" title="Photo" border="1" alt="Photo"></td>
                <td><img src="./img_6130.jpg" height="400" title="Photo" border="1" alt="Photo"></td>
            </tr>
		    <tr>
                <td><img src="./img_6131.jpg" height="800" title="Photo" border="1" alt="Photo"></td>
                <td><img src="./img_6132.jpg" height="800" title="Photo" border="1" alt="Photo"></td>
            </tr>
            <tr>	
                <td><img src="./img_6133.jpg" height="800" title="Photo" border="1" alt="Photo"></td>
                <td><img src="./img_6134.jpg" height="800" title="Photo" border="1" alt="Photo"></td>
            </tr>
        </table>
    </center>
</body>
[/code] Essaye ca et renomme tes photos en minuscules

#13

j’ai trouver l’erreur, l’extension était en majuscule.

Merci :wink:


#14

Tant que j’y suis j’ai une autre question:

Je voudrais faire un site avec accès par mot de pass avec la méthode des deux fichiers .htaccess et .htpasswd.
Mon site se trouve dans /var/www/html/gxx.ath.cx/ sur ma fedora core3
Le pb c’est que rien ne se passe.

J’ai fais le fichier pass.htaccess:

Authname "Zone Protégée"
AuthUserFile /var/www/html/gxx.ath.cx/.htpasswd
AuthGroupFile /dev/null
AuthType Basic

require valid-user

J’ai fais le fichier pass.htpasswd:

rjc:xvnkjo1235467

J’ai transféré ces 2 fichiers dans /var/www/html/gxx.ath.cx/ car je veux protéger tt le site gxx.ath.cx

Voila dc si qq1 a une idée pourquoi rien ne se passe merci


#15

As tu configuré apache pour gerer les delegations???

AllowOverride


#16

j’ai fais ceci dans httpd.conf

<Directory /var/www/html>

Options Indexes Includes FollowSymLinks

AllowOverride All
Allow from All
order allow,deny

J’ai relancé httpd.conf mais toujours rien :confused:


#17

<Directory “/var/www/html”>

Options Indexes Includes FollowSymLinks

AllowOverride All
Allow from All
order allow,deny

j’avais oublié les guillemets


#18

Oki je vois dans ton fichier une petite erreur il est plus adequat de mettre order allow, deny avant allow from all

Ca devrais donc donner<Directory "/var/www/html"> Options Indexes Includes FollowSymLinks /*Tu as reelement besoin de includes??*/ AuthName prive /*Definis le nom de la zone privé*/ AuthType basic /*Definis le type d'identification*/ AuthUserFile /etc/httpd/privilegies /*Definis où se trouve le fichier nom + mdp*/ Require valid-user /*Demande l'authentification pour l'acces aux pages*/ AllowOverride All /*Conseiller de mettre none*/ Order allow,deny /*Defini l'ordre dans lequel les directives von etre exe*/ Allow from All /*Autorise tout le monde*/ </Directory>Ensuite tu cree le fichier user avec son mot de passe que tu tape 2 fois apres la premiere commande ici l’utilisateur est user

htpasswd -c /etc/httpd/privilegies user pass pass


#19

Grace a ton aide mon truk ce précise.
J’arrive a une fenetre qui demande un login et un mdp.
Mais c’est la creation du fichier que je ne comprends pas.
J’ai cré un fichier pass.htpasswd dans /etc/httpd/privilegies avec le nom d’utilisateur et le mdp crypté:

J’ai fais le fichier pass.htpasswd:

rjc:xvnkjo1235467

Mais cela ne fonctionne pas.

avec ta sol :
htpasswd -c /etc/httpd/privilegies user
pass
pass

cela dit: htpasswd: cannot create file /etc/httpd/privilegies rjc

Merci

NB: le code que j’ai mis dans httpd.conf doit remplacer le fichier .htaccess si j’ai bien compris


#20

[quote=“rjcb”]Grace a ton aide mon truk ce précise.
J’arrive a une fenetre qui demande un login et un mdp.
Mais c’est la creation du fichier que je ne comprends pas.
J’ai cré un fichier pass.htpasswd dans /etc/httpd/privilegies avec le nom d’utilisateur et le mdp crypté:

J’ai fais le fichier pass.htpasswd:

rjc:xvnkjo1235467

Mais cela ne fonctionne pas.[/quote]C’est normal en fait tu n’a pas a creer de repertoire ou de fichiers “privilegies” tu supprime le repertoire ainsi que le fichier pass.htpasswd qui ne te servent pas pour ca une fois supprimer tu n’oublie pas de relancer apache (on ne sais jamais vaut mieux le relancer trop de fois que pas assez)donc on reviens juste apres avoir mis les données directories dans httpd.conf une fois cela et comme apache est redemarer tu tape htpasswd -c /etc/httpd/priviligies user puis le pass 2 fois et il va te creer le fichier (option -c) /etc/httpd/privilegies avec a l’interieur le login et le mot de passe crypté tu relance apache avec un apachectl restart (en root) et voila normalement ca fonctionne
Pour ne pas creer de nouveau fichier tu ne met pas d’option exemple htpasswd /etc/httpd/privilegies nemesisPour plus d’info voir man htpasswd[quote=“rjcb”]
avec ta sol :
htpasswd -c /etc/httpd/privilegies user
pass
pass

cela dit: htpasswd: cannot create file /etc/httpd/privilegies rjc

Merci[/quote]Normal si tu as deja creer le repertoire ca risque de poser probleme si ce n’est pas le cas l’as tu fait en root cette commande??[quote=“rjcb”]
NB: le code que j’ai mis dans httpd.conf doit remplacer le fichier .htaccess si j’ai bien compris[/quote]Oui il remplace bien le .htaccess en fait le .htaccess permet de gerer la configuration de apache sans etre root c’est donc assez dangereux niveau securité si on laisse faire n’importe quoi mais c’est plus souple pour les webmaster