Pb reseau


#1

slt a tous
mon reseau marche pas !!

voila le contenue de mon fichier interface :

#the loopback interface
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address 192.168.0.6
netmask 255.255.255.0
broadcast 192.168.0.255
gateway 192.168.0.1

la command ifup -a repond :
ifup: interface lo already configured
ifup: interface eth0 already configured

ifconfig repond :
lo link encap:local loopback
inet adr: 127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:58 errors:0 dropped:0 overruns:0 frame:0
TX packets:58 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:4020(3,9 KiB) TX bytes:4020 (3,9 KiB)

g aussi essayer en DHCP
rien a faire

merci d’avance pour votre aide


#2

salut queque ça donne :
pppoeconf ?

Ignace


#3

slt

pppoeconf
repond: pas de carte reseau detecter.

me propose de lancer Modconf
ce ke g fais

ensuite lorske g selectionne un driver pour la carte reseau
repond: install this module in the kernel ?
yes

et là repond:Please enter any command-line arguments for 3c501 module.many modules can autoprobe and do not require additional parameters.

là g ne sais pas dutout ce ke g dois entrer


#4

fé un modprobe non_du_module_de_la_carte_etherenet

et ressaye

pour le nom du module regarde déjà si elle apparait en tapant :

lspci
et donne moi le résultat

ignace


#5

ok

g fais un modprobe avec non de la carte

reponse:
installation succeded

le reseau fonctionne puiske j’arrive a pinguer les autres poste et vice versa.

merci ignace

mais, car il y a un mais

je n’arrive pas a sortir sur le net via mon routeur

j’arrive a pinguer la passerelle (routeur)

lorske g fait ifconfig eth0 il me renvois mon IP avec la broadcast et le Mask mais pas la passerelle


#6

ca passe en DHCP !!

mais j’aimerais kan m^m avoir une IP fixe pour pouvoir faire tourner un server web


#7

heu là par contre je sais pas là,
j’ai jamais essayé un truc comme ça
désolé

Ignace

ps : pense a rajouter ton module dans /etc/modprobe.conf si noyau 2.6
/etc/modules.conf si noyau 2.4


#8

si tu utilise dhcp pour recevoir ton adresse ip et ben tu doit ajouter cela a ton fichier de conf de dhcp:

host nom_de_ta_machine {
hardware ethernet 00:00:4C:71:46:68;
fixed-address 192.168.1.5; #adresse ip fixe que tu veux recevoir
}

pour la valeur de hardware ethernet,tu fait un ifconfig et c 'est au nivau de HWaddr que tu aura la valeur a mettre.

j’espere que ca vas marche pour toi.

peace


#9

ok

avec ca je fais correspondre une address IP a l’adress MAC de ma carte !

g donc fais corrrespondre l’address 192.168.0.2
mais j’ai toujours une address attribué par DHCP :confused:


#10

de quel type est ton routeur ? linux ou du type netgear, netopia, olitec … ?

si tu veux utiliser une ip statique sur ta debian, ton premier post etait correct, a savoir que tu dois configurer ton fichier /etc/network/interfaces avec :

auto eth0
iface eth0 inet static
address 192.168.0.2
netmask 255.255.255.0
network 192.168.0.0
broadcast 192.168.0.255
gateway 192.168.0.1

ensuite un coup de /etc/init.d/networking restart et fais un netstat -rn afin de t’assurer que la route vers ton routeur est bien la :

Table de routage IP du noyau
Destination Passerelle Genmask Indic MSS Fenêtre irtt Iface
192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
0.0.0.0 192.168.0.1 0.0.0.0 UG 0 0 0 eth0

Bien sur, ca implique que ce soit ton routeur qui te connecte (xdsl ou autre), et non pas ton PC directement (pppoeconf)


#11

ok

ca marche komme ca !
“networking restart”

merci a tous

a tres bientot :wink: