Pb vsftpd


#1

salut!

Voici mon fichier vsftpd:

Standalone mode

listen=YES
listen_port=21
chroot_local_user=YES
max_clients=50
max_per_ip=30

Access rights

anonymous_enable=NO
local_enable=YES
write_enable=YES
local_umask=022
pasv_enable=YES

Security

guest_enable=NO
ls_recurse_enable=NO

Features

ascii_download_enable=YES
ascii_upload_enable=YES

Performance

data_connection_timeout=300
accept_timeout=60
connect_timeout=60
pasv_min_port=21000
pasv_max_port=21010

Lorsque sur mon serveur je fais ftp localhost

Il met met connection refusée.
Merci


#2

AVANT de sécuriser avec des anonymous_enable=NO et guest_enable=NO, est ce que tu as au moins essayé simplement de faire marcher ton serveur avec les paramètres de base ?
est ce qu’avec le fichier de base, avant même que tu y touches, ca marche ?
PS: est ce necessaire d’ouvrir un nouveau fil a chaque fois que tu poste, même quand c’est sur un sujet que tu as déja ouvert deux fois ? :wink:


#3

je veux faire un serveur ftp avec 3 utilisateurs enfermé dans le répertoire perso et seuelemnt cela.
Aucun autre accès doit etre possible.

voici mon fichier:

#L’anonnyme
anonymous_enable=no
anon_upload_enable=no
anon_mkdir_write_enable=no
anon_other_write_enable=no

local_enable=YES
write_enable=YES
local_umask=022
dirmessage_enable=YES
xferlog_enable=YES
connect_from_port_20=YES

#chown_uploads=YES
#chown_username=whoever
#xferlog_file=/var/log/vsftpd.log
xferlog_std_format=YES
#idle_session_timeout=600
#nopriv_user=ftpsecure
#async_abor_enable=YES
ascii_upload_enable=no
ascii_download_enable=YES
ftpd_banner=Welcome to RJC FTP service.
#deny_email_enable=YES
#banned_email_file=/etc/vsftpd.banned_emails
chroot_list_enable=YES
chroot_local_user=yes
chroot_list_file=/etc/vsftpd/vsftpd.chroot_list
ls_recurse_enable=no
pam_service_name=vsftpd
userlist_enable=YES
#enable for standalone mode
listen=YES
tcp_wrappers=YES

Le pb c’est comment faire pour dire au ftp qu’il y a que le groupe ftp que j’ai créer qui peux accèderau ftp?
Car les utilisateurs avec cette config peuvent juste se connecter si ils appartiennet au groupe users.
De plus avec cette config sont ils bien enfermé dans leur rép perso.

Voila mon fichier vsftpd.chroot_list:

ftpaur
ftprjc
ftppublic

Puis autre qeustion:

j’ai déclaré anonymous_enable=no
faut il aussi déclarer les autres option relatives a l’anonymous si je déclare celle ci.

Merci