Pépin Wifi - chipset ath10k


#1

Je viens de réinstaller un portable. Je n’ai pas de wifi : la carte n’est pas reconnue.

# ip link set wlan0 up
Cannot find device "wlan0"

# lspci -nnk | grep -iA2 net
01:00.0 Network controller [0280]: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter [168c:003e] (rev 32)
Subsystem: Foxconn International, Inc. QCA6174 802.11ac Wireless Network Adapter [105b:e09d]
Kernel driver in use: ath10k_pci
Kernel modules: ath10k_pci

# uname -a
Linux user 4.19.0-6-amd64 #1 SMP Debian 4.19.67-2 (2019-08-28) x86_64 GNU/Linux

Problème : le kernel 4.19 contient le module ath10k. Pourquoi mon chipset wifi n’est-il pas reconnu ?

Ou est-ce à dire que ce driver n’est pas adapté à ce chipset ?


#2

Bonjour,
Question toute bête, il paraît que ça arrive très souvent sous Linux, ton wifi est-il bien actif ?
Chez moi, c’est touche Fn+F6…


#3

Oui, c’est vrai : ça m’était arrivé aussi, dans le temps.

Malheureusement, ce n’est pas le cas ce coup-ci : j’ai bien trouvé la touche d’activation du wifi, elle passe de « mode avion » à « wifi activé » sans que cela change quoi que ce soit, malheureusement.


#4

Par ailleurs, il y a un truc que je ne pige pas : iw est installé…

iw/stable,now 5.0.1-1 amd64  [installé, automatique]
outils pour configurer les cartes réseau sans fil sous Linux

… mais, en tant que simple commen en tant que super utilisateur, je n’ai pas accès à la commande iw, ni à iwlist, iwconfig


#5

Ah, regarde peut-être ici si tu es sous Buster !


#6

J’ai trouvé : il me manquait le paquet firmware-atheros. Le lien cité dans le premier post m’a induit en erreur.

# apt install firmware-atheros

a suffi à régler le pépin. Attention : ce paquet n’est pas libre ; il faut modifier ses sources en conséquence.


Boot sur nouvelle installation