Peripheriques / scanner / apn / camescope


#1

Bonjour.
J’essaye d’utiliser mes peripheriques.
J’ai installé gtkam et gphoto2 pour mon apn. Quand j’ouvre gtcam, je selectionne mon appareil dans la liste (kodak dx 3600) mais j’ai un message: “impossibl e d’initialiser l’appareil”. Cet appareil est sur le port usb, qui fonctionne puisque la souris fonctionne. Si j’ai bon souvenir cet appareil fonctionnait sans probleme avec gtkam sous la KLA.

Pour le scaner idem avec xsane “peripherique occupé”…

Pour le camescope il est sur un port firwire sous kino j’ai le message:
ATTENTION raw 1394 kernel module non chargé ou echec de lecture/ecriture sur dev/raw1394

Voila voila…

Si quelqu’un a une idée sur la question.


#2

Bonjour CAPUCINE,

J’ai eu ce problème avec mon appareil photo, cela provenait de la configuration de l’appareil, tu dois avoir la possibilité de le régler comme une clé USB.

Pour ce qui est du scanner, je ne sais pas, je n’ai pas encore eu l’occasion de tester la mienne. (Il va falloir que je m’en occupe des que possible)

Pour le camescope, c’est une question de droit. Il faut déja t’assurer que les modules :

ohci 1394
ieee 1394
raw 1394

sont bien chargé, avec la commande “lsmod”

Si c’est bon, tu fais :

chmod a+rw /dev/raw1394

et tu devrais y avoir accès en simple user (si mes souvenirs sont bon)

Bon courage.

Jean :wink:


#3

Je ne sais pas quelle reponse je dois avoir mais cela ne doit pas etre terrible…

[code]capucine@capucine:~$ lsmod ohci 1394
Usage: lsmod
capucine@capucine:~$ lsmod ieee 1394
Usage: lsmod
capucine@capucine:~$ lsmod raw 1394
Usage: lsmod
capucine@capucine:~$

[/code]


#4

Cela me parait bon.

Tu trouveras plus ample explications sur cette page qui ma bien servi au moment ou je me suis mis un peu à la video.

http://www.funix.org/fr/linux/main-linux.php3?ref=montage&page=menu

Il y a plusieurs logiciels de montage, tu clic sur kino et tu devrais trouver ton bonheur. :laughing:

Jean :smiley:


#5

Pour le firewire, je te file un petit extrait de mes notes d’installation:
Pour contrôler que tu aies les modules à disposition pour ton kernel:

burp:/usr/src/linux# modprobe -l | grep iee
/lib/modules/2.6.14perso-20-12-05/kernel/drivers/ieee1394/sbp2.ko
/lib/modules/2.6.14perso-20-12-05/kernel/drivers/ieee1394/raw1394.ko
/lib/modules/2.6.14perso-20-12-05/kernel/drivers/ieee1394/ohci1394.ko
/lib/modules/2.6.14perso-20-12-05/kernel/drivers/ieee1394/ieee1394.ko
/lib/modules/2.6.14perso-20-12-05/kernel/drivers/ieee1394/eth1394.ko
/lib/modules/2.6.14perso-20-12-05/kernel/drivers/ieee1394/dv1394.ko
/lib/modules/2.6.14perso-20-12-05/kernel/drivers/ieee1394/cmp.ko
/lib/modules/2.6.14perso-20-12-05/kernel/drivers/ieee1394/amdtp.ko
/lib/modules/2.6.14perso-20-12-05/kernel/drivers/ieee1394/video1394.ko
burp:/usr/src/linux#

Si ca ressemble à ça, c’est ok…
Ensuite, tu charges les modules:

modprobe ohci1394 ieee1394 raw1394 video1394

Capture en tant que simple utilisateur:

burp:~# ls -l /dev/raw*
crw-rw----  1 root root 171, 0 2006-01-07 22:08 /dev/raw1394
burp:~# chmod 666 /dev/raw*
burp:~# ls -l /dev/raw*
crw-rw-rw-  1 root root 171, 0 2006-01-07 22:08 /dev/raw1394
burp:~#

Et ensuite tu peux lancer kino et metttre ton camescope en mode lecture. Le résultat de ta capture devrait s’afficher dans kino
Attention, le format .dv est extrêmement gourmand en espace disque ! :wink:


#6

Pour le scanner, j’ai les paquets suivants installés chez moi :

libsane
sane-utils
xsane
xsane-common

Pour voir si sane reconnait ton matériel :

Pour identifier ton modèle et son adresse :

Test d’utilisation avec scanimage :

En graphique, tu peux utiliser xsane.

Fichiers de configuration de “sane”

Fichiers de configuration de “sane” par constructeur


#7

[quote=“CAPUCINE”]Je ne sais pas quelle reponse je dois avoir mais cela ne doit pas etre terrible…

[code]capucine@capucine:~$ lsmod ohci 1394
Usage: lsmod
capucine@capucine:~$ lsmod ieee 1394
Usage: lsmod
capucine@capucine:~$ lsmod raw 1394
Usage: lsmod
capucine@capucine:~$

[/code][/quote]

essaie plutot:

(ils sont méchamment distraits les autres :open_mouth: )


#8

quote=“JeanTux”

J’ai eu ce problème avec mon appareil photo, cela provenait de la configuration de l’appareil, tu dois avoir la possibilité de le régler comme une clé USB. [/quote]

je confirme, c’est la méthode la plus simple et la plus rapide; faire détecter ton app. photo comme périphérique de stockage externe usb (une clée usb en somme).

avec Gnome, c’est complétement transparent :wink:
il veut même importer les photos automatiquement le coco :smiley:


#9

Pas moi M’sieur ! :imp:

Ouaip, c’est quelque part dans les menus de l’appareil, il faut un peu chercher…


#10

Ou alors dans la notice. Encore fallait il savoir. Mon ancien appareil était reconnu tout de suite, alors que celui qui ma été offert pour noel me faisait des misères. :laughing:

Le principal est que cela fonctionne.

Jean :wink:


#11

Je vais essayer ces manips…
Concernat l’APN je ne pense pas avoir de réglages à faire dessus car sous win il est reconnu comme un disque amovible, et je n’ai modifié aucun réglage depuis le test sous KLA.
Si je savais ce qu’il fallait regarder je pourrait remettre la kla en route pour voir la “configuration” de l’APN et su scanner…


#12

De mon côté, je constate que mon scanner n’est pas reconnu non plus. Pourtant, si je me souviens bien sous Ubuntu elle fonctionnait. (A moins que c’était sous Mepis, car à un moment j’ai testé les deux !)
C’est une OfficeJet G55 de chez HP. Il doit y avoir quelque chose d’autre à ajouter. Car j’ai les paquets suivant d’installé.

libsane
sane-utils
xsane
xsane-common

Quand pensez-vous?

Jean :unamused:


#13

bonjour,
en rajoutant le paquet hpoj?


#14

J’ai rajouté hpoj, puis hpoj-xojpanel, mais cela ne donne rien de plus. Même après redémarrage. :unamused:

Dommage.

Jean :wink:


#15

j’ai la même chose que toi, plus sane, et libsane-extras


#16

[quote=“JeanTux”]J’ai rajouté hpoj, puis hpoj-xojpanel, mais cela ne donne rien de plus. Même après redémarrage. :unamused:

Dommage.

Jean :wink:[/quote]

Que te renvoient les tests que j’indique plus haut ?


#17

Tu as une imprimante toute en un aussi?

C’est peut être la cause de mon problème?

Jean :unamused:


#18

code]libsane
sane-utils
xsane
xsane-common [/code]
Pour moi c’est bon…

[code]capucine@capucine:~$ lsmod | grep "1394"
eth1394 19976 0
ohci1394 32004 0
ieee1394 100408 3 eth1394,ohci1394,sbp2

capucine@capucine:~$
[/code]

La ca donne ca et je ne sais pas ce que cela veut dire…
Mais revenons au scanner:

[code]capucine@capucine:~$ sane-find-scanner

sane-find-scanner will now attempt to detect your scanner. If the

result is different from what you expected, first make sure your

scanner is powered up and properly connected to your computer.

No SCSI scanners found. If you expected something different, make sure that # you have loaded a SCSI driver for your SCSI adapter.

Also you need support for SCSI Generic (sg) in your operating system.

If using Linux, try “modprobe sg”.

No USB scanners found. If you expected something different, make sure that

you have loaded a driver for your USB host controller and have installed a

kernel scanner module.

Not checking for parallel port scanners.

Most Scanners connected to the parallel port or other proprietary ports

can’t be detected by this program.

You may want to run this program as root to find all devices. Once you

found the scanner devices, be sure to adjust access permissions as

necessary.

capucine@capucine:~$

[/code]

La je comprend mais cela ne me plait pas!


#19

[quote=“CAPUCINE”][code]capucine@capucine:~$ sane-find-scanner

sane-find-scanner will now attempt to detect your scanner. If the

result is different from what you expected, first make sure your

scanner is powered up and properly connected to your computer.

No SCSI scanners found. If you expected something different, make sure that # you have loaded a SCSI driver for your SCSI adapter.

Also you need support for SCSI Generic (sg) in your operating system.

If using Linux, try “modprobe sg”.

No USB scanners found. If you expected something different, make sure that

you have loaded a driver for your USB host controller and have installed a

kernel scanner module.

Not checking for parallel port scanners.

Most Scanners connected to the parallel port or other proprietary ports

can’t be detected by this program.

You may want to run this program as root to find all devices. Once you

found the scanner devices, be sure to adjust access permissions as

necessary.

capucine@capucine:~$

[/code]

La je comprend mais cela ne me plait pas![/quote]

qu’as tu comme scanner?

le mien (un HP 4600 pour le CITER) n’est pas pris en charge par sane et ne le sera pas tant que HP (pour le citer ENCORE) ne proposera pas une interface de communication open source (ou qu’un genie effectue un reverse engenering sur le closed driver) …
bref, HP (oui, HP!), que du bonheur …

pour voir si le tiens est pris en charge:

sane-project.org/cgi-bin/driver.pl

et si jamais un coco de chez HP me lit en ce moment, je rapelle au passage cette page rédigée par l’equipe de sane destinée aux constructeurs de scanner: sane-project.org/manufacturers.html

@+


#20

Voila le résultat des tests:

[quote]jeantux@debian:~$ sane-find-scanner

sane-find-scanner will now attempt to detect your scanner. If the

result is different from what you expected, first make sure your

scanner is powered up and properly connected to your computer.

No SCSI scanners found. If you expected something different, make sure that

you have loaded a kernel SCSI driver for your SCSI adapter.

Also you need support for SCSI Generic (sg) in your operating system.

If using Linux, try “modprobe sg”.

No USB scanners found. If you expected something different, make sure that

you have loaded a kernel driver for your USB host controller and have setup

the USB system correctly. See man sane-usb for details.

Not checking for parallel port scanners.

Most Scanners connected to the parallel port or other proprietary ports

can’t be detected by this program.

You may want to run this program as root to find all devices. Once you

found the scanner devices, be sure to adjust access permissions as

necessary.[/quote]

puis:

[quote]jeantux@debian:~$ scanimage -L

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).[/quote]

Voila ce que j’ai sur HP dans /etc/sane.d/dll.conf:

[quote]hp
hpsj5s
hp4200
hp5400[/quote]

Rien au sujet des pilotes OfficeJet

Jean :wink: