Perl: warning: Setting locale failed


#1

Salut a tous,

j’ai un souci avec ma Sarge.
A chaque fois que j’utilise apt, j’ai le message suivant:

[quote]perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = “en_US:en_GB:en”,
LC_ALL = (unset),
LANG = "en"
are supported and installed on your system.
perl: warning: Falling back to the standard locale (“C”).
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory[/quote] J’ai fait un dpkg-reconfigure locales en en choisissant que [quote]en ISO-8859-1[/quote](distrib en anglais).

Pourtant, j’ai toujours des problemes lors de l installation de nmap par exemple:

The following NEW packages will be installed: nmap 0 upgraded, 1 newly installed, 0 to remove and 3 not upgraded. Need to get 575kB of archives. After unpacking 1933kB of additional disk space will be used. Get:1 http://ftp.uk.debian.org stable/main nmap 3.81-1 [575kB] Fetched 551kB in 10s (52.0kB/s) perl: warning: Setting locale failed. perl: warning: Please check that your locale settings: LANGUAGE = "en_US:en_GB:en", LC_ALL = (unset), LANG = "en" are supported and installed on your system. perl: warning: Falling back to the standard locale ("C"). locale: Cannot set LC_CTYPE to default locale: No such file or directory locale: Cannot set LC_MESSAGES to default locale: No such file or directory locale: Cannot set LC_ALL to default locale: No such file or directory Selecting previously deselected package nmap. (Reading database ... 90423 files and directories currently installed.) Unpacking nmap (from .../archives/nmap_3.81-1_i386.deb) ... Setting up nmap (3.81-1) ...

J’ai fait un dpkg-reconfigure locales en ne selectionnant que [quote]en ISO-8859-1[/quote]

Une idee ?

Merci


#2

slt,
Fonction recherche, cette erreur a été traité plusieurs fois :laughing:.

forum.debian-fr.org/viewtopic.ph … ight=lcall


#3

Salut,

l’erreur a ete traitee plusieurs fois mais pas de reponses claires…
Tout le monde bataille avec ce probleme.

Voici mon fichier /etc/profile:

[code]gbdeeunil0001:/etc# cat profile

/etc/profile: system-wide .profile file for the Bourne shell (sh(1))

and Bourne compatible shells (bash(1), ksh(1), ash(1), …).

if [ “id -u” -eq 0 ]; then
PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11"
else
PATH="/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/games"
fi

if [ “$PS1” ]; then
if [ “$BASH” ]; then
PS1=’\u@\h:\w$ ‘
else
if [ “id -u” -eq 0 ]; then
PS1=’# ‘
else
PS1=’$ '
fi
fi
fi

export PATH

umask 022
gbdeeunil0001:/etc#[/code]
Voici mon fichier /etc/environment:

gbdeeunil0001:/etc# cat environment LANG="en" LANGUAGE="en_US:en_GB:en" gbdeeunil0001:/etc#

Voici le resultat de l’execution de la commande locale

gbdeeunil0001:/etc# locale locale: Cannot set LC_CTYPE to default locale: No such file or directory locale: Cannot set LC_MESSAGES to default locale: No such file or directory locale: Cannot set LC_ALL to default locale: No such file or directory LANG=en LC_CTYPE="en" LC_NUMERIC="en" LC_TIME="en" LC_COLLATE="en" LC_MONETARY="en" LC_MESSAGES="en" LC_PAPER="en" LC_NAME="en" LC_ADDRESS="en" LC_TELEPHONE="en" LC_MEASUREMENT="en" LC_IDENTIFICATION="en" LC_ALL= gbdeeunil0001:/etc#

Une idee ?
Merci


#4

slt,

chez moi :

unter#locale

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "fr_FR",
        LC_ALL = "fr_FR",
        LC_MESSAGE = "fr_FR",
        LANG = "fr_FR@euro"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory

unter#grep ^fr /etc/locale.gen
 fr_FR@euro ISO-8859-15

unter#cat /etc/environment
LANGUAGE="fr_FR:fr:en_GB:en"
LANG=fr_FR@euro

Je re fait un locale:

unter#locale

locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=fr_FR@euro
LC_CTYPE="fr_FR"
LC_NUMERIC="fr_FR"
LC_TIME="fr_FR"
LC_COLLATE="fr_FR"
LC_MONETARY="fr_FR"
LC_MESSAGES="fr_FR"
LC_PAPER="fr_FR"
LC_NAME="fr_FR"
LC_ADDRESS="fr_FR"
LC_TELEPHONE="fr_FR"
LC_MEASUREMENT="fr_FR"
LC_IDENTIFICATION="fr_FR"
LC_ALL=fr_FR 

Oops passe pas…


unter#dpkg-reconfigure locales
 perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "fr_FR",
        LC_ALL = "fr_FR",
        LC_MESSAGE = "fr_FR",
        LANG = "fr_FR@euro"
   are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_CTYPE to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_MESSAGES to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_ALL to default locale: No such file or directory
Generating locales...
        fr_FR.ISO-8859-15@euro... done
        en_US.ISO-8859-1... done
        fr_FR.ISO-8859-1... done
        fr_FR.UTF-8@euro... done
Generation complete. 

Je refais un locale

unter#locale
 LANG=fr_FR@euro
LC_CTYPE="fr_FR"
LC_NUMERIC="fr_FR"
LC_TIME="fr_FR"
LC_COLLATE="fr_FR"
LC_MONETARY="fr_FR"
LC_MESSAGES="fr_FR"
LC_PAPER="fr_FR"
LC_NAME="fr_FR"
LC_ADDRESS="fr_FR"
LC_TELEPHONE="fr_FR"
LC_MEASUREMENT="fr_FR"
LC_IDENTIFICATION="fr_FR"
LC_ALL=fr_FR 

Et la c’est bon. C’est un mini bug chez Debian pour plus d’info lists.debian.org/debian-glibc/20 … 00168.html


#5

Dans ton dpkg-reconfigure locales, tu as slectionne quoi ?

Ici j’ai beau effectuer autant de dpkg-reconfigure locales que je veux, le probleme reste…


#6

lists.debian.org/debian-glibc/20 … 00168.html


#7

J’ai bien vu le lien vers la liste mais comme je disais dans le premier post, ma distrib est en anglais.
Lorsque je fais un dpkg-reconfigure locales et que je selectionne [quote]en ISO-8859-1[/quote] le problème n’est pas resolu…


#8

slt,

Pourtant sur la liste pointé par le lien, ou sur mon poste tout est écrit.