Perte de reseau wifi comme filaire _ Debian bookworm

Tags: #<Tag:0x00007fb99b27aa90>

Bonjour à tous, depuis ce matin impossible pour moi de me connecter en wifi comme en filaire, aucune manip de faite la veille mis à part une mise à jour.
En regardant sur différent forum, j’ai trouvé une solution qui fonctionne pour le wifi et filaire mais qui ne tient pas, à chaque reboot, je dois recommencer.

solution trouvé :

ip link set wlp1s0 down
ip link set wlp1s0 up
dhclient wlp1s0

Avez-vous une idée de quoi cela peut-il venir svp ?

ip -c a (j’ai copié seulement les première ligne)

lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
enp2s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
wlp1s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
OS: Debian GNU/Linux bookworm/sid x86_64 
Kernel: 5.15.0-2-amd64 
Packages: 3265 (dpkg) 
Shell: bash 5.1.12

Il y avait quoi dans ta mise à jour ?

La prochaine fois regarde si le renouvellement de dhcp ne suffit pas pour récupérer une ip plutôt que de descendre l’interface.

Bonjour, j’ai pas fait attention a ce que contenait la mise à jour.

J’ai renouvelé le dhcp mais idem, ça fonctionne mais je doit recommencer à chaque démarrage.

commande exécuté :

dhclient -r
dhclient

Bonjour et bienvenue sur le forum,

Peux-tu nous préciser comment tu configures ton réseau en temps normal ? Tu as un gestionnaire avec une interface graphique ou avec un outil en ligne de commande ?
Est-ce que tu utilises la mise en veille ou la mise en veille prolongée sur cette machine ?

Bonjour, c’est une configuration via une interface graphique, je n’ai pas fait grand chose à part entrer les identifiants.
Je n’utilise pas de veille, lorsque j’ai fini, j’éteins l’ordinateur.

Est-ce que ton gestionnaire de réseau indique que la connexion est établie ou pas ?
Qu’indique le retour de la commande ip a juste après la tentative de ton gestionnaire de réseau, qu’elle soit réussie ou non ?

Le gestionnaire indique que la connexion est établie, il détecte bien la box et indique connecté. Mais impossible de mettre en route le VPN, mail ou de visionner une page internet, ça m’indique qu’il y a aucune connexion.
voila le retour de ip a avant un dhclient -r :

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp2s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether 94:57:a5:eb:31:0d brd ff:ff:ff:ff:ff:ff
3: wlp1s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 60:6d:c7:1f:cc:8e brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.19/24 brd 192.168.1.255 scope global dynamic noprefixroute wlp1s0
       valid_lft 85591sec preferred_lft 85591sec
    inet6 2a01:cb05:5c1:b800:8680:a49e:ef47:4d4d/64 scope global temporary dynamic 
       valid_lft 1795sec preferred_lft 595sec
    inet6 2a01:cb05:5c1:b800:626d:c7ff:fe1f:cc8e/64 scope global dynamic mngtmpaddr noprefixroute 
       valid_lft 1795sec preferred_lft 595sec
    inet6 fe80::626d:c7ff:fe1f:cc8e/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
4: ipv6leakintrf0: <BROADCAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default qlen 1000
    link/ether ca:90:f0:b3:b8:bf brd ff:ff:ff:ff:ff:ff
    inet6 fdeb:446c:912d:8da::/64 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::dc23:dda6:eb28:8164/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
5: docker0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default 
    link/ether 02:42:b6:a0:9f:03 brd ff:ff:ff:ff:ff:ff
    inet 172.17.0.1/16 brd 172.17.255.255 scope global docker0
       valid_lft forever preferred_lft forever

et le retour de ip a après un dhclient (connexion rétabli) :

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp2s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether 94:57:a5:eb:31:0d brd ff:ff:ff:ff:ff:ff
3: wlp1s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 60:6d:c7:1f:cc:8e brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.19/24 brd 192.168.1.255 scope global dynamic wlp1s0
       valid_lft 86397sec preferred_lft 86397sec
    inet6 2a01:cb05:5c1:b800:8680:a49e:ef47:4d4d/64 scope global temporary dynamic 
       valid_lft 1801sec preferred_lft 601sec
    inet6 2a01:cb05:5c1:b800:626d:c7ff:fe1f:cc8e/64 scope global dynamic mngtmpaddr noprefixroute 
       valid_lft 1801sec preferred_lft 601sec
    inet6 fe80::626d:c7ff:fe1f:cc8e/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
4: ipv6leakintrf0: <BROADCAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default qlen 1000
    link/ether ca:90:f0:b3:b8:bf brd ff:ff:ff:ff:ff:ff
    inet6 fdeb:446c:912d:8da::/64 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::dc23:dda6:eb28:8164/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
5: docker0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default 
    link/ether 02:42:b6:a0:9f:03 brd ff:ff:ff:ff:ff:ff
    inet 172.17.0.1/16 brd 172.17.255.255 scope global docker0
       valid_lft forever preferred_lft forever

Ah, mais ta machine a une adresse IP en double couche avant ta manipulation sur le client DHCP.
Essaie de redémarrer ta machine et donne-nous le retour des commandes suivantes :

  • ip r
  • ip -6 r
  • cat /etc/resolv.conf

Voici le retour des commandes :

:~$ ip r
default via 192.168.1.1 dev wlp1s0 proto dhcp metric 600 
169.254.0.0/16 dev wlp1s0 scope link metric 1000 
172.17.0.0/16 dev docker0 proto kernel scope link src 172.17.0.1 linkdown 
192.168.1.0/24 dev wlp1s0 proto kernel scope link src 192.168.1.19 metric 600 
:~$ ip -6 r
::1 dev lo proto kernel metric 256 pref medium
2a01:cb05:5c1:b800::/64 dev wlp1s0 proto ra metric 600 pref medium
fdeb:446c:912d:8da::/64 dev ipv6leakintrf0 proto kernel metric 95 pref medium
fe80::/64 dev ipv6leakintrf0 proto kernel metric 95 pref medium
fe80::/64 dev wlp1s0 proto kernel metric 600 pref medium
default via fdeb:446c:912d:8da::1 dev ipv6leakintrf0 proto static metric 95 pref medium
default via fe80::6666:24ff:fee6:e37c dev wlp1s0 proto ra metric 600 pref high
:~$ cat /etc/resolv.conf
#Generated by NetworkManager
nameserver ::1

Les mêmes commandes une fois la connexion rétablie (si ça peut servir)

:~# ip r
default via 192.168.1.1 dev wlp1s0 
172.17.0.0/16 dev docker0 proto kernel scope link src 172.17.0.1 linkdown 
192.168.1.0/24 dev wlp1s0 proto kernel scope link src 192.168.1.19 
:~# ip -6 r
::1 dev lo proto kernel metric 256 pref medium
2a01:cb05:5c1:b800::/64 dev wlp1s0 proto ra metric 600 pref medium
fdeb:446c:912d:8da::/64 dev ipv6leakintrf0 proto kernel metric 95 pref medium
fe80::/64 dev ipv6leakintrf0 proto kernel metric 95 pref medium
fe80::/64 dev wlp1s0 proto kernel metric 600 pref medium
default via fdeb:446c:912d:8da::1 dev ipv6leakintrf0 proto static metric 95 pref medium
default via fe80::6666:24ff:fee6:e37c dev wlp1s0 proto ra metric 600 pref high
:~# cat /etc/resolv.conf
domain home
search home
nameserver 192.168.1.1

Voilà, en fait, le problème semble venir de ce qui change entre avant et après l’appel de la commande dhclient -r : le serveur DNS.
Avant le lancement de la commande, il semble que ton système veuille utiliser un serveur DNS local, peut-être que ton serveur local (ou quelque chose qui le lance) a été mis à jour et qu’il n’assure plus sa fonction.
Je ne connais pas très bien NetworkManager, je ne saurais t’aider plus.

Merci de l’orientation en tout cas. Ton aide va me permettre d’orienter mes recherches sur les forums et internet.

J’ai remarqué une chose, je sais pas si ça un lien, je suis pas calé là-dedans :
avec la commande cat /etc/resolv.conf au démarrage :

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
# 127.0.0.53 is the systemd-resolved stub resolver.
# run "resolvectl status" to see details about the actual nameservers.

nameserver ::1

et après un dhclient -r

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
# 127.0.0.53 is the systemd-resolved stub resolver.
# run "resolvectl status" to see details about the actual nameservers.

nameserver 192.168.1.1
nameserver ::1
search home

J’ai pas encore trouvé, je rame un peu à trouver une solution…

salut
essaies simplement de configurer le dns dans ton interface graphique,

sinon

nameserver 192.168.1.1

dans ton /etc/resolv.conf

et
configuration en auto de /etc/network/interfaces

ps aux |egrep -i 'wicd|netcfg|dhcpd|networkmanager|net'

peut montrer des conflits.

J’ai modifié /etc/resolv.conf mais au redémarrage, il est redevenu comme avant.
Concernant le dns dans l’interface graphique, j’ai décoché DNS automatique et saisi l’adresse 192.168.1.1 mais ça change rien.

Voici le retour de

ps aux |egrep -i 'wicd|netcfg|dhcpd|networkmanager|net'

( j’ai pas mis avant/après connexion car rien ne change) :

:~# ps aux |egrep -i 'wicd|netcfg|dhcpd|networkmanager|net'
root          36  0.0  0.0      0     0 ?        I<   07:03   0:00 [netns]
root          37  0.0  0.0      0     0 ?        I<   07:03   0:00 [inet_frag_wq]
root          77  0.0  0.0      0     0 ?        I    07:03   0:00 [kworker/0:2-inet_frag_wq]
root         627  1.7  0.2 260716 20396 ?        Ssl  07:04   0:02 /usr/sbin/NetworkManager --no-daemon
fabienl+    2639  0.1  0.5 85996960 41572 tty2   SLl+ 07:04   0:00 /usr/lib/x86_64-linux-gnu/webkit2gtk-4.0/WebKitNetworkProcess 5 27
fabienl+    2658  0.0  0.1 599912  9672 ?        Sl   07:04   0:00 /usr/libexec/gvfsd-network --spawner :1.2 /org/gtk/gvfs/exec_spaw/2
fabienl+    2680  0.1  0.8 17045548 61336 tty2   Sl+  07:04   0:00 /tmp/.mount_tutano3VkrK3/tutanota-desktop --type=utility --utility-sub-type=network.mojom.NetworkService --field-trial-handle=5585238875421342374,14888495441780005129,131072 --disable-features=SpareRendererForSitePerProcess --lang=fr --service-sandbox-type=none --user-data-dir=/home/fabienl14/.config/tutanota-desktop --shared-files=v8_context_snapshot_data:100
root        3319  0.0  0.0   6348  2388 pts/0    S+   07:06   0:00 grep -E -i wicd|netcfg|dhcpd|networkmanager|net

faut tenter le manuel :
/etc/resolv.conf
et
/etc/network/interfaces

J’avais aussi modifié /etc/network/interfaces mais cela n’a rien changé…

tout ça n’est pas très rigoureux : tu fais plei nde trucs sans expliquer pourquoi ;ni pourquoi ça changerait quelquechose :

  1. dns
    pourquoi as-tu mis 192.168.1.1 ? Et pas une dns qui marche ?
    as-tu redémarré le démon? ( sinon aucune raison que ça change quoi que ce soit )
    As-tu tenté un ping avec adresse ip?
    ping 192.168.1.1
    ping 212.27.48.10
    ping free.fr
ps aux |egrep -i 'wicd|netcfg|dhcpd|networkmanager|net'

il est clair que tu as plein de trucs en conccurence : as -tu essayé sans ? A quoi ça sert? Qui les lance ( fabien ??? , pas normal ) Tu caches ton login donc on ne peut pas suivre.
As-tu essayé en les virant après redémaarge : « kill -9 » puis « net restart »

Des phrases comme

sont vraiment contre productives : tu as un problème que tu ne sais pas résoudre alors donnes nous des indications, qu’as-tu mis dedans?