Perte du SSD à la modification des paramètres bios


#21

Est-ce la partition qui se monte en lecture seule ou sont-ce les permissions sur celle-ci qui ne te permettent pas d’écrire ? Dans le premier cas l’erreur est “système de fichiers en lecture seule” et même root ne peut pas écrire, dans le second l’erreur est “accès refusé” pour un utilisateur normal mais root peut écrire. Pour vérifier :

# montre les options de montage
mount | grep /data
# montre les messages du noyau lors du montage ; remplacer sdXY par le véritable nom de périphérique de la partition et exécuter en root
dmesg |grep sdXY
# montre les permissions sur la racine de la partition
ls -la /data

#22

ohlalal désolée le mail de notification est arrivé dans les spam, j’étais toujours en train d’attendre une réponse…

$ mount | grep /data
/dev/sda3 on /data type ext4 (rw,nosuid,nodev,noexec,relatime,data=ordered)

# dmesg |grep sda3
[    1.512480]  sda: sda1 sda2 sda3
[    2.799838] EXT4-fs (sda3): mounted filesystem with ordered data mode. Opts: (null)

drwxr-xr-x  3 root root  4096 oct.   4 11:06 .
drwxr-xr-x 23 root root  4096 oct.   1 16:09 ..
drwx------  2 root root 16384 oct.   4 11:02 lost+found

Ton message me fait penser que je crois que j’avais déjà eu ce problème.

A l’installation j’ai créé un utilisateur root. Je pense que je ne l’avais pas fait sur l’installation précédente parce que je n’avais pas eu les même problématiques que maintenant :

je ne peux pas taper une commande qui commence par “su” ni faire un “sudo su”, si je veux passer une commande en root je dois d’abord me connecter en root (su root), ce qui ne me semble pas l’idéal. De même lorsque que par exemple je lance une installation, c’est le mot de passe root que je dois saisir, non pas mon mot de passe utilisateur comme j’avais l’habitude. Il ne parait donc pas si étonnant que la partition ait été créée en root avec ces droits là. Je comptais regarder ça quand j’aurais réglé le problème de partition mais ce sont en fait peut-être des problèmes liés?

Est-ce que je peux retrouver maintenant une situation où je n’ai plus à switcher régulièrement en root, et où j’ai les droits sur ma partition?

Merci d’avance.

Edit : j’ai un autre soucis que j’avais aussi déjà eu : le PC freeze parfois sans prévenir. Je n’ai pas ce problème sous windows, et je ne sais pas dans quelle direction chercher.


#23

Les résultats des commandes montrent que la partition est montée en lecture-écriture (rw) et que c’est simplement un problème de permissions dans /data : seul le propriétaire a la permission en écriture, et le propriétaire c’est root (qui n’a pas besoin de permission de toute façon). Il faut donc soit accorder la permission en écriture à tout le monde (avec chmod), soit changer le propriétaire (avec chown).

Pourtant tu te contredis dans la suite de la même phrase puisque “su root” est “une commande qui commence par su” :

Alors, que faut-il croire ?

De toute façon cette commande est aberrante. Autant “sudo” que “su” servent à exécuter une commande ou un shell en tant que root, donc combiner les deux n’a aucun sens.

Apparemment, ton compte utilisateur n’est pas membre du groupe “sudo”, il suffit de l’y ajouter en tant que root, ce qui sera effectif à la prochaine ouverture de session :

adduser ton_identifiant sudo

Non, ça n’a aucun rapport. Il faut avoir les privilèges de root pour créer un système de fichiers dans une partition, et par défaut le propriétaire de la racine est l’utilisateur propriétaire, donc root.


#24

Je suis désolée, je ne m’exprime peut-être pas clairement, mais je n’aime pas trop qu’on me parle comme à une arriérée, même si je débute sous linux.

J’ai confonfu “su” et “sudo” parce que je n’arrivais pas à utiliser sudo et avais l’habitude de passer mes commandes avec afin de ne pas me connecter en root.

J’ai donné “sudo su” en exemple pour essayer d’expliquer mon problème je ne l’utilise pas en principe.

Sudo n’était pas installé, j’avais déjà eu le soucis, je ne me souvenais pas de la solution.

Pour la partition j’ai déjà essayé de mettre /data en 755, ce qui n’a absolument rien donné.

Je vais essayer d’en changer le propriétaire : ça a marché.

Je ne vais pas en demander plus sinon je vais encore avoir l’impression d’être idiote.


#25

Bjr,

Ca se désactive dans windows, je sais plus comment… Ca devrait se trouver sur le web

Mes disques NTFS sont montés ainsi dans le fstab (si ça peut aider) :

UUID=xxxxxxxxxxxx   /point/de/montage     ntfs    defaults,uid=1000,gid=1000    0    0

Puis peut-être avec un :

# chown ton_user:ton_user /point/de/montage

#26

Merci @jul

J’ai trouvé la solution :

J’avais encore un problème de permissions d’exécution pour installer mes jeux. Au final j’ai mis ces options dans le fstab :

defaults,nofail,noauto,x-systemd.automount

Ce sont les options qui m’avaient été données pour une précédente installation (l’option rw que j’avais essayée devait bloquer l’exécution).


#27

sudo et su ne s’utilisent pas de la même façon. L’argument de sudo est une commande, alors que l’argument de su est un nom d’utilisateur. Si tu exécutes su <commande> alors su considère <commande> comme un nom d’utilisateur (qui n’existe pas), et ça provoque une erreur. Pour passer une commande à su, il faut utiliser l’option -c.

755 signifie que seul l’utilisateur propriétaire a la permission en écriture, donc si ce n’est pas toi ça ne sert à rien. Pour donner la permission en écriture à tout le monde il faut mettre 777.