Petites questions sur Ubuntu


#1

Salut tout le monde,

J’ai renoncer a Linux plusieurs fois car aucune version mis a part la knoppix ne marchait sur mon portable … et la c’est Ubuntu marche nikel… donc je suis assez content.

Donc j’ai 2-3 questions de bases a poser :

  1. Je n’arrive pas a monter mes partitions ntfs (hda1 et 4) sur ma distrib.
    J’ai modifié le /etc/fstab en ajoutant :

/dev/hda1 /mnt/nt1 ntfs user,auto,showexec,umask=0,codepage=850;isocharset=iso8859-1 0 0

et même chose pour hda4 sur un point de montage nt2
Quand je boot et que je vois tous les [OK], je vois qu’il n’arrive pas a les monter et quand je vais voir dans mnt j’ai ni nt1 ni nt2

  1. sinon j’ai du faire une connerie dans Firefox … ca fait que je l’ai en russe lol j’arrive pas a changer le langage alors que j’ai installer le pack francais dans options /general/ajouter / FR-FR

  2. la derniere comment trouver des themes pour gnome et changer le logon (ecran de connexion)

Soyez gentils je débute … :wink: Merci d’avance


#2

J’ai vu dans un autre post qu’il fallait faire un mkdir nt1, mkdir nt2 dans /mnt donc j’ai fais ca + sous une fenetre terminal
mount -t ntfs /dev/hda1 /mnt/nt1 et ca me dit : Impossible d’afficher le contenu :confused:


#3

sinon pour les themes gnome j’ai trouver un site pas mal du tout :

gnome-look.org … j’arrive a télécharger un theme mais pas a l’installer


#4

bon réflexe de créer les répertoires, mais aprés, si ton fstab est bien configuré, un simple “mount /mnt/nt1” suffit (pas besoin de préciser quoi que ce soit, il va chercher les arguments. Ca marche même en relatif (mount nt1 quand tu es dans /mnt)
si ca ne marche pas directement, essayes déja sans donner d’option (user,auto, etc…).


#5

je sais pourquoi ca fonctionne pas

jme logue en root sous terminal cd /mnt/nt1 ls -al
et hop j’ai tout mes fichiers de ma partition windows donc mon montage est bon donc c’est un probleme de droit donc maintenant faut que je trouve avec chmod comment faire ca et autoriser mon utilisateur a acceder a tout ca :wink:


#6

c’est l’option users (avec un s) de /etc/fstab, qui fait ca, (en tout cas, chez moi ca marche avec defaults,users,umask=0


#7

Salut j’ai testé sous toutes les coutures ton astuce mais ca ne fonctionne pas chez moi … ne faudrait t il pas mettre mon “utilisateur” dans le groupe root pour quil accèdent a mes partoches windows et si oui ya t il un interet a avoir ce user dans le groupe root :wink:


#8

Non, tu as raison de trouver ridicule l’idée de rajouter ton user à root, mais la, il y a qqchose que je ne comprends pas: ce que je t’ai donné ne peut QUE fonctionner. Eventuellement, peut etre le group disk, mais je n’ai jamais eu besoin de faire ca…
si tu fais un ls -l de /mnt, qu’est ce que tu obtiens pour nt1 et nt2 ?
tu as bien le flag ‘x’ actif partout ? (genre “drwxr-xr-x”) ?


#9

Autant pour moi avec les options defaults,users,umask=0 ca fonctionne …
Merci bien … j’ai redémarré et c’est passé j’ai du mal démonter mes volumes :laughing:

J’ai 2 petites questions pour finir vu que maintenant ca fonctionne :slightly_smiling:

J’ai entendu dire que sous Linux, tu ne pouvais pas écrire sur du FS NTFS ou c’était super déconseillé … Peux tu me dire pourquoi et si oui serait ce intéressant pour moi de les convertir en fat32 ?

Sinon j’ai installé en plus de la Ubuntu sur mon portable … un serveur linux debian sarge en noyau 2.4 … L’installation a réussi a merveille sauf que quand je démarre j’arrive en mode console puis je fais un startx il me dit qu’il ne connait pas la commande (PS : j’ai coché environnements de bureau a l’install) j’ai fait un apt-get install x-window-system-core mais il me manque encore des paquets a mettre

Voilà si je peux me permettre de vous embeter encore un peu plus et d’en savoir plus … merci et bonne continuation


#10

ps : j’ai utiliser ce tuto : guide.andesi.org/html/fxfree.html

et quand je fais startx ca me met un message au début du mode graphique :

En gros il me manque pas mal de choses.

Je tente ca on verra bien


#11

l’ecriture NTFS n’est plus sensée être experimentale, avec les noyaux 2.6, et effectivement, je n’ai pas eu de problèmes (par contre par défaut, il continue à monter les partages ntfs en lecture seule, il faut mettre explicitement une option rw dans fstab, ou faire un ‘mount -o remount,rw’ de ta partoche quand tu veux l’utiliser en rw). Mais je préfère tout de même utiliser ma partition de données en fat32 pour echanger avec windows, car le module vfat est lui vraiment rodé blindé depuis des années. Je garde donc ma partition C: en NTFS pour la sécurité, et les autres en fat32, pour l’échange fiable avec linux. Sinon, avant, la manipulation sur NTFS etait limitée à la modification de fichier existants, et on devait se limiter à des modifications qui ne changeaient pas la taille (pour réécrire sur les mêmes clusters du disque, car le pilote linux ne savait pas modifier la table d’allocation, ni surtout les descripteurs de sécurité). Cette limitation est levée, mais je ne connais pas la fiabilité du module ntfs en RW…

il faut installer un login manager (c’est xdm le générique).
mais installes plutot le paquet kdm (ou gdm si tu préfères gnome), c’est plus joli. Par le jeu des dépendances, il installera tout ce qu’il faut pour démarrer en session graphique, normalement.