PILOTES : Comment savoir lesquels sont installés

Bonjour,

J’ai récupéré le PC d’un ami, il est sous debian.

Ce PC à l’air d’avoir un problème de driver graphique.

Y’a t’il un moyen de savoir quel est le pilote graphique installé?

Je sais pas s’il y a une méthode mais manuellement execute ces commandes et copie les résultat ici:
1- lspci | grep "VGA"
2- aptitude search nvidia ati | grep "i A"
3- cat /etc/X11/xorg.conf | grep "Driver"
4- lsmod

si mesa-utils est installé

[quote=“snake57”]

Y’a t’il un moyen de savoir quel est le pilote graphique installé?[/quote]
Installé ou utilisé ?

Pour utilisé lspci -k ou lspci -v ou lsmod

Pour installé, apt-get ou aptitude ou dpkg.

Merci pour vos indications, alors voici mes réponses :

[quote=“kripteks”]Je sais pas s’il y a une méthode mais manuellement execute ces commandes et copie les résultat ici:
1- lspci | grep "VGA"
2- aptitude search nvidia ati | grep "i A"
3- cat /etc/X11/xorg.conf | grep "Driver"
4- lsmod[/quote]

~$ lspci | grep "VGA" 00:01.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Wrestler [Radeon HD 6320]

~$ aptitude search nvidia ati | grep "i A" i A foomatic-db-compressed-ppds - OpenPrinting printer support - Compressed i A foomatic-db-engine - Support d'imprimante de OpenPrinting - pro i A foomatic-filters - gestion d'imprimantes OpenPrinting - filtr i A keyboard-configuration - réglage de la disposition du clavier pour p libosgi-foundation-ee-java - Java OSGi API - Foundation Execution Envir p libosgi-foundation-ee-java-doc - Javadoc for Java OSGi API - Foundation Exe i A libstartup-notification0 - Bibliothèque pour disposer d'informations i A notification-daemon - démon pour l'affichage de fenêtres passive i A xserver-xorg-video-ati - serveur X X.org - enveloppe pour les pilot

~$ cat /etc/X11/xorg.conf | grep "Driver" cat: /etc/X11/xorg.conf: Aucun fichier ou dossier de ce type

~$ lsmod Module Size Used by parport_pc 22364 0 ppdev 12763 0 lp 17149 0 parport 31858 3 lp,ppdev,parport_pc loop 22641 0 ath3k 12671 0 bluetooth 119406 1 ath3k arc4 12458 2 snd_hda_codec_realtek 188797 1 ath9k 73540 0 ath9k_common 12728 1 ath9k eeepc_wmi 12564 0 asus_wmi 18726 1 eeepc_wmi ath9k_hw 317921 2 ath9k_common,ath9k ath 21370 3 ath9k_hw,ath9k_common,ath9k mac80211 192768 1 ath9k cfg80211 137140 3 mac80211,ath,ath9k psmouse 64455 0 r8169 46980 0 ata_generic 12479 0 sparse_keymap 12760 1 asus_wmi evdev 17562 5 powernow_k8 17573 0 mperf 12453 1 powernow_k8 snd_hda_codec_hdmi 30783 1 pcspkr 12579 0 serio_raw 12931 0 k10temp 12611 0 fglrx 2634044 0 rfkill 19012 3 cfg80211,asus_wmi,bluetooth mii 12675 1 r8169 xhci_hcd 73170 0 snd_hda_intel 26345 0 snd_hda_codec 78031 3 snd_hda_intel,snd_hda_codec_hdmi,snd_hda_codec_realtek snd_hwdep 13186 1 snd_hda_codec snd_pcm 63900 3 snd_hda_codec,snd_hda_intel,snd_hda_codec_hdmi snd_page_alloc 13003 2 snd_pcm,snd_hda_intel snd_seq 45093 0 snd_seq_device 13176 1 snd_seq snd_timer 22917 2 snd_seq,snd_pcm sp5100_tco 12900 0 pata_atiixp 12736 0 ohci_hcd 22467 0 snd 52850 9 snd_timer,snd_seq_device,snd_seq,snd_pcm,snd_hwdep,snd_hda_codec,snd_hda_intel,snd_hda_codec_hdmi,snd_hda_codec_realtek i2c_piix4 12536 0 i2c_core 23876 1 i2c_piix4 ehci_hcd 40215 0 wmi 13243 1 asus_wmi processor 28157 3 powernow_k8 thermal_sys 18040 1 processor usbcore 128498 5 ehci_hcd,ohci_hcd,xhci_hcd,ath3k usb_common 12354 1 usbcore soundcore 13065 1 snd button 12937 1 fglrx ext4 350411 2 crc16 12343 2 ext4,bluetooth jbd2 62015 1 ext4 mbcache 13065 1 ext4 raid1 30714 1 md_mod 87742 2 raid1 sd_mod 36136 6 crc_t10dif 12348 1 sd_mod ahci 24997 3 libahci 22860 1 ahci libata 140589 4 libahci,ahci,pata_atiixp,ata_generic scsi_mod 162372 2 libata,sd_mod

[quote=“misaine”]si mesa-utils est installé

mesa-utils est installé, et pourtant :

~$ glxinfo | grep "version string" Error: unable to open display

~$ lshw -class display -bash: lshw : commande introuvable

Ben un peu les deux enfait, j’ai l’impression que mes pilotes graphiques sont soit mal installé, soit pas installé du tout, soit en conflit.

~$ lspci -k 00:00.0 Host bridge: Advanced Micro Devices [AMD] Family 14h Processor Root Complex Subsystem: ASUSTeK Computer Inc. Device 84e7 00:01.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Wrestler [Radeon HD 6320] Subsystem: ASUSTeK Computer Inc. Device 84e7 Kernel driver in use: fglrx_pci 00:01.1 Audio device: Advanced Micro Devices [AMD] nee ATI Wrestler HDMI Audio [Radeon HD 6250/6310] Subsystem: ASUSTeK Computer Inc. Device 84e7 Kernel driver in use: snd_hda_intel 00:04.0 PCI bridge: Advanced Micro Devices [AMD] Family 14h Processor Root Port Kernel driver in use: pcieport 00:11.0 SATA controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 SATA Controller [IDE mode] (rev 40) Subsystem: ASUSTeK Computer Inc. Device 8496 Kernel driver in use: ahci 00:12.0 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB OHCI0 Controller Subsystem: ASUSTeK Computer Inc. Device 8496 Kernel driver in use: ohci_hcd 00:12.2 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB EHCI Controller Subsystem: ASUSTeK Computer Inc. Device 8496 Kernel driver in use: ehci_hcd 00:13.0 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB OHCI0 Controller Subsystem: ASUSTeK Computer Inc. Device 8496 Kernel driver in use: ohci_hcd 00:13.2 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB EHCI Controller Subsystem: ASUSTeK Computer Inc. Device 8496 Kernel driver in use: ehci_hcd 00:14.0 SMBus: Advanced Micro Devices [AMD] nee ATI SBx00 SMBus Controller (rev 42) Subsystem: ASUSTeK Computer Inc. Device 8496 Kernel driver in use: piix4_smbus 00:14.1 IDE interface: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 IDE Controller (rev 40) Subsystem: ASUSTeK Computer Inc. Device 8496 Kernel driver in use: pata_atiixp 00:14.2 Audio device: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA) (rev 40) Subsystem: ASUSTeK Computer Inc. Device 848d Kernel driver in use: snd_hda_intel 00:14.3 ISA bridge: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 LPC host controller (rev 40) Subsystem: ASUSTeK Computer Inc. Device 8496 00:14.4 PCI bridge: Advanced Micro Devices [AMD] nee ATI SBx00 PCI to PCI Bridge (rev 40) 00:14.5 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB OHCI2 Controller Subsystem: ASUSTeK Computer Inc. Device 8496 Kernel driver in use: ohci_hcd 00:15.0 PCI bridge: Advanced Micro Devices [AMD] nee ATI SB700/SB800/SB900 PCI to PCI bridge (PCIE port 0) Kernel driver in use: pcieport 00:15.1 PCI bridge: Advanced Micro Devices [AMD] nee ATI SB700/SB800/SB900 PCI to PCI bridge (PCIE port 1) Kernel driver in use: pcieport 00:15.2 PCI bridge: Advanced Micro Devices [AMD] nee ATI SB900 PCI to PCI bridge (PCIE port 2) Kernel driver in use: pcieport 00:15.3 PCI bridge: Advanced Micro Devices [AMD] nee ATI SB900 PCI to PCI bridge (PCIE port 3) Kernel driver in use: pcieport 00:16.0 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB OHCI0 Controller Subsystem: ASUSTeK Computer Inc. Device 8496 Kernel driver in use: ohci_hcd 00:16.2 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB EHCI Controller Subsystem: ASUSTeK Computer Inc. Device 8496 Kernel driver in use: ehci_hcd 00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 0 (rev 43) 00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 1 00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 2 00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 3 Kernel driver in use: k10temp 00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 4 00:18.5 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 6 00:18.6 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 5 00:18.7 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 7 03:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01) Subsystem: AzureWave Device 1d89 Kernel driver in use: ath9k 04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06) Subsystem: ASUSTeK Computer Inc. P8P67 and other motherboards Kernel driver in use: r8169 05:00.0 USB controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 04) Subsystem: ASUSTeK Computer Inc. P8P67 Deluxe Motherboard Kernel driver in use: xhci_hcd 06:00.0 USB controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 04) Subsystem: ASUSTeK Computer Inc. P8P67 Deluxe Motherboard Kernel driver in use: xhci_hcd

[code]~$ lspci -v
00:00.0 Host bridge: Advanced Micro Devices [AMD] Family 14h Processor Root Complex
Subsystem: ASUSTeK Computer Inc. Device 84e7
Flags: bus master, 66MHz, medium devsel, latency 32

00:01.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Wrestler [Radeon HD 6320] (prog-if 00 [VGA controller])
Subsystem: ASUSTeK Computer Inc. Device 84e7
Flags: bus master, fast devsel, latency 0, IRQ 18
Memory at c0000000 (32-bit, prefetchable) [size=256M]
I/O ports at f000 [size=256]
Memory at feb00000 (32-bit, non-prefetchable) [size=256K]
Expansion ROM at [disabled]
Capabilities:
Kernel driver in use: fglrx_pci

00:01.1 Audio device: Advanced Micro Devices [AMD] nee ATI Wrestler HDMI Audio [Radeon HD 6250/6310]
Subsystem: ASUSTeK Computer Inc. Device 84e7
Flags: bus master, fast devsel, latency 0, IRQ 40
Memory at feb44000 (32-bit, non-prefetchable) [size=16K]
Capabilities:
Kernel driver in use: snd_hda_intel

00:04.0 PCI bridge: Advanced Micro Devices [AMD] Family 14h Processor Root Port (prog-if 00 [Normal decode])
Flags: bus master, fast devsel, latency 0
Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
I/O behind bridge: 00001000-00001fff
Memory behind bridge: d0100000-d02fffff
Prefetchable memory behind bridge: 00000000d0300000-00000000d04fffff
Capabilities:
Kernel driver in use: pcieport

00:11.0 SATA controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 SATA Controller [IDE mode] (rev 40) (prog-if 01 [AHCI 1.0])
Subsystem: ASUSTeK Computer Inc. Device 8496
Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 19
I/O ports at f190 [size=8]
I/O ports at f180 [size=4]
I/O ports at f170 [size=8]
I/O ports at f160 [size=4]
I/O ports at f150 [size=16]
Memory at feb4f000 (32-bit, non-prefetchable) [size=1K]
Capabilities:
Kernel driver in use: ahci

00:12.0 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB OHCI0 Controller (prog-if 10 [OHCI])
Subsystem: ASUSTeK Computer Inc. Device 8496
Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 18
Memory at feb4e000 (32-bit, non-prefetchable) [size=4K]
Kernel driver in use: ohci_hcd

00:12.2 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB EHCI Controller (prog-if 20 [EHCI])
Subsystem: ASUSTeK Computer Inc. Device 8496
Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 17
Memory at feb4d000 (32-bit, non-prefetchable) [size=256]
Capabilities:
Kernel driver in use: ehci_hcd

00:13.0 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB OHCI0 Controller (prog-if 10 [OHCI])
Subsystem: ASUSTeK Computer Inc. Device 8496
Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 18
Memory at feb4c000 (32-bit, non-prefetchable) [size=4K]
Kernel driver in use: ohci_hcd

00:13.2 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB EHCI Controller (prog-if 20 [EHCI])
Subsystem: ASUSTeK Computer Inc. Device 8496
Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 17
Memory at feb4b000 (32-bit, non-prefetchable) [size=256]
Capabilities:
Kernel driver in use: ehci_hcd

00:14.0 SMBus: Advanced Micro Devices [AMD] nee ATI SBx00 SMBus Controller (rev 42)
Subsystem: ASUSTeK Computer Inc. Device 8496
Flags: 66MHz, medium devsel
Kernel driver in use: piix4_smbus

00:14.1 IDE interface: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 IDE Controller (rev 40) (prog-if 8a [Master SecP PriP])
Subsystem: ASUSTeK Computer Inc. Device 8496
Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 17
I/O ports at 01f0 [size=8]
I/O ports at 03f4 [size=1]
I/O ports at 0170 [size=8]
I/O ports at 0374 [size=1]
I/O ports at f100 [size=16]
Kernel driver in use: pata_atiixp

00:14.2 Audio device: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA) (rev 40)
Subsystem: ASUSTeK Computer Inc. Device 848d
Flags: bus master, slow devsel, latency 32, IRQ 16
Memory at feb40000 (64-bit, non-prefetchable) [size=16K]
Capabilities:
Kernel driver in use: snd_hda_intel

00:14.3 ISA bridge: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 LPC host controller (rev 40)
Subsystem: ASUSTeK Computer Inc. Device 8496
Flags: bus master, 66MHz, medium devsel, latency 0

00:14.4 PCI bridge: Advanced Micro Devices [AMD] nee ATI SBx00 PCI to PCI Bridge (rev 40) (prog-if 01 [Subtractive decode])
Flags: bus master, VGA palette snoop, 66MHz, medium devsel, latency 64
Bus: primary=00, secondary=02, subordinate=02, sec-latency=64

00:14.5 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB OHCI2 Controller (prog-if 10 [OHCI])
Subsystem: ASUSTeK Computer Inc. Device 8496
Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 18
Memory at feb4a000 (32-bit, non-prefetchable) [size=4K]
Kernel driver in use: ohci_hcd

00:15.0 PCI bridge: Advanced Micro Devices [AMD] nee ATI SB700/SB800/SB900 PCI to PCI bridge (PCIE port 0) (prog-if 00 [Normal decode])
Flags: bus master, fast devsel, latency 0
Bus: primary=00, secondary=03, subordinate=03, sec-latency=0
Memory behind bridge: fea00000-feafffff
Capabilities:
Kernel driver in use: pcieport

00:15.1 PCI bridge: Advanced Micro Devices [AMD] nee ATI SB700/SB800/SB900 PCI to PCI bridge (PCIE port 1) (prog-if 00 [Normal decode])
Flags: bus master, fast devsel, latency 0
Bus: primary=00, secondary=04, subordinate=04, sec-latency=0
I/O behind bridge: 0000e000-0000efff
Prefetchable memory behind bridge: 00000000d0000000-00000000d00fffff
Capabilities:
Kernel driver in use: pcieport

00:15.2 PCI bridge: Advanced Micro Devices [AMD] nee ATI SB900 PCI to PCI bridge (PCIE port 2) (prog-if 00 [Normal decode])
Flags: bus master, fast devsel, latency 0
Bus: primary=00, secondary=05, subordinate=05, sec-latency=0
Memory behind bridge: fe900000-fe9fffff
Capabilities:
Kernel driver in use: pcieport

00:15.3 PCI bridge: Advanced Micro Devices [AMD] nee ATI SB900 PCI to PCI bridge (PCIE port 3) (prog-if 00 [Normal decode])
Flags: bus master, fast devsel, latency 0
Bus: primary=00, secondary=06, subordinate=06, sec-latency=0
Memory behind bridge: fe800000-fe8fffff
Capabilities:
Kernel driver in use: pcieport

00:16.0 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB OHCI0 Controller (prog-if 10 [OHCI])
Subsystem: ASUSTeK Computer Inc. Device 8496
Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 18
Memory at feb49000 (32-bit, non-prefetchable) [size=4K]
Kernel driver in use: ohci_hcd

00:16.2 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB EHCI Controller (prog-if 20 [EHCI])
Subsystem: ASUSTeK Computer Inc. Device 8496
Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 17
Memory at feb48000 (32-bit, non-prefetchable) [size=256]
Capabilities:
Kernel driver in use: ehci_hcd

00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 0 (rev 43)
Flags: fast devsel

00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 1
Flags: fast devsel

00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 2
Flags: fast devsel

00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 3
Flags: fast devsel
Capabilities:
Kernel driver in use: k10temp

00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 4
Flags: fast devsel

00:18.5 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 6
Flags: fast devsel

00:18.6 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 5
Flags: fast devsel

00:18.7 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 7
Flags: fast devsel

03:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
Subsystem: AzureWave Device 1d89
Flags: bus master, fast devsel, latency 0, IRQ 16
Memory at fea00000 (64-bit, non-prefetchable) [size=64K]
Capabilities:
Kernel driver in use: ath9k

04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)
Subsystem: ASUSTeK Computer Inc. P8P67 and other motherboards
Flags: bus master, fast devsel, latency 0, IRQ 47
I/O ports at e000 [size=256]
Memory at d0004000 (64-bit, prefetchable) [size=4K]
Memory at d0000000 (64-bit, prefetchable) [size=16K]
Capabilities:
Kernel driver in use: r8169

05:00.0 USB controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 04) (prog-if 30 [XHCI])
Subsystem: ASUSTeK Computer Inc. P8P67 Deluxe Motherboard
Flags: bus master, fast devsel, latency 0, IRQ 18
Memory at fe900000 (64-bit, non-prefetchable) [size=8K]
Capabilities:
Kernel driver in use: xhci_hcd

06:00.0 USB controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 04) (prog-if 30 [XHCI])
Subsystem: ASUSTeK Computer Inc. P8P67 Deluxe Motherboard
Flags: bus master, fast devsel, latency 0, IRQ 19
Memory at fe800000 (64-bit, non-prefetchable) [size=8K]
Capabilities:
Kernel driver in use: xhci_hcd[/code]

Si ces commandes te sont nécessaires, peut-tu me dire ce que je dois taper exactement stp?

Donc voila, est ce que toutes ces lignes vous permettent de savoir ou j’en suis avec mes pilotes? Ce qui est installer, ce qui ne l’est pas. Peut être que vous pouvez même voir ce qui pose problème?!?!

le pilote serait fglrx (driver non-libre) mais il est mal installé.

Misaine, je te remercie de ta réponse.
Peut-tu stp me dire comment tu as vu cela dans les différent log? Histoire que j’en apprenne un peu plus sur le fonctionnement de ma debian?

Y’a t’il un moyen de réinstaller ça bien?
J’imagine qu’il faut le désinstaller et le réinstaller, mais je ne sais pas comment faire. C’est surtout la partie désinstallation qui me pose problème.

je connais très peu les pilotes ati
quelqu’un de plus qualifié pourra sans doute te répondre

[quote]~$ glxinfo | grep "version string"
Error: unable to open display[/quote]

Bonjour,

Est ce que cela est vraiment anormal ?
J’avais l’impression qu’avec les versions actuelles d’Xorg, ce fichier était fabriqué “dynamiquement”.

Cordialement.

Dominique.

Bonjour,

Si j’ai bien compris, tu as une carte ATI Radeon HD 6320.

Cette carte est prise en compte par le driver libre.
Cette remarque car j’ai une très et constante mauvaise expérience des drivers proprio d’ATI - ça n’engage que moi, mais quand même, depuis le temps que ça dure, ça me pousse du côté du libre…

Pour qu’elle fonctionne il faut que le paquet firmware-nonfree soit installé, est-ce le cas?

Il peut ne s’agir que de cela.

@+

[quote]~$ glxinfo | grep "version string"
Error: unable to open display[/quote]
Il a du exécuter la commande sans X (pas sur).

[quote=“kripteks”][quote]~$ glxinfo | grep "version string"
Error: unable to open display[/quote]
Il a du exécuter la commande sans X (pas sur).[/quote]
Kripteks, lorsque j’ai exécuté cette commande, j’avais bien le serveur X qui tournait.

Ce paquet est bel et bien installé.

[quote=“hartza”]Cette carte est prise en compte par le driver libre.
Cette remarque car j’ai une très et constante mauvaise expérience des drivers proprio d’ATI - ça n’engage que moi, mais quand même, depuis le temps que ça dure, ça me pousse du côté du libre…[/quote]
Il me semble que le pilote libre ne gère pas l’accélération 3D et justement, j’ai besoin de l’accélération 3D sur ce poste.

[quote=“misaine”]Est ce que cela est vraiment anormal ?
J’avais l’impression qu’avec les versions actuelles d’Xorg, ce fichier était fabriqué "dynamiquement[/quote]
Effectivement ce fichier est devenu optionnel.

Bon, je connais pas la méthode d’installation d’ati, mais dans le temps c’était avec fglrx.

Dans le wiki de ce site, le seul lien pour ati, est la méthode fainéant: isalo.org/wiki.debian-fr/ind … %C3%A9ants
Donc suffit de suivre la méthode du wiki. Normalement, il fait tout le boulot pour toi, c’est l’automatisation.

Alternative: tu pourras trouver sur internet ou sur ce site ou sur le wiki de debian.org, une méthode d’installation de carte ati, et ouvre un nouveau sujet sur cet partie d’installation si besoin l’est, car continuer d’ici serait du hors du sujet.

ouvre un sujet avec ati et fglrx dans le titre tu auras sûrement plus de réponses

De mon coté je pense que mon driver ati et bien installé mais j’ai de gros ralentisement quand je suis en mode plein écran sur youtube (problème de driver ou flashplayer ??!) du coup je suis allez sur le site pour l’installation de pilote pour les fainéants et du coup voici une erreur :

[code]root@LenovoM9686-67G:/usr/local/bin# wget smxi.org/smxi.zip && unzip smxi.zip
–2014-10-05 19:41:49-- http://smxi.org/smxi.zip
Résolution de smxi.org (smxi.org)… 209.197.72.47
Connexion vers smxi.org (smxi.org)|209.197.72.47|:80…connecté.
requête HTTP transmise, en attente de la réponse…302 Found
Emplacement: http://smxi.org/sm/smxi.zip [suivant]
–2014-10-05 19:41:50-- http://smxi.org/sm/smxi.zip
Réutilisation de la connexion existante vers smxi.org:80.
requête HTTP transmise, en attente de la réponse…200 OK
Longueur: 200195 (196K) [application/zip]
Sauvegarde en : «smxi.zip»

100%[======================================================================================================================>] 200 195 110K/s ds 1,8s

2014-10-05 19:41:52 (110 KB/s) - «smxi.zip» sauvegardé [200195/200195]

Archive: smxi.zip
inflating: sgfxi
inflating: sm-lib-apt-tools
inflating: sm-lib-du-fixes
inflating: sm-lib-kernel
inflating: smxi
inflating: svmi
root@LenovoM9686-67G:/usr/local/bin# sgfxi
ERROR: (250) You must be out of X/Desktop (like KDE, Gnome, Flux, LXDE etc) to run this feature.
Exiting script now.
[/code]

J’aime bien la date des 3 derniers messages du sujet :laughing:

Pour répondre au dernier message, il veut que tu quittes/fermes ton environnement de bureau (gnome, kde, etc) (si tu sais le faire ferme X en entier) et finalement l’utiliser en ligne de commande (via ctrl-alt-f1ou2ou3ou4ouetc).

Tes infos datent probablement de plusieurs années, j’utilise quotidiennement des applications 3D (très) gourmandes via le pilote libre radeon.


Mince, me suis fait eu par la date, ce message date effectivement de plusieurs années…