Plantage aprés grub

Tags: #<Tag:0x00007fae4a123e50> #<Tag:0x00007fae4a123d88>

Salut,
Après installation d’une bulleyes sur un vieux pc i386 en pentium 4, je n’arrive pas à booter et je ne comprend pas trop pourquoi.

je vois bien écris grub à un moment et puis écran noir avec curseur qui clignotte.
Impossibilité de faire quoi que ce soit, même un ctrl alt supp.
les tty ne s’affiche pas, il n’y à rien.

j’ai tenté de démarrer en rescue et je ne vois rien non plus.
j’ai mis ma partition de démarrage sur /dev/sda
dans le dmesg pas d’erreur non plus.

malheureusement je n’arrive pas à avoir d’accès ssh dessus.

Est-ce que le menu de GRUB s’affiche ?

Non juste « Grub »

De façon persistante ou transitoire (combien de temps, que se passe-t-il ensuite) ?

Comment tentes-tu démarrer en rescue sans le menu ?

Non vraiment, grub s’affiche pendant peut être une demi sec, il clignotte juste et après comme j’ai dit écran noir avec curseur clignotant sans action possible avec les touches du clavier.

Pour le menu rescue, je passe par le cd d’install, c’est une vieille bécane et le boot sur usb ne fonctionne pas, donc je passe par le mode avancé du cd d’install, puis graphical rescue mode.
Là, j’ai bien accès à ma partition de root avec tous mes répertoires en r/w, je peux faire des installs aussi et j’ai accès au réseau, mais le ssh ne fonctionne pas, je ne sais pas trop pourquoi.
quand j’essaye de me connecter dessus j’ai un message :
[PTY allocation request failed on channel 0]

je ne sais pas si c’est ça le problème avec l’accès en ssh.

Ah, tu parlais du mode rescue de l’installateur et pas du mode dépannage/recovery dans les options avancées du menu de GRUB du système installé.

Ça pourrait être un problème de gestion du mode graphique par défaut par GRUB, ça m’est déjà arrivé avec certaines machines. On peut forcer GRUB en mode texte pour voir.

Démarrer l’installateur en mode rescue, monter la racine et lancer un shell dessus.
Editer /etc/defaut/grub et décommenter la ligne suivante :

#GRUB_TERMINAL=console

Enregistrer.
Exécuter update-grub pour prendre en compte la modification.
Redémarrer.
Si le menu de GRUB s’affiche, ce ne sera pas très joli mais on verra pour sélectionner un mode graphique qui passe.

Merci Pascal,
Alors, là j’ai bien le menu grub qui s’affiche.
Quand je le laisse démarrer avec son entrée par défaut, il plante au niveau de l’initialisation de la ram.
J’ai testé avec toutes les autres options, rescue ou pas rescue, le pc plante à tous les coups mais à des étapes differentes de l’initialisation et sans message d’erreur …

Décidément un problème chasse l’autre. Il a l’air bien, ce PC.

C’est-à-dire ? Qu’est-ce qui s’affiche ?

En mode rescue, qu’est-ce qui s’affiche en dernier ?

Donc sur cette photo c’est le plantage qu’il y a avec l’option de démarrage par défaut :
IMG_20200427_091235

Là, c’est celle avec son recovery :
IMG_20200427_091402

Là c’est avec le noyau 5.4 :
IMG_20200427_091655

et son recovery :
IMG_20200427_092030

biensûr tout les démarrages finissent par freezer et le serveur ssh ne fonctionne pas.
J’aurais tendence à dire que cela vient du disque peut être qui serait défectueux mais il y avait une lubuntu dessus avant et qui tourné très bien.

  1. Où as-tu vu qu’il était question d’initialisation de la RAM dans tous ces messages ?

  2. Tu ne voudrais pas essayer d’installer Buster (stable) plutôt que Bullseye (testing) ? Sur une aussi vieille machine tu ne devrais pas avoir besoin d’un noyau récent pour prendre en charge le matériel.

  3. La dernière image avec le noyau 5.4 montre que le blocage intervient au moment de l’initialisation du pilote radeon de la carte graphique. C’est peut-être juste une coïncidence, mais tu peux essayer de démarrer en ajoutant le paramètre nomodeset à la ligne de commande du noyau pour le démarrage en mode recovery (à côté de single) dans l’entrée de menu de GRUB.

  4. En tout cas rien ne laisse penser à un problème de disque, il y aurait des messages d’erreur spécifiques.

  1. :slight_smile: oui c’était que sur l’option par défaut et c’était de la ramdisk dont il était question.
    Oui je ne suis pas en permanance à coté de ce poste et je doit faire des aller/retour pour faire les tests.
    Il se peut que mes informations soit legerement modifié pendant le trajet :smiley:

  2. A l’origine c’était pour y installer une lxde et j’aurais preferer avoir un système « récent », je me suis dit « chez debian ils sont capable de tout » mais oui je vais tester ça :slight_smile:

3/4 ok je vais tester ça dans un premier temps

« Initial ram disk » ça ne veut pas dire « initialisation de la RAM » mais « disque mémoire initial ». Aujourd’hui il serait plus exact d’écrire « Initial RAM file system » (« système de fichiers en mémoire initial »). « Initial » car c’est un système de fichiers temporaire qui est monté comme racine initiale avant le montage du véritable système de fichiers racine défini par le paramètre root= du noyau.

Dans ce cas les photos, c’est pratique comme aide-mémoire, même si on ne les poste pas.

1 J'aime

Bon voilà, j’ai pu enfin tester.
et ça fonctionne avec nomodeset, ça démarre.
Du coup, pour démarrer en mode normal je peux faire comment ?

Ça fonctionne avec nomodeset seulement en mode recovery (affichage texte) ou aussi en mode normal (affichage graphique) ?

On peut mettre nomodeset en dur au démarrage mais l’inconvénient de nomodeset est que cela désactive l’accélération graphique et la gestion des résolutions dans le noyau, ce qui dégrade globalement l’affichage. D’autre part certains pilotes Xorg et environnements graphiques ne fonctionnent pas sans ces fonctionnalités.

Maintenant qu’on sait dans quelle direction chercher, il faut commencer par identifier la carte graphique avec lspci. Si c’est un GPU ATI, il peut être nécessaire d’installer les firmwares non libres du paquet firmware-amd-graphics.

Donc j’ai regardé et c’est bien de l’ati, par contre je n’ai pas de paquet firmware-amd-graphics (je crois que la carte c’est une rv250)

Bon alors, c’est bon, j’ai réussi à démarrer.
J’ai trouvé la paquet firmware-amd-graphics, je les installé et fais les mises à jour du système lxde démarre, par contre c’est un peu illisibleIMG_20200505_2036031

Peut-être que la composition de couleurs n’est pas supportée ou buguée.
Essaye de la désactiver dans les paramètres « peaufinage des fenêtres ».

Frenchement je ne vois pas comment atteindre quoi que ce soit dans ces conditions.
j’ai tout juste pu arrivé à me connecter, mais je ne vois strictement rien au reste.

Tu peux essayer de jouer avec les options du pilote Xorg radeon. Pour les informations voir :

man radeon

Quand tu déplaces le pointeur sur les fenêtres cela ne devient pas lisible ?