Plantage avant l'écran de connexion depuis aujourd'hui

Tags: #<Tag:0x00007fd6f7bd2fd8>

Bonjour,
Ce soir impossible de démarrer ma machine. Je passe Grub, vient l’écran noir, le pointeur par dessus puis un écran de plantage avant l’affichage de l’écran de connexion de Debian

"Oh mince quelque chose s'est mal passé. Un problème est survenu et le système ne peut pas récupérer. Contactez un administrateur système."

Je suis sous Testing, je fais des mises à jour quotidiennes. Actuellement j’ai 4 options de boot : Linux 5.14, Linux 5.10 et leurs variantes recovery. Toutes échouent

J’au un chip graphique Intel (IvyBridge) avec pilote libre

Une idée ?

Habituellement je suis en connexion manuelle : je rentre mon mdp et lance GNOME-Wayland

Merci d’avance

1 J'aime

Bonjour,

J’adore ce genre de message qui ne se met pas du tout à la place de l’« administrateur système ».
Essaie de te connecter en console. Si ça fonctionne, essaie de voir les journaux du gestionnaire d’affichage.

Merci :slight_smile:
Je n’ai pas trouvé l’option dans GRUB. Et si je tape c dans Grub, j’obtiens grub> _ qui est propre à Grub si je comprends bien ?

Démarre en « recovery mode », le système te demandera le mot de passe root.

Ben non, en fait les 4 modes cités dans mon 1er post arrivent au même point : apparition du pointeur (et non curseur comme j’ai indiqué) et echec

Ha en fait g une étape en plus en mode recovery : il me dit « impossible d’ouvrir l’accès à la console, le compte root est verrouillé » et me demande de valider ce qui tente de lancer la session graphique

J’utilise sudo, je ne sais plus si le compte root existe

Tu peux démarrer ton PC sur un système live (une clé USB avec une Ubuntu par exemple), et te chrooter sur le système installé sur ton disque dur, ça devrait te permettre de consulter les journaux de démarrage et/ou déverrouiller le compte root.

Merci je vais tenter cela.

J’imagine qu’il n’y a pas moyen de jouer un paramètre de GRUB pour éviter l’interface graphique et obtenir une ligne de commande non root?

Si, tu peux appuyer sur la touche e dans le menu Grub pour entrer en mode édition, puis repère la ligne d’exécution du noyau (elle commence par « linux »), ajoute init=/bin/bash (attention: clavier qwerty) à la fin de cette ligne, puis appuie sur F10 pour exécuter le démarrage, et tu te retrouves avec un shell avec les privilèges root.
Par contre, comme le système n’est pas entièrement démarré (l’init systemd étant « bypassé »), tu n’auras pas un système pleinement fonctionnel, mais tu devrais pouvoir consulter les journaux des démarrages précédents. D’ailleurs, tu pourras aussi activer le compte root et définir son mot de passe (la partition / sera montée en lecture seule, mais tu peux la remonter en lecture/écriture). C’est d’ailleurs un moyen simple et rapide de retrouver l’accès au compte root si on a perdu son mot de passe, et une très bonne raison pour protéger GRUB par un mot de passe et chiffrer son système, si on tient à sécuriser son PC.

Merci je vais commencer par là :slight_smile:

Tu peux aussi lancer le CD d’installation netinst de debian, et aller dans les options avancée et demarrer en « rescue ».
Ca te permet de monter ta partition racine et les autres partitions, et ensuite tu peux aller vois les logs, installer ou desinstaller des package ou refaire le grub, soit par une nouvelle installation, soit par un update

Suivant la méthode de Sputnik93 g tenté un chgt de mot de passe comme ici
https://alphons.io/1105/comment-deverouiller-lutilisateur-root-sous-ubuntu/
Mais « erreur de manipulation du jeton d’authentification
passwd : passwd unchanged »

Puis g lu :
https://www.starnet.com/xwin32kb/error-in-locking-authority-file/

Je suis convaincu que le souci vient de mon disque plein (il l’était presque)

Du coup boot sur USB et allègement du disque ?

C’est une des causes possibles, surtout si tout ton système est installé dans une seule partition.

Oui.

Je galère certains repertoires apparaissent vides depuis une clé USB Ubuntu alors que j’y stocke de gros fichiers du coup pas évident de faire du ménage (d’autant peut être que j’ai déplacé des dossiers xdg Toi aussi bouge tes dossiers xdg-user-dirs (Documents, Images, Musique, Téléchargements, Vidéos) ! - Libre et ouvert ?)
J’ai effacé le dossier tmp et son contenu (3 Go env.) que j’ai recrée ensuite : j’espère que c’est un dossier traditionnel et que ça marchera comme ça ?
En tout cas ça n’a pas permis de redémarrer