Plus de connexion wifi

Tags: #<Tag:0x00007efed4a5c600>

Bonjour,

Je n’ai plus de wifi depuis hier, ça m’a semblé s’arrêter d’un coup sans raison, mais j’avais fait un apt update et apt upgrade un peu avant.
J’utilise d’habitude l’interface graphique, mais elle ne m’affiche simplement plus aucun réseau disponible (alors que j’en vois plusieurs avec mon portable).
J’ai essayé de chercher dans divers forum, sans succès.

(Je précise que j’ai pas trop l’habitude de me servir du terminal.)

# uname -a
Linux bulle 4.19.0-13-amd64 #1 SMP Debian 4.19.160-2 (2020-11-28) x86_64 GNU/Linux

# /sbin/iwconfig
wlp2s0    IEEE 802.11  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=200 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          
lo        no wireless extensions.

enp3s0    no wireless extensions.

# nmcli general
STATE     CONNECTIVITY  WIFI-HW  WIFI    WWAN-HW  WWAN   
connecté  plein         activé   activé  activé   activé

# ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT group default qlen 1000
    link/ether 3c:97:0e:f1:75:4f brd ff:ff:ff:ff:ff:ff
3: wlp2s0: <NO-CARRIER,BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state DORMANT mode DORMANT group default qlen 1000
    link/ether 48:5a:b6:cb:55:d7 brd ff:ff:ff:ff:ff:ff

Bonjour,

as-tu nmtui? pour activer test connexion avec une interface en mode texte?

Merci pour ta réponse. Je viens de tester :

  • dans « Activer une connexion » je ne vois que mon réseau filaire
  • dans « Modifier une connexion » je vois tous les réseaux enregistrés, dont ma box (qui me semble bien parametrée, la case de connexion automatique est cochée) mais je ne peux toujours pas m’y connecter.

Que donnent les commandes :

lshw -class network
lspci

Et dans la réponse de lspci, dans la partie correspondant à ton wifi (s’il apparait), il y a un ID en debut de ligne:

lspci -v -s XX:XX.X

Voilà ce que j’obtient :

# lshw -class network
  *-network                 
       description: Interface réseau sans fil
       produit: BCM43142 802.11b/g/n
       fabriquant: Broadcom Limited
       identifiant matériel: 0
       information bus: pci@0000:02:00.0
       nom logique: wlp2s0
       version: 01
       numéro de série: 48:5a:b6:cb:55:d7
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=wl0 driverversion=6.30.223.271 (r587334) latency=0 multicast=yes wireless=IEEE 802.11
       ressources: irq:17 mémoire:f0500000-f0507fff
  *-network
       description: Ethernet interface
       produit: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       fabriquant: Realtek Semiconductor Co., Ltd.
       identifiant matériel: 0
       information bus: pci@0000:03:00.0
       nom logique: enp3s0
       version: 07
       numéro de série: 3c:97:0e:f1:75:4f
       taille: 100Mbit/s
       capacité: 1Gbit/s
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 duplex=full firmware=rtl8168e-3_0.0.4 03/27/12 ip=192.168.1.40 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       ressources: irq:19 portE/S:2000(taille=256) mémoire:f0404000-f0404fff mémoire:f0400000-f0403fff



# lspci
00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C216 Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C216 Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
00:1c.3 PCI bridge: Intel Corporation 7 Series/C216 Chipset Family PCI Express Root Port 4 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM77 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C216 Chipset Family SMBus Controller (rev 04)
02:00.0 Network controller: Broadcom Limited BCM43142 802.11b/g/n (rev 01)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 07)



# lspci -v -s 02:00.0 
02:00.0 Network controller: Broadcom Limited BCM43142 802.11b/g/n (rev 01)
	Subsystem: Lenovo BCM43142 802.11b/g/n
	Flags: bus master, fast devsel, latency 0, IRQ 17
	Memory at f0500000 (64-bit, non-prefetchable) [size=32K]
	Capabilities: [40] Power Management version 3
	Capabilities: [58] Vendor Specific Information: Len=78 <?>
	Capabilities: [48] MSI: Enable- Count=1/1 Maskable- 64bit+
	Capabilities: [d0] Express Endpoint, MSI 00
	Capabilities: [100] Advanced Error Reporting
	Capabilities: [13c] Virtual Channel
	Capabilities: [160] Device Serial Number 00-00-b6-ff-ff-cb-48-5a
	Capabilities: [16c] Power Budgeting <?>
	Kernel driver in use: wl
	Kernel modules: wl

Il faut que tu installe le package broadcom-sta-dkms via ton interface ethernet.
sudo apt install broadcom-sta-dkms

Il est apaprement déjà installé : « broadcom-sta-dkms est déjà la version la plus récente (6.30.223.271-10) »

Quels ont été les paquets upgradé par la mise à jour?

Je suis pas sure que c’est ce que tu me demandes mais voilà ce que j’ai trouvé dans /var/log/dpkg.log*. Ça correspond à ma dernière maj avant que je perde le wifi.

2021-01-22 08:06:11 startup archives unpack
2021-01-22 08:06:19 upgrade mutt:amd64 1.7.2-1+deb9u4 1.7.2-1+deb9u5
2021-01-22 08:06:19 status half-configured mutt:amd64 1.7.2-1+deb9u4
2021-01-22 08:06:19 status unpacked mutt:amd64 1.7.2-1+deb9u4
2021-01-22 08:06:20 status half-installed mutt:amd64 1.7.2-1+deb9u4
2021-01-22 08:06:20 status triggers-pending mime-support:all 3.60
2021-01-22 08:06:20 status triggers-pending gnome-menus:amd64 3.13.3-9
2021-01-22 08:06:20 status triggers-pending desktop-file-utils:amd64 0.23-1
2021-01-22 08:06:20 status half-installed mutt:amd64 1.7.2-1+deb9u4
2021-01-22 08:06:20 status triggers-pending mime-support:all 3.60
2021-01-22 08:06:20 status triggers-pending man-db:amd64 2.7.6.1-2
2021-01-22 08:06:21 status half-installed mutt:amd64 1.7.2-1+deb9u4
2021-01-22 08:06:21 status unpacked mutt:amd64 1.7.2-1+deb9u5
2021-01-22 08:06:21 status unpacked mutt:amd64 1.7.2-1+deb9u5
2021-01-22 08:06:21 upgrade gstreamer1.0-plugins-bad:amd64 1.10.4-1 1.10.4-1+deb9u1
2021-01-22 08:06:21 status half-configured gstreamer1.0-plugins-bad:amd64 1.10.4-1
2021-01-22 08:06:21 status unpacked gstreamer1.0-plugins-bad:amd64 1.10.4-1
2021-01-22 08:06:22 status half-installed gstreamer1.0-plugins-bad:amd64 1.10.4-1
2021-01-22 08:06:22 status half-installed gstreamer1.0-plugins-bad:amd64 1.10.4-1
2021-01-22 08:06:22 status unpacked gstreamer1.0-plugins-bad:amd64 1.10.4-1+deb9u1
2021-01-22 08:06:23 status unpacked gstreamer1.0-plugins-bad:amd64 1.10.4-1+deb9u1
2021-01-22 08:06:23 upgrade libgstreamer-plugins-bad1.0-0:amd64 1.10.4-1 1.10.4-1+deb9u1
2021-01-22 08:06:23 status triggers-pending libc-bin:amd64 2.24-11+deb9u4
2021-01-22 08:06:23 status half-configured libgstreamer-plugins-bad1.0-0:amd64 1.10.4-1
2021-01-22 08:06:23 status unpacked libgstreamer-plugins-bad1.0-0:amd64 1.10.4-1
2021-01-22 08:06:23 status half-installed libgstreamer-plugins-bad1.0-0:amd64 1.10.4-1
2021-01-22 08:06:23 status half-installed libgstreamer-plugins-bad1.0-0:amd64 1.10.4-1
2021-01-22 08:06:24 status unpacked libgstreamer-plugins-bad1.0-0:amd64 1.10.4-1+deb9u1
2021-01-22 08:06:24 status unpacked libgstreamer-plugins-bad1.0-0:amd64 1.10.4-1+deb9u1
2021-01-22 08:06:24 startup packages configure
2021-01-22 08:06:24 configure mutt:amd64 1.7.2-1+deb9u5 <aucune>
2021-01-22 08:06:24 status unpacked mutt:amd64 1.7.2-1+deb9u5
2021-01-22 08:06:24 status unpacked mutt:amd64 1.7.2-1+deb9u5
2021-01-22 08:06:24 status unpacked mutt:amd64 1.7.2-1+deb9u5
2021-01-22 08:06:24 status unpacked mutt:amd64 1.7.2-1+deb9u5
2021-01-22 08:06:24 status unpacked mutt:amd64 1.7.2-1+deb9u5
2021-01-22 08:06:24 status unpacked mutt:amd64 1.7.2-1+deb9u5
2021-01-22 08:06:24 status unpacked mutt:amd64 1.7.2-1+deb9u5
2021-01-22 08:06:24 status unpacked mutt:amd64 1.7.2-1+deb9u5
2021-01-22 08:06:25 status half-configured mutt:amd64 1.7.2-1+deb9u5
2021-01-22 08:06:25 status triggers-awaited mutt:amd64 1.7.2-1+deb9u5
2021-01-22 08:06:25 trigproc mime-support:all 3.60 <aucune>
2021-01-22 08:06:25 status half-configured mime-support:all 3.60
2021-01-22 08:06:25 status installed mime-support:all 3.60
2021-01-22 08:06:25 trigproc desktop-file-utils:amd64 0.23-1 <aucune>
2021-01-22 08:06:25 status half-configured desktop-file-utils:amd64 0.23-1
2021-01-22 08:06:26 status installed mutt:amd64 1.7.2-1+deb9u5
2021-01-22 08:06:26 status installed desktop-file-utils:amd64 0.23-1
2021-01-22 08:06:26 configure libgstreamer-plugins-bad1.0-0:amd64 1.10.4-1+deb9u1 <aucune>
2021-01-22 08:06:26 status unpacked libgstreamer-plugins-bad1.0-0:amd64 1.10.4-1+deb9u1
2021-01-22 08:06:26 status half-configured libgstreamer-plugins-bad1.0-0:amd64 1.10.4-1+deb9u1
2021-01-22 08:06:26 status installed libgstreamer-plugins-bad1.0-0:amd64 1.10.4-1+deb9u1
2021-01-22 08:06:26 trigproc libc-bin:amd64 2.24-11+deb9u4 <aucune>
2021-01-22 08:06:26 status half-configured libc-bin:amd64 2.24-11+deb9u4
2021-01-22 08:06:26 status installed libc-bin:amd64 2.24-11+deb9u4
2021-01-22 08:06:26 trigproc man-db:amd64 2.7.6.1-2 <aucune>
2021-01-22 08:06:26 status half-configured man-db:amd64 2.7.6.1-2
2021-01-22 08:06:29 status installed man-db:amd64 2.7.6.1-2
2021-01-22 08:06:29 trigproc gnome-menus:amd64 3.13.3-9 <aucune>
2021-01-22 08:06:29 status half-configured gnome-menus:amd64 3.13.3-9
2021-01-22 08:06:29 status installed gnome-menus:amd64 3.13.3-9
2021-01-22 08:06:29 configure gstreamer1.0-plugins-bad:amd64 1.10.4-1+deb9u1 <aucune>
2021-01-22 08:06:29 status unpacked gstreamer1.0-plugins-bad:amd64 1.10.4-1+deb9u1
2021-01-22 08:06:29 status half-configured gstreamer1.0-plugins-bad:amd64 1.10.4-1+deb9u1
2021-01-22 08:06:29 status installed gstreamer1.0-plugins-bad:amd64 1.10.4-1+deb9u1
2021-01-22 11:55:09 startup archives unpack
2021-01-22 11:55:16 install rfkill:amd64 <aucune> 0.5-1+b1
2021-01-22 11:55:16 status half-installed rfkill:amd64 0.5-1+b1
2021-01-22 11:55:17 status triggers-pending man-db:amd64 2.7.6.1-2
2021-01-22 11:55:17 status unpacked rfkill:amd64 0.5-1+b1
2021-01-22 11:55:17 status unpacked rfkill:amd64 0.5-1+b1
2021-01-22 11:55:17 startup packages configure
2021-01-22 11:55:17 trigproc man-db:amd64 2.7.6.1-2 <aucune>
2021-01-22 11:55:17 status half-configured man-db:amd64 2.7.6.1-2
2021-01-22 11:55:18 status installed man-db:amd64 2.7.6.1-2
2021-01-22 11:55:18 configure rfkill:amd64 0.5-1+b1 <aucune>
2021-01-22 11:55:18 status unpacked rfkill:amd64 0.5-1+b1

Je viens juste de réaliser que j’avais eu un probleme similaire il y a quelques semaines mais je n’ai pas eu besoin de réinstaller quoique ce soit.

J’ai supprimé le ssid + mdp wifi enregistrés dans le système et j’ai tout simplement reconfiguré la connexion

ps: simple glitch d’une maj du kernel certainement

Le problème c’est que je ne vois même pas les réseaux disponibles. Donc si je le supprime je pense que je ne pourrais pas le reconfigurer, tout comme je ne peux pas me connecter à un nouveau réseau (si je fais un partage de co avec mon portable par exemple).

Où en es tu de ta galère?

Toujours pareil…

Je sais pas si ça a un lien mais j’arrive à me connecter en filaire que si le cable est déjà connecté au moment du démarrage. C’est à dire que si je démarre et que je branche ensuite, je n’ai pas internet.
Edit : finalement c’était juste un problème de cable

Quelqu’un a une idée ? Je commence vraiment à désespérer, et j’ai besoin du wifi pour mes cours :confused:
@Zargos est ce que tu penses que ca pourrait venir d’une des mises à jour ?