[Post-Scriptum : RÉSOLU] Erreur dans CUPS


#1

J’obtiens l’erreur suivante :

[code]Erreur:

client-error-not-possible[/code]

Cependant cette imprimante, avec le même pilote fonctionnait bien sous Ubuntu.
Est-ce dû au noyau 2.4 [au lieu de 2.6 sur Ubuntu] qui supporterait mal l’impression sur le port USB ?
En fiat, les travaux apparaissent systématiquement annulés dans l’interface d’amin CUPS, et l’erreur mentionnée s’affiche alors quand j’essaie de relancer le travail en question.

Historique de l’install (pilote pour Lexmark z602):
1°) Récupération du piote chez Lexmark : c’est un tgz dans lequel on peut extraire deux rpm [Je passe sur l’install de tcl, etc.]
2°) Conversion vers .deb avec Alien.
3°) Install des .deb.
4°) Dans /usr/share/cups/model :

5°) Installation via localhost:631.
6°) Situation actuelle : voir erreur plus haut.

Et tout ça marchait sans pb sous Ubuntu. D’où mon hypothèse sur le noyau.


#2

et le noyau que tu avais sur ton ubuntu, tu n’y as pas accés sur ta debian ?


#3

Et pourquoi ne pas passer sur un 2.6.8 d’origine sur la Debian Sarge netinstall ?


#4

Eh bien c’est fait, Ricardo :

patrick@Mallorca:~$ uname -a Linux Mallorca 2.6.8-2-686 #1 Thu May 19 17:53:30 JST 2005 i686 GNU/Linux

et ça n’a rien changé.
J’ai même essayé de mettre root et mon user dans le groupe lpadmin, mais rien n’y fait. D’ailleurs j’ai vu des messages identiques sur Google, mais pas de procédure évidente.

Je suis encore en Sarge 3.1 (stable) : faudrait-il passer en Testing pour corriger le pb dans CUPS ?


#5

tu n’as pas une autre imprimante plus simple à tester, pour voir si ca ne vient pas d’abord d’un pb de config cups ?


#6

Bon, je n’ai pas d’autre imprimante sous la main, alors j’ai supprimé La Lexmark z602 et installé une imprimante virtuelle PDF à l’emplacement cups-pdf:/ , en mode RAW.
Là, la page de test a été correctement générée par CUPS : Test_Page.pdf dans /root/cups-pdf/
Je ne sais pas si ce test est suffisant pour valider l’installation de CUPS.
Que faire maintenant ? Je déprime un peu…
:cry:


#7

J’approfondis la chose :
la commande ‘lpinfo -v’ renvoie :

Mallorca:~/cups-pdf# lpinfo -v
network socket
network http
network ipp
direct z600:/dev/usb/lp0
network lpd
direct parallel:/dev/lp0
direct usb://Lexmark/Z600%20Series
direct usb:/dev/usb/lp1
direct usb:/dev/usb/lp2
direct usb:/dev/usb/lp3
direct usb:/dev/usb/lp4
direct usb:/dev/usb/lp5
direct usb:/dev/usb/lp6
direct usb:/dev/usb/lp7
direct usb:/dev/usb/lp8
direct usb:/dev/usb/lp9
direct usb:/dev/usb/lp10
direct usb:/dev/usb/lp11
direct usb:/dev/usb/lp12
direct usb:/dev/usb/lp13
direct usb:/dev/usb/lp14
direct usb:/dev/usb/lp15
file cups-pdf:/

Et j’ai configuré ainsi la Lexmark :

Description: Lexmark-z602
Emplacement: usb://Lexmark/Z600%20Series
Etat de l'imprimante: au repos, accepte les travaux.
URI de périphérique: usb://Lexmark/Z600%20Series

Voici ce qui se produit quand j’essaie d’imprimer une page de test avec la Lexmark :

Lexmark-8 Test Page root 15k Annulé depuis Fri Oct 21 18:31:18 2005
Et si je redémarre le travail :

Erreur:
    client-error-not-possible

J’ajoute que j’ai aussi essayé :
Emplacement: usb:/dev/usb/lp0 sans plus de succès.
Je vais rechercher des journaux d’erreur dans /var…


#8

Je crois que j’ai trouvé un truc intéressant :

Mallorca:~/cups-pdf# tail /var/log/cups/error_log
I [21/Oct/2005:18:31:18 +0200] Adding start banner page "none" to job 8.
I [21/Oct/2005:18:31:18 +0200] Adding end banner page "none" to job 8.
I [21/Oct/2005:18:31:18 +0200] Job 8 queued on 'Lexmark' by 'root'.
E [21/Oct/2005:18:31:18 +0200] Unable to convert file 0 to printable format for job 8!
I [21/Oct/2005:18:31:18 +0200] Hint: Do you have ESP Ghostscript installed?
I [21/Oct/2005:18:31:18 +0200] Hint: Try setting the LogLevel to "debug".
I [21/Oct/2005:18:31:25 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=4119)
I [21/Oct/2005:18:31:34 +0200] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=4120)
I [21/Oct/2005:18:38:26 +0200] Started "/usr/lib/cups/cgi-bin/jobs.cgi" (pid=4123)
E [21/Oct/2005:18:38:27 +0200] restart_job: job #8 cannot be restarted - no files!

Que faut-il penser de "Do you have ESP Ghostscript installed?"
C’est libre, cet ESP Ghostscript ???


#9

Waouuuuuu !
J’ai trouvé la solution !
Suite au message d’erreur précédent, j’ai cherché et trouvé un paquet ‘gs-esp’ ; j’ai redémarré cups : et voilà ! La page de test s’est enfin imprimée.

$ sudo apt-get install gs-esp
$ /etc/init.d/cupsys restart

Ce qui me turlupine, c’est que ce paquet gs-esp ne figure pas dans les dépendances de cups. Est-ce un oubli ou un bogue ?
A qui devrais-je le signaler ?

En tout cas, ça va mieux !!! :smiley:


#10

ca se rapporte.
Je crois que l’outil de rapport de bogue, c’est ‘reportnug’ mais faudrait être sûr.
Je ne sais pas par contre si c’est consideré vraiment comme un bogue.
Peut être que gs-esp figure déjà dans la liste des paquets ‘suggèrés’…
Il faut chercher des references à un site dans les readme du paquet, peut être.


#11

Au temps pour moi !
Ce paquet est en effet mentionné dans la liste des paquets recommandés [symbole : losange vert].
Je suppose que ce n’est pas une dépendance dans la mesure où les imprimantes PostScript n’en ont pas besoin. On pourrait imaginer une question posée lors de l’installation de cupsys.
C’est décrit ici :
http://packages.debian.org/stable/net/cupsys


#12

En fait il persiste un petit pb : j’arrive à imprimer la page de test en root à partir de l’interface HTTP de CUPS, mais c’est plus compliqué pour un simple utilisateur.

  • D’abord, je précise que le client de cups est logiquement cups-client.
  • Ajouter mon user au groupe ‘lp’ est sans effet, donc inutile.

En mode console, on peut tester simplement l’impression ainsi:

patrick@Mallorca:~$ touch test.txt
patrick@Mallorca:~$ echo "zzz" >> test.txt
patrick@Mallorca:~$ lp test.txt
request id is Lexmark-9 (1 file(s))

Avec les applications graphiques, il faut passer le fichier à imprimer à ‘lp’ au lieu de ‘lpr’;
Par exemple, j’ai dû modifier ainsi xpdfrc (/etc/xpdf/xpdfrc) :

psFile                  "|lp -d Lexmark"

Notez que le pipe “|lp” au lieu de “|lpr” ne fonctionnait pas.

Mais dans d’autres applications, c’est le nom “Lexmark” qui est indiqué par défaut (dans OpenOffice par exemple, ou dans le gestionnaire d’impression GNUStep ) — Lexmark, c’est le nom de mon imprimante dans l’install de CUPS. Et dans le cas d’Ooo, il ne se passe rien ! Pire, rien ne se place dans la liste des travaux.
Je vais jeter un oeil sur lppasswd…


#13

:bulb: Bingo !

patrick@Mallorca:~$ sudo lppasswd -a -g lp patrick
Enter password:
Enter password again:
patrick@Mallorca:~$

Il est maintenant possible d’imprimer vers ‘Lexmark’ à partir d’une application comme Ooo.
En fait j’ai d’abord mis le user ‘patrick’ dans le groupe ‘lp’, puis exécuté la commande ci-dessus. Je ne sais pas si c’est CE QU’IL FALLAIT FAIRE, mais ça marche. Qqn a dû documenter tout ça déjà, mais où chercher ?