Postfix + ralentissement des envois

Hello,

Je dispose d’un postfix publique avec plusieurs noms de domaines et 20000 utilisateurs. Pour éviter de me retrouver ban chez nos plus gros fournisseurs de mails, , j’ai mis en place une règle pour limiter les envois. Je vois bien l’appel de cette règle dans mes logs, mais je n’ai pas l’impression qu’elle soit réellement appliquée, voici ce que j’ai fait :

dans le main.cf :

[…]
default_destination_rate_delay = 5s
transport_maps = hash:/etc/postfix/transport
slow_destination_concurrency_limit = 3
slow_destination_rate_delay = 10s
[…]

dans le master.cf :

[...]
slow unix - - n - - smtp -o syslog_name=postfix-slow
[...]

dans le transport :

orange.fr slow:
wanadoo.fr slow:
laposte.net slow:
free.fr slow:
hotmail.fr slow:
outlook.fr slow:
gmail.com slow:
yahoo.fr slow:

Maintenant, si je regarde mes logs, je vois par exemple ceci :

Nov 19 08:26:38 mail postfix-slow/smtp[25261]: Trusted TLS connection established to gmail-smtp-in.l.google.com[74.125.133.27]:25: TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature RSA-PSS (2048 bits) server-digest SHA256
Nov 19 08:26:38 mail postfix-slow/smtp[25261]: BBE9661F48: to=<123456@gmail.com>, relay=gmail-smtp-in.l.google.com[74.125.133.27]:25, delay=0.97, delays=0.22/0.03/0.52/0.2, dsn=2.0.0, status=sent (250 2.0.0 OK  1574148398 v23si1958025wmh.50 - gsmtp)
Nov 19 08:28:06 mail postfix-slow/smtp[25261]: Trusted TLS connection established to gmail-smtp-in.l.google.com[74.125.133.27]:25: TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature RSA-PSS (2048 bits)
Nov 19 08:28:08 mail postfix-slow/smtp[25261]: 4605961F48: to=<dsdsfdsfdsfdsfds@gmail.com>, relay=gmail-smtp-in.l.google.com[74.125.133.27]:25, delay=2.6, delays=0.48/0/0.21/1.9, dsn=2.0.0, status=sent (250 2.0.0 OK  1574148488 q21si1877541wmj.95 - gsmtp)
Nov 19 08:29:15 mail postfix-slow/smtp[25261]: Trusted TLS connection established to gmail-smtp-in.l.google.com[74.125.133.27]:25: TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature RSA-PSS (2048 bits)
Nov 19 08:29:16 mail postfix-slow/smtp[25261]: 2144B61F48: to=<123456@gmail.com>, relay=gmail-smtp-in.l.google.com[74.125.133.27]:25, delay=0.96, delays=0.59/0/0.14/0.23, dsn=2.0.0, status=sent (250 2.0.0 OK  1574148556 145si1888551wme.106 - gsmtp)
Nov 19 08:30:18 mail postfix-slow/smtp[25261]: Trusted TLS connection established to gmail-smtp-in.l.google.com[74.125.133.27]:25: TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature RSA-PSS (2048 bits)
Nov 19 08:30:18 mail postfix-slow/smtp[25261]: D32B061F48: to=<dsdsfdsf@gmail.com>, relay=gmail-smtp-in.l.google.com[74.125.133.27]:25, delay=0.48, delays=0.21/0/0.13/0.14, dsn=2.0.0, status=sent (250 2.0.0 OK  1574148618 91si8358301wrj.101 - gsmtp)
Nov 19 08:33:22 mail postfix-slow/smtp[26007]: Trusted TLS connection established to gmail-smtp-in.l.google.com[74.125.133.26]:25: TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature RSA-PSS (2048 bits) server-digest SHA256
Nov 19 08:33:22 mail postfix-slow/smtp[26007]: F28BF61F6C: to=<0987654@gmail.com>, relay=gmail-smtp-in.l.google.com[74.125.133.26]:25, delay=0.64, delays=0.27/0.04/0.24/0.09, dsn=2.0.0, status=sent (250 2.0.0 OK  1574148802 b9si1967534wmc.110 - gsmtp)
Nov 19 08:33:50 mail postfix-slow/smtp[26007]: Trusted TLS connection established to gmail-smtp-in.l.google.com[74.125.133.26]:25: TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature RSA-PSS (2048 bits)
Nov 19 08:33:50 mail postfix-slow/smtp[26007]: 4B2CF61F6C: to=<0987654@gmail.com>, relay=gmail-smtp-in.l.google.com[74.125.133.26]:25, delay=0.43, delays=0.19/0/0.15/0.09, dsn=2.0.0, status=sent (250 2.0.0 OK  1574148830 p66si1911481wmp.141 - gsmtp)
Nov 19 08:36:31 mail postfix-slow/smtp[26675]: Trusted TLS connection established to gmail-smtp-in.l.google.com[74.125.133.26]:25: TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature RSA-PSS (2048 bits)
Nov 19 08:36:31 mail postfix-slow/smtp[26675]: 13E5E61F6C: to=<0987654@gmail.com>, relay=gmail-smtp-in.l.google.com[74.125.133.26]:25, delay=0.56, delays=0.36/0.01/0.11/0.07, dsn=2.0.0, status=sent (250 2.0.0 OK  1574148991 w12si1953200wmk.130 - gsmtp)
Nov 19 08:37:36 mail postfix-slow/smtp[26675]: Trusted TLS connection established to gmail-smtp-in.l.google.com[74.125.133.26]:25: TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature RSA-PSS (2048 bits)
Nov 19 08:37:36 mail postfix-slow/smtp[26675]: 4BE4161F6C: to=<0987654@gmail.com>, relay=gmail-smtp-in.l.google.com[74.125.133.26]:25, delay=0.37, delays=0.16/0/0.13/0.08, dsn=2.0.0, status=sent (250 2.0.0 OK  1574149056 131si1897407wma.127 - gsmtp)
Nov 19 09:16:27 mail postfix-slow/smtp[32286]: Trusted TLS connection established to eur.olc.protection.outlook.com[104.47.1.33]:25: TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)
Nov 19 09:16:28 mail postfix-slow/smtp[32286]: E9E9A61F48: to=<sdfdsfdsf@hotmail.fr>, relay=eur.olc.protection.outlook.com[104.47.1.33]:25, delay=3.1, delays=2.1/0.02/0.42/0.56, dsn=2.6.0, status=sent (250 2.6.0 <23581296b1f696bbc571206096daec9a@monserveur.org> [InternalId=63964947962569, Hostname=VE1EUR01HT101.eop-EUR01.prod.protection.outlook.com] 16257 bytes in 0.281, 56.432 KB/sec Queued mail for delivery -> 250 2.1.5)

La règle slow est bien appelée, en revanche, j’ai l’impression que le délais de 5 sec entre chaque envoi n’est pas appliqué. Les envois ont l’air de se faire immédiatement sans tenir compte de la temporisation que j’ai demandé.

Qu’est-ce qui cloche dans ma paramétrie ?

merci

Essaye avec slow unix - - n - 5 smtp -o syslog_name=postfix-slow -o smtp_destination_concurrency_limit=3 -o slow_destination_rate_delay=10

sur une ligne dans le master.cf

Bon, à priori c’était fonctionnel, je ne savais juste pas compter.

J’avais tout de même mis des trucs pas bons dans le main.cf.

Reste un truc que je n’ai toujours pas compris : j’ai parfois l’impression qu’entre main.cf et le master.cf, il y a une redite de la conf, mais sous une forme différente, typiquement les options et la ligne que tu évoques (-o smtp_destination_concurrency_limit=3 -o slow_destination_rate_delay=10) ne viennent-elles pas en doublon du main.cf ? Et j’ai l’impression que ça se produit pour d’autres options. Du coup, quel intérêt d’envoyer l’info deux endroits différents ?

Ces options sont uniquement pour le cas slow, à titre indicatif j’ai

wanadoo.com veryslow:
wanadoo.fr veryslow:
orange.com veryslow:
orange.fr veryslow:
laposte.net veryslow:
sfr.fr veryslow:
gmail.com veryslow:
gmail.fr veryslow:
free.fr veryslow:
alice.fr slow:

avec dans le master.cf

slow      unix  -  -  n  -  5  smtp -o syslog_name=postfix-slow     -o smtp_destination_concurrency_limit=2 -o     slow_destination_rate_delay=2
veryslow  unix  -  -  n  -  5  smtp -o syslog_name=postfix-veryslow -o smtp_destination_concurrency_limit=2 -o veryslow_destination_rate_delay=8

pour différencier les traitements suivant les domaines

Mais du coup, dans ton main.cf, tu présentes ça comment ?
juste avec la ligne

transport_maps = hash:/etc/postfix/transport

sans rien d’autre ?

Bon, ceci dit, j’ai fait la même conf que toi et le résultat dans la log ne me parait pas logique. J’ai envoyé à la file 5 mails au même destinataire chez orange :

Nov 19 20:29:17 mail postfix-slow/smtp[10766]: Trusted TLS connection established to smtp-in.orange.fr[193.252.22.65]:25: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
Nov 19 20:29:17 mail postfix-slow/smtp[10766]: 0255061F6C: to=<toto@orange.fr>, relay=smtp-in.orange.fr[193.252.22.65]:25, delay=2.2, delays=1.8/0.01/0.2/0.18, dsn=2.0.0, status=sent (250 2.0.0 TvVH2100h4js4Zv01vVHHt mail accepted for delivery)
Nov 19 20:29:22 mail postfix-slow/smtp[10766]: Trusted TLS connection established to smtp-in.orange.fr[193.252.22.65]:25: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
Nov 19 20:29:23 mail postfix-slow/smtp[10766]: 7331261F6C: to=<toto@orange.fr>, relay=smtp-in.orange.fr[193.252.22.65]:25, delay=2.6, delays=0.28/2/0.24/0.1, dsn=2.0.0, status=sent (250 2.0.0 TvVN2101b4js4Zv01vVNMA mail accepted for delivery)
Nov 19 20:29:28 mail postfix-slow/smtp[10766]: Trusted TLS connection established to smtp-in.orange.fr[193.252.22.65]:25: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
Nov 19 20:29:28 mail postfix-slow/smtp[10766]: C4FC861F6C: to=<toto@orange.fr>, relay=smtp-in.orange.fr[193.252.22.65]:25, delay=1.7, delays=0.38/1/0.17/0.11, dsn=2.0.0, status=sent (250 2.0.0 TvVU2100K4js4Zv01vVUQC mail accepted for delivery)
Nov 19 20:29:41 mail postfix-slow/smtp[10766]: Trusted TLS connection established to smtp-in.orange.fr[80.12.242.9]:25: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
Nov 19 20:29:41 mail postfix-slow/smtp[10766]: AEAB661F6C: to=<toto@orange.fr>, relay=smtp-in.orange.fr[80.12.242.9]:25, delay=0.67, delays=0.44/0/0.14/0.09, dsn=2.0.0, status=sent (250 2.0.0 TvVh2100B4js4Zv01vVhYD mail accepted for delivery)
Nov 19 20:29:47 mail postfix-slow/smtp[10766]: Trusted TLS connection established to smtp-in.orange.fr[193.252.22.65]:25: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
Nov 19 20:29:47 mail postfix-slow/smtp[10766]: 52A7A61F6C: to=<toto@orange.fr>, relay=smtp-in.orange.fr[193.252.22.65]:25, delay=0.67, delays=0.43/0/0.13/0.1, dsn=2.0.0, status=sent (250 2.0.0 TvVn2100p4js4Zv01vVnby mail accepted for delivery)

D’après moi, il y aurait dû y avoir au 3eme mail un délais de 10 sec pour envoyer le 4eme, alors que quand on regarde la valeur delay, ça a pris moins d’une seconde.

Ou alors j’ai mal compris le sens des variables smtp_destination_concurrency_limit et slow_destination_rate_delay

Alors, j’ai aussi repris les réglages dans le main.cf, je ne me rappelle pas qui précède qui d’autant tout n’est pas de moi, ça me parait superflu. Je crois que c’était lors des réglages, il me semble que les paramètres de master.cf passés par -o sont prioritaires (à vérifier)

Ensuite, si tu regardes, tu as eu 5 connexions en 30s (20:29:17 -> 20:29:47), ces limitations interviennent lorsque tu envois un mail à 20 destinataires orange.fr par exemple, dans ce cas ça limite le nombre de mails par connexions et le nmbre de connexions par secondes. C’est surtout interessant si tu gères un très gros serveur ou bien un serveur de mailing ou de gestion de liste de diffusion (mon cas), dans ce cas je me retrouve à envoyer plusieurs centaines/milliers de mails en un court laps de temps. Avec ces réglages, les envois peuvent s’étaler sur une longue durée (dizaines de minutes voire heure).
Mes problèmes ont été réglés avec l’authentification par certificat.

1 J'aime

D’accord, merci pour l’explication, je comprends mieux .Ma règle se déclenche mais du coup ne s’applique à rien.

Il ne devrait pas y avoir de redite. Les options passées dans le master.cf permettent de surcharger/remplacer les options globales du main.cf service par service (smtp, submission, slow, etc.)

bon, définitivement, il y a un truc que je ne comprends pas…

J’ai encore et toujours des problèmes de bans chez orange, laposte et free.

Voilà ma conf :

alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
allow_percent_hack = no
append_dot_mydomain = no
biff = no
bounce_notice_recipient = root
broken_sasl_auth_clients = no
compatibility_level = 2
default_destination_concurrency_limit = 2
default_destination_rate_delay = 2s
delay_notice_recipient = root
delay_warning_time = 4h
disable_vrfy_command = yes
error_notice_recipient = root
header_checks = regexp:/etc/postfix/header_checks
inet_interfaces = all
inet_protocols = ipv4
lmtp_tls_session_cache_database = btree:${data_directory}/lmtp_scache
mailbox_size_limit = 0
message_size_limit = 10240000
milter_default_action = accept
milter_mail_macros = i {mail_addr} {client_addr} {client_name} {auth_authen}
milter_protocol = 6
mime_header_checks = regexp:/etc/postfix/header_checks
mydestination = $myhostname, mail, localhost.localdomain, localhost
mydomain = mondomaine.org
myhostname = mail.mondomaine.org
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
myorigin = $myhostname
non_smtpd_milters = inet:localhost:11332
notify_classes = bounce, delay, resource, software
policyd-spf_time_limit = 3600s
postscreen_access_list = permit_mynetworks, cidr:/etc/postfix/postscreen_access.cidr
postscreen_blacklist_action = drop
postscreen_dnsbl_action = drop
postscreen_dnsbl_sites = zen.spamhaus.org*3 dbl.spamhaus.org bl.spamcop.net*2 cbl.abuseat.org dnsbl-1.uceprotect.net multi.uribl.com
postscreen_dnsbl_threshold = 3
postscreen_greet_action = enforce
postscreen_greet_banner = Patience est mere de vertue
readme_directory = no
recipient_delimiter = +
relayhost =
show_user_unknown_table_name = no
smtp_tls_CAfile = /etc/ssl/certs/ca-certificates.crt
smtp_tls_loglevel = 1
smtp_tls_mandatory_ciphers = high
smtp_tls_mandatory_protocols = !SSLv2, !SSLv3
smtp_tls_note_starttls_offer = yes
smtp_tls_protocols = !SSLv2, !SSLv3
smtp_tls_security_level = may
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_banner = $myhostname ESMTP
smtpd_client_restrictions = permit_mynetworks, permit_sasl_authenticated, permit_inet_interfaces, reject_unknown_reverse_client_hostname,
smtpd_data_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_multi_recipient_bounce, reject_unauth_pipelining
smtpd_helo_required = yes
smtpd_helo_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_invalid_helo_hostname, reject_non_fqdn_helo_hostname, reject_unknown_helo_hostname, reject_unauth_pipelining
smtpd_milters = inet:localhost:11332
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_non_fqdn_recipient, reject_unauth_destination, reject_unknown_recipient_domain,
smtpd_relay_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_authenticated_header = yes
smtpd_sasl_local_domain = $myhostname
smtpd_sasl_path = private/auth
smtpd_sasl_security_options = noanonymous
smtpd_sasl_tls_security_options = $smtpd_sasl_security_options
smtpd_sasl_type = dovecot
smtpd_sender_restrictions = permit_mynetworks, permit_sasl_authenticated, check_policy_service unix:private/policyd-spf, reject_sender_login_mismatch, reject_unauth_destination, reject_unknown_sender_domain, reject_unlisted_sender, reject_non_fqdn_sender, reject_unauth_pipelining
smtpd_tls_CAfile = $smtp_tls_CAfile
smtpd_tls_auth_only = yes
smtpd_tls_cert_file = /etc/letsencrypt/live/cert_global_mondomaine/fullchain.pem
smtpd_tls_dh1024_param_file = $config_directory/dh4096.pem
smtpd_tls_dh512_param_file = $config_directory/dh512.pem
smtpd_tls_eecdh_grade = auto
smtpd_tls_key_file = /etc/letsencrypt/live/cert_global_mondomaine/privkey.pem
smtpd_tls_loglevel = 2
smtpd_tls_mandatory_ciphers = high
smtpd_tls_mandatory_protocols = !SSLv2, !SSLv3
smtpd_tls_protocols = !SSLv2, !SSLv3
smtpd_tls_received_header = yes
smtpd_tls_security_level = may
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtputf8_autodetect_classes = verify
strict_rfc821_envelopes = yes
swap_bangpath = no
tls_preempt_cipherlist = yes
tls_random_source = dev:/dev/urandom
tls_ssl_options = no_ticket, no_compression
transport_maps = hash:/etc/postfix/transport
virtual_alias_maps = mysql:/etc/postfix/mysql-virtual-alias-maps.cf
virtual_gid_maps = static:5000
virtual_mailbox_base = /var/mail
virtual_mailbox_domains = mysql:/etc/postfix/mysql-virtual-mailbox-domains.cf
virtual_mailbox_maps = mysql:/etc/postfix/mysql-virtual-mailbox-maps.cf
virtual_minimum_uid = 5000
virtual_transport = lmtp:unix:private/dovecot-lmtp
virtual_uid_maps = static:5000
smtp       inet  n       -       y       -       1       postscreen
smtpd      pass  -       -       y       -       -       smtpd
dnsblog    unix  -       -       y       -       0       dnsblog
tlsproxy   unix  -       -       y       -       0       tlsproxy
submission inet  n       -       y       -       -       smtpd -o syslog_name=postfix/submission -o smtpd_tls_security_level=encrypt -o smtpd_sasl_auth_enable=yes -o smtpd_client_restrictions=permit_sasl_authenticated,reject
smtps      inet  n       -       y       -       -       smtpd -o syslog_name=postfix/smtps -o smtpd_tls_wrappermode=yes -o smtpd_sasl_auth_enable=yes -o smtpd_client_restrictions=permit_sasl_authenticated,reject
pickup     unix  n       -       y       60      1       pickup
cleanup    unix  n       -       y       -       0       cleanup
qmgr       unix  n       -       n       300     1       qmgr
tlsmgr     unix  -       -       y       1000?   1       tlsmgr
rewrite    unix  -       -       y       -       -       trivial-rewrite
bounce     unix  -       -       y       -       0       bounce
defer      unix  -       -       y       -       0       bounce
trace      unix  -       -       y       -       0       bounce
verify     unix  -       -       y       -       1       verify
flush      unix  n       -       y       1000?   0       flush
proxymap   unix  -       -       n       -       -       proxymap
proxywrite unix  -       -       n       -       1       proxymap
smtp       unix  -       -       y       -       -       smtp
relay      unix  -       -       y       -       -       smtp
showq      unix  n       -       y       -       -       showq
error      unix  -       -       y       -       -       error
retry      unix  -       -       y       -       -       error
discard    unix  -       -       y       -       -       discard
local      unix  -       n       n       -       -       local
virtual    unix  -       n       n       -       -       virtual
lmtp       unix  -       -       y       -       -       lmtp
anvil      unix  -       -       y       -       1       anvil
scache     unix  -       -       y       -       1       scache
maildrop   unix  -       n       n       -       -       pipe flags=DRhu user=vmail argv=/usr/bin/maildrop -d ${recipient}
uucp       unix  -       n       n       -       -       pipe flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
ifmail     unix  -       n       n       -       -       pipe flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
bsmtp      unix  -       n       n       -       -       pipe flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -t$nexthop -f$sender $recipient
scalemail-backend unix - n       n       -       2       pipe flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}
mailman    unix  -       n       n       -       -       pipe flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py ${nexthop} ${user}
policyd-spf unix -       n       n       -       -       spawn user=nobody argv=/usr/bin/policyd-spf
slow       unix  -       -       n       -       5       smtp -o syslog_name=postfix-slow -o smtp_destination_concurrency_limit=2 -o slow_destination_rate_delay=5
veryslow   unix  -       -       n       -       5       smtp -o syslog_name=postfix-veryslow -o smtp_destination_concurrency_limit=1 -o veryslow_destination_rate_delay=10

mon fichier transport contient ceci :

wanadoo.com veryslow:
wanadoo.fr veryslow:
orange.com veryslow:
orange.fr veryslow:
laposte.net veryslow:
sfr.fr veryslow:
gmail.com veryslow:
gmail.fr veryslow:
outloook.fr veryslow:
hotmail.fr veryslow:
hotmail.com veryslow:
icloud.fr veryslow:
free.fr veryslow:
alice.fr slow:

Comment est-ce possible qu’avec cette conf, j’ai encore des messages comme ça dans ma log ?

Dec  6 09:33:04 mail postfix-veryslow/smtp[28991]: B3617622B5: to=<magicien@orange.fr>, relay=smtp-in.orange.fr[193.252.22.65]:25, delay=2.6, delays=0.33/0.09/2.2/0, dsn=4.0.0, status=deferred (host smtp-in.orange.fr[193.252.22.65] refused to talk to me: 421 mwinf5c54 ME Service refuse. Veuillez essayer plus tard. Service refused, please try later. OFR_108; [108])
Dec  6 09:42:47 mail postfix-veryslow/smtp[30472]: B3617622B5: to=<magicien@orange.fr>, relay=smtp-in.orange.fr[80.12.242.9]:25, delay=586, delays=583/0.02/2.2/0, dsn=4.0.0, status=deferred (host smtp-in.orange.fr[80.12.242.9] refused to talk to me: 421 mwinf5c54 ME Service refuse. Veuillez essayer plus tard. Service refused, please try later. OFR_108; [108])
Dec  6 09:52:48 mail postfix-veryslow/smtp[31902]: B3617622B5: to=<magicien@orange.fr>, relay=smtp-in.orange.fr[193.252.22.65]:25, delay=1186, delays=1183/0.02/2.2/0, dsn=4.0.0, status=deferred (host smtp-in.orange.fr[193.252.22.65] refused to talk to me: 421 mwinf5c54 ME Service refuse. Veuillez essayer plus tard. Service refused, please try later. OFR_108; [108])
Dec  6 10:12:48 mail postfix-veryslow/smtp[2503]: B3617622B5: to=<magicien@orange.fr>, relay=smtp-in.orange.fr[80.12.242.9]:25, delay=2386, delays=2383/0.02/2.2/0, dsn=4.0.0, status=deferred (host smtp-in.orange.fr[80.12.242.9] refused to talk to me: 421 mwinf5c54 ME Service refuse. Veuillez essayer plus tard. Service refused, please try later. OFR_108; [108])
Dec  6 10:52:48 mail postfix-veryslow/smtp[8898]: B3617622B5: to=<magicien@orange.fr>, relay=smtp-in.orange.fr[193.252.22.65]:25, delay=4786, delays=4784/0.02/2.2/0, dsn=4.0.0, status=deferred (host smtp-in.orange.fr[193.252.22.65] refused to talk to me: 421 mwinf5c54 ME Service refuse. Veuillez essayer plus tard. Service refused, please try later. OFR_108; [108])

Il suffit qu’un mec envoi un mail avec une vingtaine de personnes en CC dont 3 ou 4 sous le même domaine, et c’est la fin des haricots !

Je n’arrive pas à ralentir correctement mon trafic :frowning:

Et l’autre point que je ne comprends pas : j’ai l’impression que tout mail envoyé avec des destinataires en copie, voit ses copies envoyées simultanément.
Exemple : si j’ai 25 destinataires en copies dont 5 chez free, 10 chez orange etc… j’ai l’impression que tout part en même temps, sans respecter un délais correct. Comment limiter ça ?

Cette limitation de 20 destinataires, où est-elle seté ? je crois que mon problème est simplement là.

Merci !