Problème à l'extinction / redémarrage


#1

Bien le bonjour a tous,

Après une petite excursion sur d’autres distributions Linux, je viens de me réinstaller une petite Debian Jessie a l’occasion de la sortie de la RC1.
Je suis globalement très satisfait, mais je rencontre un problème assez perturbant…

En effet, impossible d’éteindre ou de redémarrer mon PC proprement, que ce soit a partir de GNOME ou bien en ligne de commande. A chaque fois je me retrouve bloqué avec un écran noir et un curseur qui clignote, la seule solution étant alors d’éteindre le PC manuellement. J’ai bien essayé de lui laisser une fois le temps de s’éteindre, mais j’ai fini par presser le bouton après une heure d’attente.

J’ai trouvé un post lié a un problème relativement similaire sur le forum anglophone : forums.debian.net/viewtopic.php? … f&start=15
Malheureusement, ça ne m’a pas plus éclairé que ça quant a une potentielle solution a appliquer.
Surtout que son problème a l’air d’être periodique quand le miens est permanent…

A priori je ne pense pas que ça vienne du kernel car j’ai eu le même problème en testant un dérivé d’Ubuntu 14.04 (kernel 3.13 donc) mais pas sur Manjaro (kernel 3.16 a l’époque).
Quelqu’un aurait il une idée pour résoudre ce problème ou tout du moins pour savoir d’où il peut bien venir ?

Pour ce qui est des spécifications techniques :

00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09) 00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09) 00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09) 00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04) 00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04) 00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04) 00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04) 00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4) 00:1c.4 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 5 (rev c4) 00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04) 00:1f.0 ISA bridge: Intel Corporation HM77 Express Chipset LPC Controller (rev 04) 00:1f.2 IDE interface: Intel Corporation 7 Series Chipset Family 4-port SATA Controller [IDE mode] (rev 04) 00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04) 00:1f.5 IDE interface: Intel Corporation 7 Series Chipset Family 2-port SATA Controller [IDE mode] (rev 04) 01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 630M] (rev ff) 02:00.0 Network controller: Intel Corporation Centrino Wireless-N 2230 (rev c4) 03:00.0 Ethernet controller: Qualcomm Atheros AR8161 Gigabit Ethernet (rev 10)

Merci d’avance pour votre aide !

PS : J’ai essayé d’utiliser les commandes suivantes pour arrêter mon PC :

poweroff
poweroff -i
poweroff -f

#2

Eh eh ! problème pour ma part rencontré et résolu ! Il semble que la carte réseau ai besoin d’être ‘réveillée’ par le système d’exploitation, surtout
pour le mode le WOL et le SHUTDOWN…
Explication qui pour moi a marché :
Si tu as la possibilité de configurer le bios, fait le en mode windows 7 (non pas windows8 ) (fait sur un intel nuk)
Ensuite et plus important :
Charge ethtool à partir de Synaptics ou en commande, puis ajoute l’entrée :
ethtool -s eth0 wol g dans ‘préférences’, puis ‘applications au démarrage’ (si tu es en mode graphique sous gnome)
redémarre ton pc et essaye à nouveau un ‘poweroff’ ou un 'shutdown -h now :mrgreen:


#3

Salut,

Voudrais tu me détailler ton mode opératoire dans l’installation d’une version [mono]Testing[/mono] (n’ayons pas peur des mots) à savoir [mono]Jessie[/mono], stp ?

Sais tu qu’il est fréquent de ce voir confronter à des bugs (c’est du Testing, hein … Instable quoi.) émanants de cette dernière ?
Nous nous en prémunissons (enfin certains d’entre nous) à travers l’installation et l’utilisation d’[mono]apt-listbugs[/mono], ce dernier te chante t-il ?


#4

Merci a vous pour vos réponses.

Concernant le WoL, il semblerait que mon matériel ne le supporte pas :

Cannot get current wake-on-lan settings: Operation not supported not setting wol
J’ai essayé de regarder dans le BIOS, mais il n’y a visiblement rien permettant de l’activer a ce niveau.
Existerait il a votre connaissance une manière différente de “réveiller la carte réseau” ?

Je suis pleinement conscient que Jessie est une version testing, mais mon matériel n’est pas supporté par le kernel de Debian 7. Globalement ça ne me gêne d’ailleurs pas, j’essaie juste de résoudre les bugs quand il se présentent.
Par contre je n’avais jamais vraiment utilisé apt-listbugs, je vais l’installer et regarder le man…

Au niveau de l’installation, je suis passé par les DVD RC1 et j’ai utilisé l’installeur graphique classique, rien de bien spécial ici.
Le seul point peut être intéressant, c’est qu’une fois l’installation finie, j’ai du installer le paquet “firmware-iwlwifi” pour pouvoir faire fonctionner mon wifi.

J’espère que ça répond a ta question.


#5

Salut,

[quote=“N3mesis98”]
J’espère que ça répond a ta question.[/quote]
Tout à fait.
Mise à part le [mono]$ man[/mono], tu trouveras sur notre wiki un tuto consacré à [mono]apt-listbugs[/mono].

Cette méthode bien que disponible n’est guère recommandable.
En effet, sa compilation est faite avec les bugs du moment.

LA méthode que je préconise et ne suis pas le seul en ces lieux.

  • Installation de la version [mono]Stable[/mono] ([mono]Wheezy[/mono], en l’occurrence), sans graphique. C’est important.
  • Mise à jour [mono]# aptitude update && aptitude -s full-upgrade[/mono]
  • Installation d’[mono]apt-listbugs[/mono]
  • Modification du fichier [mono]/etc/apt/sources.list[/mono] pour inclure les dépôts [mono]Jessie[/mono].
  • Création d’un fichier [mono]/etc/apt/preferences[/mono] afin de déterminer l’épinglage des dépôts.
  • Mise à jour [mono]# aptitude update && aptitude -s full-upgrade[/mono]
  • À présent, tu peux installer le gestionnaire graphique de ton choix. ^¿^

#6

J’essaierais d’utiliser cette méthode la prochaine fois que j’installerais une testing. Mais en attendant, j’aimerais si possible corriger le problème sans réinstaller mon système.

Au niveau de apt-listbug, j’ai recherché les bugs sur tout les paquets de mon système et j’obtiens uniquement ceci:

b30 - #775812 - base: HP EliteBook 840 G1 laptop fails to halt/poweroff after 15/12/2015 upgrade

Sinon, au niveau de la carte réseau, il n’y aurait pas moyen de la réveiller en mettant l’interface wlan0 ou eth0 en up ?


#7

[quote=“deb’forme”]Eh eh ! problème pour ma part rencontré et résolu ! Il semble que la carte réseau ai besoin d’être ‘réveillée’ par le système d’exploitation, surtout
pour le mode le WOL et le SHUTDOWN…
Explication qui pour moi a marché :
Si tu as la possibilité de configurer le bios, fait le en mode windows 7 (non pas windows8 ) (fait sur un intel nuk)
Ensuite et plus important :
Charge ethtool à partir de Synaptics ou en commande, puis ajoute l’entrée :
ethtool -s eth0 wol g dans ‘préférences’, puis ‘applications au démarrage’ (si tu es en mode graphique sous gnome)[/quote]
Je m’incruste dans ce sujet juste pour te remercier de cette réponse qui qui m’a mis sur la bonne piste de la carte réseau et du Wake-on-LAN. Sur une et une seule de mes machines, sous Wheezy l’arrêt du système (avec halt, poweroff ou shutdown ou un appui bref sur le bouton marche/arrêt) ne mettait plus la machine hors tension alors cela fonctionne sous Squeeze. Pas mieux avec le noyau de wheezy-backports. Après avoir lu ton message, j’ai désactivé la carte réseau intégrée dans le BIOS et constaté que l’arrêt fonctionnait. ethtool indiquait que l’interface était déjà en WOL g, donc ta commande n’aurait servi à rien. La désactivation du WOL par ethtool (d) n’a pas résolu le problème. Par contre le WOL était désactivé dans les paramètres du BIOS, et après l’avoir activé le problème a disparu. Je n’ai pas l’explication, mais ce contournement me satisfait.


#8

Entre temps, j’ai activé les détails plymouth sur mon système, et étrangement, je bloque après l’affichage du “[OK] Reached target shutdown”.
J’ai aussi essayé d’utiliser un debug shell de systemd sans succès, je n’ai n’y ai plus accès au moment ou mon PC se retrouve bloqué…

A votre avis, existerait il une autre manière pour connaître les services encore en cours d’exécution au moment ou le blocage survient ?

Edit :
J’ai réussi a éteindre correctement mon PC en utilisant la commande

dans un tty.
Sans le sudo ou dans un émulateur de terminal ça ne passe pas.

Je ne considère pas ça comme étant une réelle solution a mon problème, mais ça peut toujours être une information utile…


#9

Pas d’autres pistes pour essayer de resoudre ce problème ?
De mon coté en tout cas je seche un peu…


#10

Problème resolu.

J’ai utilisé une fois (dans un tty) la commande:

Mon PC s’est alors eteint correctement, et depuis, un simple poweroff suffit.

Merci pour votre aide


#11

Je viens d’installer debian 9.6. Quand je fais le shutdown sur la machine, elle n’arrete pas les services comme se font les versions precedentes. Elle s’eteint comme si je fais un arret brutal de la machine. Je pense que c’est pas normal. Est ce que quelqu’un sache le pourquoi? je serai tres content si je trouve quelqu’un qui pourra m’aider s’il vous plait.


#12

Quelle commande entres tu dans le terminal ?
“shutdown” ou “shutdown -h now” pour ma part avec la seconde commande peux importe la distro de linux que j’ai utilisé ça à toujours très bien fonctionné.

Sinon quel est le dernier message que tu vois ?


#13

Qu’est-ce qui te fais dire ça ?
Comment as-tu installé le système et avec quel environnement de travail ?

PS : La nécromancie c’est pas bien ce sujet à au bas mots 2 ou 3 ans …


#14

Quelque soit la commande que je fais, elle s’eteint brusquement. Lorsque je redemarre, elle fait des tests d’intégrités. Parfois elle me demande de lancer fsck