Probleme avec alsa et sarge


#1

Bonjour,

J’ai installé sarge il y a peu avec un noyau 2.6 et je n’arrive pas a configurer alsa correctement.
En fait je lance alsaconf en root et tout se passe bien jusqu’au reboot du noyau où visiblement je perd ma config audio et ou je suis obligé de relancer alsaconf jusqu"au reboot suivant. Je pense qu’il y a un fichier de config a bidouiller pour sauvegarder la config ou alors des drivers a charger que alsaconf ferait automatiquement, mais je ne sais pas lesquels.
Est ce que quelqu’un aurait une réponse ou au moins une piste ?

merci


#2

Pour que le module (driver) de ta carte son soit chargé automatiquement au démarrage, il faut le rajouter dans le fichier /etc/modules


#3

Commencons par ceci des fois que…
parce que alsaconf gere tout tout seul maintenant, plus besoin de bidouiller les fichiers de config: ca serait dommage de pas en profiter…

# root> apt-get update
# root> apt-get dist-upgrade

sinon:

# root> apt-get install  alsa-base alsa-utils

parce que sans ca tu vas pas aller bien loin, fin bon tu as alsaconf donc a priori tu l’as fait…
Ensuite c’est la fete:
alsaconf detecte ta(es) carte(s) son
puis genere le fichier /etc/modprobe.d/sound
puis update les modules

# root> alsaconf 

La suite suis pas sur hein mais je crois qu’il faut conctener l’alias du son dans modprobe.conf a moins que ca se fasse tout seul ausi maintenant, je sis pas du tout du tout!
:confused:
deja regarde si tu as du son apres le redemarrage, on verra apres si besoin…


#4

merci pour les réponses, mais je n’ai pas résolu mes problèmes.
En fait j’avais déja fait ce que echo me suggère. Tout marche bien jusqu’a ce que je redemarre mon noyau, et alors je n’ai plus de son.
J’ai essayé de faire un diff sur un lsmod avant et après : les mêmes modules sont chargés mais les dépendances ne sont pas les mêmes (colonne “used by”), ca me parait une bonne piste mais je ne sais pas quoi faire après.

a plus


#5

T’as essayé de faire un alsamixer pour voir si ta carte son n’est pas tout simplement en mute au démarrage?


#6

j’ai le même problème avec ma sounblaster live !
au démarrage le driver ne se charge pas non plus !!

tu pourras peut-être trouver des éléments ici :
alsa-project.org/alsa-doc/


#7

après quelques essai voilà comment je suis arrivé à charger le son au démarrage :

Comme j’ai 2 cartes sons : la première est celle intégrée à la carte mère (une sis 7012)
et la deuxième c’est une carte SounBlaster Live.

J’ai remarqué qu’au ddémarrage il me chargait la première carte (donc celle du système SIS 7012) et non la SounBlaster !

J’ai désactivé LA sis dans le bios et il à chargé la SB au démarrage sans problème.

Si ça peut aider quelqu’un !


#8

ouaip,
en fait j’ai le même style de problème : quand je lance alsamixer (merci BOBX, je n’avais même pas testé si le son était mute ou non…), alsa “pointe” sur ma carte tuner TV (Brooktree connexant BT878). Après avoir lancé alsaconf, tout marche bien et alsamixer me donne bien le status de ma carte son (CMI 87838), je vais essayer de chercher du coté de l’init d’alsa…

a pluche


#9

[quote=“monsieur_oliv”]merci pour les réponses, mais je n’ai pas résolu mes problèmes.
En fait j’avais déja fait ce que echo me suggère. Tout marche bien jusqu’a ce que je redemarre mon noyau, et alors je n’ai plus de son.
J’ai essayé de faire un diff sur un lsmod avant et après : les mêmes modules sont chargés mais les dépendances ne sont pas les mêmes (colonne “used by”), ca me parait une bonne piste mais je ne sais pas quoi faire après.

a plus[/quote]

Chaque chose en son temps et j’en arrive a la suite!
Si ca ne marche toujours pas…
tous les alias du repertoire /etc/modprobe.d/ doivent etre concatenes ds le fichier /etc/modprobe.conf…


#10

euh tu fais comment pour concatener les alias de /etc/modprobe.d dans /etc/modprobe.conf ? je vois pas exactement ce que ca veut dire ?
Un truc du genre grep -r alias /etc/modprobe.d/ > /etc/modprobe.conf ? Dans ce cas, je vais créer le fichier car il n’existe pas (pourtant mes souvenirs d’il y a 3-4 ans, il existait effectivement), par contre j’ai un fichier modules.conf qui contient un certain nombre d’alias, est ce que sur les dernières versions de debian modprobe.conf aurait été remplacé par un autre fichier ?

merci et a plus tard,


#11

[quote=“monsieur_oliv”]euh tu fais comment pour concatener les alias de /etc/modprobe.d dans /etc/modprobe.conf ? je vois pas exactement ce que ca veut dire ?
Un truc du genre grep -r alias /etc/modprobe.d/ > /etc/modprobe.conf ? Dans ce cas, je vais créer le fichier car il n’existe pas (pourtant mes souvenirs d’il y a 3-4 ans, il existait effectivement), par contre j’ai un fichier modules.conf qui contient un certain nombre d’alias, est ce que sur les dernières versions de debian modprobe.conf aurait été remplacé par un autre fichier ?

merci et a plus tard,[/quote]

ca ne semblerait pas si illogique que ca quand on y pense, donc oui c’est peut etre le cas… A moins que mes souvenirs me trahissent.
Je ne suis pas chez moi et sous NetBSD donc en ce qui me concerne je pourrai pas t’en dire plus avant ce soir!


#12

Normalement, il n’est jamais nécessaire, et en plus il n’est pas recommandé, d’éditer à la main /etc/modules.conf.
Il doit être mis à jour à partir des fichiers contenus dans /etc/modutils en lançant un update-modules.

Dans mon fichier modules.conf, j’ai cette partie :

# Prevent abnormal drivers from grabbing index 0
options snd-bt87x index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2

A priori, ça empêche que certains modules soient utilisés comme carte son principale. As tu la même chose?


#13

Comme n’importe quel fichier de conf, il n’est pas recommande d’editer a la main

update-module ne fait a ma connaissance que la mise a jour de modules.conf depuis modutils…
d’ailleurs regarde dans modules.conf si tu retrouves l’alias du module son de ta carte son… Moi, ce n’etait pas le cas, d’ou la necessite de le rajouter a la main.
Depuis cet ajout j’ai du son…

mattotop t’es ou??? :smiley:


#14

Je dirais plutôt que ce sont les fichiers générés automatiquement qu’il n’est pas recommander d’éditer à la main, sinon vi powaaaa!

[quote=“Echo”]
update-module ne fait a ma connaissance que la mise a jour de modules.conf depuis modutils…
d’ailleurs regarde dans modules.conf si tu retrouves l’alias du module son de ta carte son… Moi, ce n’etait pas le cas, d’ou la necessite de le rajouter a la main.
Depuis cet ajout j’ai du son…

mattotop t’es ou??? :smiley:[/quote]

Le problème de ta modif, c’est que le jour où ton fichier sera regénéré de façon normale, tu perdras tes modifs si tu n’as rien modifié dans /etc/modutils
D’ailleurs, je n’ai pas d’alias concernant ma carte son qui apparaît dans modules.conf, et pourtant le son marche très bien.


#15

Hello à tous,

Je suis tout nouveau sur le forum, ça fait 3 jours que j’ai installé une Debian Sarge (en testing / Etch). Et je viens d’Ubuntu.
J’en avais un peu marre du “pré-maché” d’Ubuntu, même si cela reste le top pour beaucoup d’entre nous, et je me suis donc dirigé en toute logique vers Debian, distro sur laquelle se base Ubuntu. Et j’adore.
Aussi, je ne crache pas sur Ubuntu, loin de là, c’est cette distro qui m’aura définitivement inculqué les notions necessaires et la philosophie générale pour accéder à Debian.

Voilà pour la préésentation et la petite histoire :smiley:

Alors, pour en revenir au sujet:

Je posséde une CL SB Audigy 2 ZS et j’ai méchamment galéré aussi pour la faire fonctionner sous Debian Sarge (Etch)!

Le pire est que je ne serais finallement dire exactement comment faire x_X

J’ai parcouru le web en passant par des dizaines de sites dont celui-ci entre autre.

Finallement, ce qui revient toujours et à surement aidé à faire avancer le schmilblick à été ceci:

Donc, j’avais ce joli message dans gstreamer-properties:

ce que j’ai fait -entre autre- (merci à ce forum) ->

#root> apt-get remove --purge alsa-base alsa-utils #root> apt-get install alsa-base alsa-utils #root> alsaconf

et (merci à je ne sais plus quel forum):

[quote]edit /etc/esound/esd.conf
replace auto_spawn=0 by auto_spawn=1[/quote]

j’ai maintenant bien du son dans gnome, xmms, mplayer, …

mais je repete:

  • ça a été galére (je ne compte pas le nombre de bidouillages que j’ai essayé)
  • j’ai fait bien plus que cela mais je ne serais tout citer de mémoire
  • je reste persuadé que ce sont les méthodes décrites ci-dessus qui ont fait avancer les choses.

prochaine étape: installer des applis KDE (K3b, Kate, Kaffeine) et croiser les doigts pour avoir du son … surtout dans Kaffeine. Le tout sans perdre le son dans Gnome, Xmms & MPlayer :confused:

Tout un programme je vous dis :wink:

Mais quand ça fonctionne, c’est nickel.

Billet d’humeur du jour: j’espere sincerement que des efforts tous particuliers seront investis dans une meilleure architecture du son (intégration et interaction des différents systèmes de son) pour Linux car cela reste relativement très complexe. ALSA, ESD, OSS, ARTS, Gstreamer, … :open_mouth:

Ce petit stress mis à part et une fois résolu, Debian, j’adore. On sent immédiatement la qualité de travail fourni sur cette distribution! Une longue histoire en perspective :wink:

@+


#16

Merci a moi en fait :wink:
et de rien :stuck_out_tongue:


#17

[quote=“Echo”]
Merci a moi en fait :wink:
et de rien :p[/quote]

ECHO président!

Merci en tout cas


#18

Le contraire.
Un fichier autogenere: tu peux le regenerer.
sinon tu te touches pr recuperer un fichier de config fonctionnel.
ptin vi je sais pas comment tu fais. Fuck vi! :laughing:
GNU Emacs powaaaaaaa!

[quote=“BobX”]

[quote=“Echo”]
update-module ne fait a ma connaissance que la mise a jour de modules.conf depuis modutils…
d’ailleurs regarde dans modules.conf si tu retrouves l’alias du module son de ta carte son… Moi, ce n’etait pas le cas, d’ou la necessite de le rajouter a la main.
Depuis cet ajout j’ai du son…

mattotop t’es ou??? :smiley:[/quote]

Le problème de ta modif, c’est que le jour où ton fichier sera regénéré de façon normale, tu perdras tes modifs si tu n’as rien modifié dans /etc/modutils
D’ailleurs, je n’ai pas d’alias concernant ma carte son qui apparaît dans modules.conf, et pourtant le son marche très bien.[/quote]
ca sent le mystere! :question:


#19

[quote=“ghostintheshell”][quote=“Echo”]
Merci a moi en fait :wink:
et de rien :p[/quote]
[/quote]
comment je me la pete dans mon post en fait :smiley:

[quote=“ghostintheshell”]
ECHO président!

Merci en tout cas [/quote]

aaaah je kiff ton smiley je te le pique!!!
:smiling_imp:


#20

[quote=“Echo”][quote=“BobX”]

Je dirais plutôt que ce sont les fichiers générés automatiquement qu’il n’est pas recommander d’éditer à la main, sinon vi powaaaa!
[/quote]
Le contraire.
Un fichier autogenere: tu peux le regenerer.
sinon tu te touches pr recuperer un fichier de config fonctionnel.
[/quote]

C’est tout simple, avant de modifier un fichier de conf, tu le recopies dans un coin. Le jour où tu travailleras sur des serveurs en prod. ça viendra tout seul