Problème avec apache²


#1

Bonjour a tous.
Pourriez vous m’aider a changer l’emplacement root de mon apache ?
Merci.
llaq.


#2

Bonjour,
Il y a beaucoup de docs sur Apache2, celle-ci, entres autres, peut répondre, peut-être, à tes besoins.


#3

Celle-ci est beaucoup plus technique mais permet de se faire une idée de l’étendu des possibles avec un serveur Apache2
https://httpd.apache.org/docs/2.4/getting-started.html


#4

Bonjour @Acksop et @Albert.
Merci,je vais regarder ca !
llaq.
Edit :
En fait,j’ai modifié le repertoire dans le fichier

/etc/apache2/sites-available/000-default.conf

et quand je vais sur mon serveur apache avec mon navigateur,j’ai une erreur 403


#5

Ton dossier contenant tes fichiers accessible par le navigateur, il se trouve où ?
peut tu faire un ll sur ton dossier et le fournir en réponse ?


#6

Hello.
Le dossier est /srv/data/webserver
Voici le résultat du ls -l dans /srv/data :

  total 4
drwxr-xr-x 2 root     root      2 Jul 21 16:18 databases
-rw-r--r-- 1 root     root     10 Jul 21 16:34 index.html
drwxr-xr-x 5 root     root     12 Jul 30 08:55 mysql
drwxr-x--- 2 www-data www-data  3 Jul 21 16:43 webserver 

Si tu veux voir l’erreur,elle est sur lelibreauquotidien.fr
Merci.
llaq.


#7

cela provient surement de ta config apache va voir dans

/etc/apache2/httpd.conf

et ajoute le dossier

/srv/data/

en accès de la même manière qu’avec

/var/www/

#8

Je m’attendais a ce que tu dises ca…
Sauf qu’il y’a un petit problème :grin: :

apache2.conf    conf-enabled  magic           mods-enabled  sites-available
conf-available  envvars       mods-available  ports.conf    sites-enabled

Je n’ai que ca dans

/etc/apache2

Merci.
llaq.


#9

C’est dans le fichier apache2.conf (httpd.conf était l’ancien nom), normalement vers la fin du fichier il y a quelques directives <directory>, il faut que tu décommentes (si mes souvenirs sont bon) celle portant sur /srv et fais la pointer sur ton dossier /srv/data, si elle n’existe pas créé la identiquement à celle qui pointe sur le dossier qui était dans la configuration original de 000-default.conf

En fait j’ai remarqué qu’il fallait que les dossiers racine des virtual host soient référencés pour ne pas avoir d’erreur 403

Enfin pour finir et si ca ne fonctionne toujours pas, donne droit au groupe www-data a ton dossier /srv/data par
#chown root:www-data /srv/data

Vérifie tout de même les droits sur tes fichiers contenus dans le dossier /srv/data/webserver, ils doivent être au minimum en lecture pour le groupe www-data.


#10

Nickel,ca marche parfaitement,je ne sais pas comment te remercier !
En tout cas,je marque le sujet en résolu !
Merci.
llaq.


#11

Bonjour,

J’ai trouvé les conseils et explications de @jmbc bien avisés :


#12

J’ai mis du temps a comprendre … @r2mi: Merci pour ce précieux conseil de @jmbc