Problème avec configuration apache et l'url rewriting


#1

Bonjour à tous,
Je vais vous soliciter pour un petit problème que je rencontre.

Voilà j’ai configuré apache 2.0 sur debian sarge 3.1 avec mysql 4.15, php4, et autres logiciels utiles pour mon site web et je constate un problème qui doit être lié avec l’url rewriting mal géré par ma configuration d’apache.
J’ai constaté aussi que mysql est trop limité au niveau des connexion simultanées et ceci pourrait peut-être être lié à mon problème.

Normalement mon htacess doit procéder a l’url rewriting puisqu’il fonctionne sur mon hébergement mutualisé tutoshop.org/jackanderson
Apparement il aime pas quand on refresh la page et se plante, avez vous une idée de quoi ça pourrait bien venir et comment résoudre le problème ?

Merci d’avance, là je perd ma patience.


#2

l’url rewriting est assez difficile a configurer correctement, dans ta configue d’apache est-ce que tu as bien configurer la poursuite des liens??
symlinksfollow???

httpd.apache.org/docs/2.0/fr/mis … guide.html

Voila de la doc bien interressante dsl je suis a la bourre il faut que j’y aille :slightly_smiling:


#3

Merci de ta réponse

Oui j’ai mis ça:

<Directory /> Options FollowSymLinks AllowOverride All </Directory>
Puis:

Je sais pas si il faut le rajouter ailleurs ?


#4

Est ce que tu peux mettre tes regles d’url rewriting et la config de ton site ce serais plus facile a voir ou se trouve l’erreur :slightly_smiling:


#5

Alors:
httpd.conf

et le .htacess


#6

Ca m’a l’air correcte c’est ca qui m’étonne un peu

Essaye de vérifié les droits d’accès aux pages et regarde aussi sur ton serveur dédié si tu arrive à accéder aux pages directements sans url rewriting.

Si tu n’y arrive pas ça viens de là


#7

Ca semble fonctionner la première fois sur tutoshop.org/jackanderson mais après ça bloque, apparement le problème est lié à mysql et non à apache :confused:

Sur tutoshop.org/galeries/galeri … ckanderson ça fonctionne (l’erreur vient du faite que je n’ai pas encore copié les données dans la base de donnée).
Dois-je mettre des droits spéciaux à l’utilisateur nobody sur les dossiers web ?


#8

C’est bon j’ai trouvé !

[code]#

AllowOverride controls what directives may be placed in .htaccess files.

It can be “All”, “None”, or any combination of the keywords:

Options FileInfo AuthConfig Limit Indexes

AllowOverride None [/code]

L’erreur vennait d’ici, je comrpend pas très bien car je l’avais précisé poru chaque virtual host… enfin bon je suis content.


#9

Le principale c’est que ca marche ++