Problème avec frozen-bubble-data :


#1

Bonsoir,

Sous Knoppix 3.4, j’ai un pb de package avec frozen-bubble-data. Je n’arrive pas à le mettre à jour, ni à le désinstaller.

Voilà les messages d’erreur rencontrés :

root@athlon:/home/???# apt-get remove frozen-bubble-data
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances… Fait
Les paquets suivants seront ENLEVÉS :
frozen-bubble-data
0 mis à jour, 0 nouvellement installés, 1 à enlever et 588 non mis à jour.
127 partiellement installés ou enlevés.
Il est nécessaire de prendre 0o dans les archives.
Après dépaquetage, 5747ko d’espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] o
dpkg : erreur de traitement de frozen-bubble-data (–remove) :
Le paquet est dans un état incohérent - vous devriez
le réinstaller avant d’essayer de le supprimer.
Des erreurs ont été rencontrées pendant l’exécution :
frozen-bubble-data
E: Sub-process /usr/bin/dpkg returned an error code (1)

Sous KPackage, ce paquet comporte un “?” devant son nom (pas bon signe !).
Sous Synaptic, je n’arrive pas non plus à le supprimer ou réinstaller.

Le plus embétant, c’est que je ne peux plus rien installer, desinstaller ou même mettre à jour avec Synaptic à cause de ça (impossible de déselectionner la mise à jour de frozen-bubble-data)…

Help !!

Merci d’avance.


#2

[quote=“Korben Dallas”]Bonsoir,

Sous Knoppix 3.4, j’ai un pb de package avec frozen-bubble-data. Je n’arrive pas à le mettre à jour, ni à le désinstaller.

Voilà les messages d’erreur rencontrés :

root@athlon:/home/???# apt-get remove frozen-bubble-data
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances… Fait
Les paquets suivants seront ENLEVÉS :
frozen-bubble-data
0 mis à jour, 0 nouvellement installés, 1 à enlever et 588 non mis à jour.
127 partiellement installés ou enlevés.
Il est nécessaire de prendre 0o dans les archives.
Après dépaquetage, 5747ko d’espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] o
dpkg : erreur de traitement de frozen-bubble-data (–remove) :
Le paquet est dans un état incohérent - vous devriez
le réinstaller avant d’essayer de le supprimer.
Des erreurs ont été rencontrées pendant l’exécution :
frozen-bubble-data
E: Sub-process /usr/bin/dpkg returned an error code (1)

Sous KPackage, ce paquet comporte un “?” devant son nom (pas bon signe !).
Sous Synaptic, je n’arrive pas non plus à le supprimer ou réinstaller.

Le plus embétant, c’est que je ne peux plus rien installer, desinstaller ou même mettre à jour avec Synaptic à cause de ça (impossible de déselectionner la mise à jour de frozen-bubble-data)…

Help !!

Merci d’avance.[/quote]

Essaies les commandes suivantes avec le paquet fautif.

[code]dpkg --force-reinstreq nom_paquet

dpkg --purge nom_paquet

dpkg --force-all --remove nom_paquet

dpkg – force-all - P nom_paquet [/code]


#3

[quote=“Neuromancien”]
Essaies les commandes suivantes avec le paquet fautif.

Bon, ça part mal…
dpkg m’a l’air plutôt compliqué quand je regarde man dpkg !!
Voilà ce que j’obtiens à la 1ère commande :

root@athlon:/home/???# dpkg --force-reinstreq frozen-bubble-data
dpkg: option de forçage/refus « reinstreq » inconnue

Taper dpkg --help pour une obtenir une aide sur l’installation et la désinstallation des paquets [*] ;
Utiliser dselect pour gérer le paquets de manière plus conviviale ;
Taper dpkg -Dhelp pour une obtenir une liste des valeurs drapeaux de débogage ;
Taper dpkg --force-help pour consulter la liste des options de forçage ;
Taper dpkg-deb --help pour une obtenir une aide sur la manipulation des fichiers .deb ;
Taper dpkg --licence pour voir la licence copyright et l’absence de garantie (GNU GPL) [
].

Les options marquées d’un [*] affichent beaucoup d’informations - tubez-les à travers « less » ou « more » !


#4

quoi que documentée dans man dpkg, le --force-reinstreq n’est pas documenté dans dpkg --force-help (ki donne un détail sur les options de forcage) peut être que le man dpkg n’est pas à jour, donc.
Par contre, j’ai vu l’option --force-remove-reinstreq, ki pourrait peut etre te faire avancer.
Mais si je me souviens bien on peut faire confiance à neuromancien: il a dû débroussailler pas mal sur les possibilité de résolution d’incohérence de paquetage.


#5

[quote=“MattOTop”]quoi que documentée dans man dpkg, le --force-reinstreq n’est pas documenté dans dpkg --force-help (ki donne un détail sur les options de forcage) peut être que le man dpkg n’est pas à jour, donc.
Par contre, j’ai vu l’option --force-remove-reinstreq, ki pourrait peut etre te faire avancer.
Mais si je me souviens bien on peut faire confiance à neuromancien: il a dû débroussailler pas mal sur les possibilité de résolution d’incohérence de paquetage.[/quote]
En fait, à bout d’élément, j’ai restauré une image faite très peu de temps avant. Mon problème a donc disparu de façon radicale, même si je n’ai pas compris l’origine.