Probleme avec fstab


#1

A l’installation de debian j’avais choisit de monter automatiquement une partition fat32, le truc c’est que maintenant j’ai des problemes pour modifier fstab.

Je voudrais résoudre le probleme des accents francais qui n’apparaisse pas et donner les droits de lecture et d’écriture a mon utilisateur.

A l’origine l’unique option existante était “defaults”, en me renseignant un peu j’ai pu lire que ca voulait dire que les options venait de mount, je suppose donc instaurée par l’install.

J’ai donc essayé de rajouter “utf-8,uid=1000” mais la partition ne se montait plus au démarage.

Je donc tenté de supprimer l’option “defaults” et mis comme option:

/dev/sda7 /FAT vfat auto,user,rw,exec,utf-8,uid=1000 0 0

Mais là encore rien ne se monte plus au démarage.


#2

Je ne comprends pas le lien avec les accents …
Voilà le tuto qui m’a aidé à e monter les partitions au démarrage et à les rendre accessibles en lecture/écriture/exécution :
lea-linux.org/cached/index/Admin … fstab.html

Cela donne chez moi :
/dev/hda5 /mnt/donnees vfat defaults,umask=2,gid=1000,uid=0,rw,user 0 0
pour la partition donnees en fat32


#3

je n’ai pas trouvé l’otion “utf-8” ni dans les options générales de mount, ni dans celles spécifique à la fat32.
Je pense que tu devrais plutot jouer avec “codepage=…” (850, normalement, sinon, il faut chercher la liste des codepages), et sinon, “iocharset=…” peut peut être faire qqchose, mais je ne sais pas ce qu’il faut mettre dedans.
En attendant, fais un “man mount”, pour lire la doc sur les options de montage (-o).


#4

En lisant MattOTop, j’ai cherché un peu plus.
utf-8 fait parti des options d’un jeu de caractère
S’il s’agit d’avoir les bon caractères de façon à ce qui est affiché corresponde à ce qui est tapé sur le clavier :

  • se mettre en mode console (petite fenêtre noire en mode texte)
  • de donner les droits administrateur (pour avoir le droit de faire la modification) et taper : su
  • donner le mot de passe root comme demandé
  • l’invite passe de $ à #
  • taper dpkg-reconfigure locales
  • cocher un jeu de caractère adapter
    Le jeu de caractère dépend du pays : belgique, france suisse, canada , … et donc du type de clavier dont on dispose.
    Par exemple pour un clavier français choisir un jeu de caractère commençant par fr_FR est une bonne idée (sur mon PC c’est fr_FR@euro ISO-8859-15)
  • choisir le jeu de caractère effectif, chez moi c’est fr_FR@euro
    Il faut peut-être redémarrer ensuite le serveur graphique pour que la modification soit prise en compte (ALT-CTRL-Ret.Arr)
    En espérant avoir été utile …
    :wink:

#5

Alors codepage n’a rien changer mais la technique de ginkgo biloba à résolu le probleme, en fait ca ne venais simplement pas de fstag.