Problème avec hotplug et udev lors d'un dist-upgrade


#1

Bonjour à tous,

Je suis passé hier soir de Sarge à Etch et j’ai eu un problème lors de cette mise à jour. Voici le message que j’obtiens lors de la commande apt-get dist-upgrade:

apt-get dist-upgrade Lecture des listes de paquets... Fait Construction de l'arbre des dépendances... Fait Calcul de la mise à jour... Fait Les paquets suivants seront ENLEVÉS : hotplug inkscape libgc1 libopenh323-1.15.2 libosp4 libostyle1 libpt-1.8.3 libsigc++-1.2-5c102 Les NOUVEAUX paquets suivants seront installés : ca-certificates dmidecode g++-4.0 gcc-4.0 kdeartwork-emoticons kdenetwork-kfile-plugins laptop-detect libaa1 libgc1c2 libmagick9 libopenh323-1.15.3c2 libosp4c2 libostyle1c2 libpt-1.8.3c2 librapi2-tools libsigc++-1.2-5c2 libstdc++6-4.0-dev linux-image-2.6-686 linux-image-2.6.12-1-686 linux-sound-base openssl python-ipy python2.3-ipy tex-common Les paquets suivants ont été conservés : grip Les paquets suivants seront mis à jour : aalib1 alsa-base alsa-utils apt apt-utils aptitude base-config foomatic-gui g++ gcc gimp gimp-data gnomemeeting hal imagemagick kdeartwork kdenetwork kernel-image-2.6-686 libapt-pkg-perl libcurl3 libpt-plugins-oss libpt-plugins-v4l2 openjade python-foomatic synaptic synce-dccm tasksel texinfo udev w3m 30 mis à jour, 24 nouvellement installés, 8 à enlever et 1 non mis à jour. Il est nécessaire de prendre 0o/53,1Mo dans les archives. Après dépaquetage, 56,7Mo d'espace disque supplémentaires seront utilisés. Souhaitez-vous continuer ? [O/n] o Préconfiguration des paquets ... dpkg : hotplug : problème de dépendance, mais suppression comme demandé : udev dépend de hotplug (>= 0.0.20040329-17). (Lecture de la base de données... 113690 fichiers et répertoires déjà installés.) Suppression de hotplug ... (Lecture de la base de données... 113667 fichiers et répertoires déjà installés.) Préparation du remplacement de udev 0.056-3 (en utilisant .../archives/udev_0.071-1_i386.deb) ... ln: `/etc/udev/rules.d/z55_hotplug.rules': fichier existant. dpkg : erreur de traitement de /var/cache/apt/archives/udev_0.071-1_i386.deb (--unpack) : le sous-processus pre-installation script a retourné une erreur de sortie d'état 1 Des erreurs ont été rencontrées pendant l'exécution : /var/cache/apt/archives/udev_0.071-1_i386.deb E: Sub-process /usr/bin/dpkg returned an error code (1)

hotplug et désinstaller et udev plante lors de l’installation.

J’ai résinstaller hotplug et j’ai fait un apt-get upgrade mais voici le message de apt-get:

apt-get upgrade Lecture des listes de paquets... Fait Construction de l'arbre des dépendances... Fait Les paquets suivants ont été conservés : aalib1 alsa-base alsa-utils apt apt-utils aptitude base-config foomatic-gui g++ gcc gimp gimp-data gnomemeeting grip hal imagemagick inkscape kdeartwork kdenetwork kernel-image-2.6-686 libapt-pkg-perl libcurl3 libpt-plugins-oss libpt-plugins-v4l2 openjade python-foomatic synaptic synce-dccm tasksel texinfo udev w3m 0 mis à jour, 0 nouvellement installés, 0 à enlever et 32 non mis à jour.

La mise à jour n’est pas terminée.

Avez-vous une idée ?

ceci-cela


#2

essayes d’installer la version etch de hotplug, avant de refaire ton upgrade:
apt-get -t testing install hotplug

sinon, tu peux aussi regarder ce que donne un apt-get dselect-upgrade


#3

me renvoie que c'est la version la plus récente qui est installé.

[code]apt-get dselect-upgrade[/code]

a installé quelques packages supplémentaires mais l'installation du package de udev plante après la désinstallation de hotplug.

me renvoie que c’est la version la plus récente qui est installé.

a installé quelques packages supplémentaires mais l’installation du package de udev plante après la désinstallation de hotplug.


#4

j’ai fait la même migration que toi il y a peu, et j’ai eu des pb de ce coté là, mais je ne me souviens plus comment je l’ai règlé… :frowning:
En attendant, chez moi, je n’ai effectivement plus de paquet hotplug: même s’il existe en etch, j’ai:console@emeraude:~$ sudo apt-get install hotplug -s Password: Lecture des listes de paquets... Fait Construction de l'arbre des dépendances... Fait Paquets suggérés : ifrename Les paquets suivants seront ENLEVÉS : gnome-desktop-environment gnome-volume-manager hal hal-device-manager udev usbmount Les NOUVEAUX paquets suivants seront installés : hotplug 0 mis à jour, 1 nouvellement installés, 6 à enlever et 29 non mis à jour. Remv gnome-desktop-environment [1:2.10.2.3] Remv gnome-volume-manager [1.2.1-1] Remv hal-device-manager [0.4.8-8] Remv hal [0.4.8-8] Remv usbmount [0.0.14] Remv udev [0.071-1] Inst hotplug (0.0.20040329-25 Debian:testing) Conf hotplug (0.0.20040329-25 Debian:testing)

Sinon, as tu essayé de voir ce que donne la suppression d’hotplug ?

sudo apt-get remove hotplug -s --purge(j’ai imaginé que tu n’avais pas customisé hotplug, d’ou le --purge)
PS:faire plusieurs upgrade de suite te permettra peut être d’installer un peu plus de paquets, je crois (même si udev et les paquets en dépendant restent en erreur…[/img]


#5

Ok, mon problème est résolu, j’ai désinstallé udev:

Les paquets suivants ont été désinstallés:

Suppression de gnome-desktop-environment …
Suppression de gnome-volume-manager …
Suppression de hal …
Suppression de udev …

J’ai fait un

Les paquets non mis à jour ont été mis à jour.

J’ai installé udev seul:

[code]apt-get install udev
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances… Fait
Les paquets suivants seront ENLEVÉS :
hotplug
Les NOUVEAUX paquets suivants seront installés :
udev
0 mis à jour, 1 nouvellement installés, 1 à enlever et 1 non mis à jour.
Il est nécessaire de prendre 0o/317ko dans les archives.
Après dépaquetage, 659ko d’espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? o
ATTENTION : les paquets suivants n’ont pas été authentifiés.
udev
Faut-il installer ces paquets sans vérification (o/N) ? o
(Lecture de la base de données… 116963 fichiers et répertoires déjà installés.)
Suppression de hotplug …
Sélection du paquet udev précédemment désélectionné.
(Lecture de la base de données… 116940 fichiers et répertoires déjà installés.)
Dépaquetage de udev (à partir de …/archives/udev_0.071-1_i386.deb) …


  • Please purge the hotplug package!

dpkg : avertissement - impossible de supprimer l’ancien fichier « /etc/dev.d/net » : Le répertoire n’est pas vide.
Paramétrage de udev (0.071-1) …
Installation de la nouvelle version du fichier de configuration /etc/init.d/udev …
Installation de la nouvelle version du fichier de configuration /etc/udev/udev.conf …
Installation de la nouvelle version du fichier de configuration /etc/udev/compat-full.rules …
Installation de la nouvelle version du fichier de configuration /etc/udev/compat.rules …
Installation de la nouvelle version du fichier de configuration /etc/udev/permissions.rules …
Installation de la nouvelle version du fichier de configuration /etc/udev/udev.rules …
Installation de la nouvelle version du fichier de configuration /etc/udev/scripts/scsi-devfs.sh …
Installation de la nouvelle version du fichier de configuration /etc/udev/cd-aliases.rules …
Installation de la nouvelle version du fichier de configuration /etc/udev/devfs.rules …
cat: /sys/kernel/hotplug_seqnum: Aucun fichier ou répertoire de ce type
[/code]

Attention, je l’ai installé sans vérification !

Puis j’ai réinstallé gnome-desktop-environment:

[code] apt-get install gnome-desktop-environment
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances… Fait
Les paquets supplémentaires suivants seront installés :
gnome-volume-manager hal
Paquets suggérés :
gnome-audio hal-device-manager
Paquets recommandés :
dasher gnome-mag gnopernicus gok gnome-accessibility-themes gthumb
Les NOUVEAUX paquets suivants seront installés :
gnome-desktop-environment gnome-volume-manager hal
0 mis à jour, 3 nouvellement installés, 0 à enlever et 1 non mis à jour.
Il est nécessaire de prendre 0o/380ko dans les archives.
Après dépaquetage, 1610ko d’espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer [O/n] ? o
ATTENTION : les paquets suivants n’ont pas été authentifiés.
hal gnome-volume-manager gnome-desktop-environment
Faut-il installer ces paquets sans vérification (o/N) ? o
Sélection du paquet hal précédemment désélectionné.
(Lecture de la base de données… 117006 fichiers et répertoires déjà installés.)
Dépaquetage de hal (à partir de …/archives/hal_0.4.8-8_i386.deb) …
Removing obsolete conffile /etc/dev.d/block/hal-unmount.dev …
Sélection du paquet gnome-volume-manager précédemment désélectionné.
Dépaquetage de gnome-volume-manager (à partir de …/gnome-volume-manager_1.2.1-1_i386.deb) …
Sélection du paquet gnome-desktop-environment précédemment désélectionné.
Dépaquetage de gnome-desktop-environment (à partir de …/gnome-desktop-environment_1%3a2.10.2.3_all.deb) …
Paramétrage de hal (0.4.8-8) …
Installation de la nouvelle version du fichier de configuration /etc/dbus-1/event.d/20hal …
Installation de la nouvelle version du fichier de configuration /etc/udev/scripts/device-removable.sh …
Installation de la nouvelle version du fichier de configuration /etc/udev/hal.rules …
Stopping Hardware abstraction layer: hald.
Stopping system message bus: dbus-1.
Starting system message bus: dbus-1.
Starting Hardware abstraction layer: hald.

Paramétrage de gnome-volume-manager (1.2.1-1) …

Paramétrage de gnome-desktop-environment (2.10.2.3) …
[/code]

Tout mon système est mis à jour.

Merci à MattOTop pour ses conseils.

ceci-cela


#6

J’ai un peu le même problème : lors d’une mise à jour d’udev (0.091-2), j’ai le message d’erreur suivant qui est apparu :[quote]**************************************************************

  • Please purge the hotplug package!
  • (/etc/init.d/hotplug has been found on this system)
    **************************************************************[/quote]Moi Je veux bien, mais je fais comment ? Je supprime purement et simplement le fichier correspondant ?
    Tant que j’y suis, je supprime aussi /etc/init.d/hotplug-net ?

Je ne suis pas du tout sûr de moi là. J’ai pourtant purgé hotplug lors de la dernière mise à jour d’udev qui m’a signalé la même erreur…


#7

[quote=“Korben Dallas”]J’ai un peu le même problème : lors d’une mise à jour d’udev (0.091-2), j’ai le message d’erreur suivant qui est apparu :[quote]**************************************************************

  • Please purge the hotplug package!
  • (/etc/init.d/hotplug has been found on this system)
    **************************************************************[/quote]Moi Je veux bien, mais je fais comment ? Je supprime purement et simplement le fichier correspondant ?
    Tant que j’y suis, je supprime aussi /etc/init.d/hotplug-net ?

Je ne suis pas du tout sûr de moi là. J’ai pourtant purgé hotplug lors de la dernière mise à jour d’udev qui m’a signalé la même erreur…[/quote]aptitude purge hotplugouapt-get remove hotplug --purge, non ?


#8

aptitude, je l’ai “remové” depuis que que j’ai eu des soucis de comportement avec.
et le apt-get remove hotplug --purge, je l’ai fait l’autre jour, mais il semble que ça m’a laissé des traces, d’où mon post.


#9

alorsupdate-rc.d -f hotplug remove à tous hasards, puis, un éventuel rm /etc/init.d/hotplug s’il reste des traces.


#10

J’ai fait tout ça :
update-rc.d m’a renvoyé Removing any system startup links for /etc/init.d/hotplug …
/etc/rcS.d/S40hotplug
et le rm m’a nettoyé le reste.

Je vous tiendrai au courant au prochain boot (demain soir).

Merci :slightly_smiling: