Problème avec le chipset réseau Realtek R8125

Bonjour, je viens de changer la carte mère de mon PC, tout fonctionne correctement, mais il reste un dernier détail logiciel à régler : le réseau ne fonctionne pas.
Ma carte mère est équipée du chipset réseau Realtek R8125, or ce driver n’est intégré au noyau linux qu’à partir de la version 5.9. Et comme mon PC tourne avec une Debian 10 stable, je ne suis qu’au noyau 4.19. :frowning:
Auriez-vous une solution pour que je puisse activer ce chipset ?

Merci de vos réponses. :slight_smile:

Bonjour

as tu penser à prendre un noyau plus récent sur debian-backport?

Ça ne posera aucun problème de passer de 4.19 à 5.9 ? :thinking:

Le seul problème sera sans doute lié à la gestion des modules via DKMS car les sources ne sont pas toujours disponibles.
Les sources existe pour le 5.10 en backport, donc tu peux essayer :wink:

Pour chercher soit via apt search en cli soit via le web avec comme mots clé debian package le_nom_du_paquet

1 J'aime

il n’y a même pas à passer sou sle noyau 5.9 sauf si celui ci est installé en dependances. Il suffit de faire apt -t buster-backports install firmware-realtek

j’ai un Asrock 4300U dont j’ai pu installer l’interface 2,5G sans problème.

2 J'aimes

Merci pour cette réponse qui semble proche de ce que j’ai fait.

J’ai opté pour cette méthode et aujourd’hui, ça marche sans problème. :smiley:

je préfère rester aussi stable que possible :slight_smile:

En espérant que ce ne soit pas par l’installation du PPA, sinon un peu de lecture de la « FrankenDebian » serait bien, et s’attendre dans le temps à son lot de problèmes.

Tu as bien raison :smiley: :stuck_out_tongue: