Problème avec le fichier fstab


#1

Salut à tous !

Je début totalement en configuration serveur, donc j’ai commencé le tuto de How to forge : The Perfect Server - Debian Wheezy mais je me retrouve bloqué à l’étape d’installation de PureFTPd And Quota.

Après avoir relancé Pure FTPd, il faut modifier le fichier /etc/fstab pour y ajouter la ligne suivante :
",usrjquota=quota.user,grpjquota=quota.group,jqfmt=vfsv0" à la partition avec le point de montage /.

Dans le tuto le fichier /etc/fstab ressemble a ça :

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
/dev/mapper/server1-root /               ext4    errors=remount-ro,usrjquota=quota.user,grpjquota=quota.group,jqfmt=vfsv0 0       1
# /boot was on /dev/sda1 during installation
UUID=46d1bd79-d761-4b23-80b8-ad20cb18e049 /boot           ext2    defaults        0       2
/dev/mapper/server1-swap_1 none            swap    sw              0       0
/dev/sr0        /media/cdrom0   udf,iso9660 user,noauto     0       0

L’ennuis c’est que quand j’ouvre le mien, il ne ressemble pas du tout !

proc  /proc       proc    defaults    0    0
none  /dev/pts    devpts  rw,gid=5,mode=620    0    0
none  /run/shm    tmpfs   defaults    0    0

Et donc je ne sais pas du tout quoi pour le coup ! Une idée ?

Dans les commentaires du tuto, quelqu’un confronté au même problème pose la question (howtoforge.com/perfect-serv … /#comments)

On lui réponds ça :
“All what you need to do is a reweite for the whole server/vhost”

server { listen 80; server_name you.server.domain.net; rewrite ^/(.*)$ /phpmyadmin/$1; <---------------------------- CETTE LIGNE LÀ EST EN GRAS ----- location /phpmyadmin { root /usr/share; index index.php index.html index.htm; location ~ ^/phpmyadmin/(.+\.php)$ { try_files $uri =404; root /usr/share/; fastcgi_pass unix:/var/run/php5-fpm.sock; fastcgi_index index.php; fastcgi_param SCRIPT_FILENAME $request_filename; include /etc/nginx/fastcgi_params; fastcgi_param PATH_INFO $fastcgi_script_name; fastcgi_buffer_size 128k; fastcgi_buffers 256 4k; fastcgi_busy_buffers_size 256k; fastcgi_temp_file_write_size 256k; fastcgi_intercept_errors on; } location ~* ^/phpmyadmin/(.+\.(jpg|jpeg|gif|css|png|js|ico|html|xml|txt))$ { root /usr/share; } } location /phpMyAdmin { rewrite ^/* /phpmyadmin last; } }

Cependant il ne précise pas où il faut placer ce bout de code !

En gros je suis perdu ! Quelqu’un a t’il une solution ?

Merci d’avance !


#2

bah si, ils le disent :


#3

Yes, j’ai placé le code dans le fichier /etc/nginx/sites-available/default, j’ai relancé nginx mais aucun changement dans mon fichier /etc/fstab. Je ne peux toujours pas placer la ligne indiqué dans le tuto ça je n’ai pas de ligne “/dev/mapper/monserveur-root / ext4”

j’ai peut être fait une erreur, voici mon fichier d’nginx :

server {
        #listen   80; ## listen for ipv4; this line is default and implied
        listen   [::]:80 default_server ipv6only=on; ## listen for ipv6

        root /usr/share/nginx/www;
        index index.php index.html index.htm;

        # Make site accessible from http://localhost/
        server_name serveur.duhrjeremy.com;

        location / {
                # First attempt to serve request as file, then
                # as directory, then fall back to displaying a 404.
                try_files $uri $uri/ /index.html;
                # Uncomment to enable naxsi on this location
                # include /etc/nginx/naxsi.rules
        }

        location /doc/ {
                alias /usr/share/doc/;
                autoindex on;
                allow 127.0.0.1;
                allow ::1;
                deny all;
        }

        # Only for nginx-naxsi used with nginx-naxsi-ui : process denied requests
        #location /RequestDenied {
        #       proxy_pass http://127.0.0.1:8080;    
        #}

        error_page 404 /404.html;

        # redirect server error pages to the static page /50x.html
        #
        error_page 500 502 503 504 /50x.html;
        location = /50x.html {
        root /usr/share/nginx/www;
        }

        # pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000
        #
        location ~ \.php$ {
        #       fastcgi_split_path_info ^(.+\.php)(/.+)$;
        #       # NOTE: You should have "cgi.fix_pathinfo = 0;" in php.ini
        #
        #       # With php5-cgi alone:
        #       fastcgi_pass 127.0.0.1:9000;
        #       # With php5-fpm:
                try_files $uri =404;
                fastcgi_pass unix:/var/run/php5-fpm.sock;
                fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
                fastcgi_index index.php;
                include fastcgi_params;
        }
        rewrite ^/(.*)$ /phpmyadmin/$1;
        location /phpmyadmin {
        root /usr/share/;
        index index.php index.html index.htm;
        location ~ ^/phpmyadmin/(.+\.php)$ {
        try_files $uri =404;
        root /usr/share/;
        fastcgi_pass unix:/var/run/php5-fpm.sock;
        fastcgi_param HTTPS $https; # <-- ajouter cette ligne
        fastcgi_index index.php;
        fastcgi_param SCRIPT_FILENAME $request_filename;
        include /etc/nginx/fastcgi_params;
        fastcgi_param PATH_INFO $fastcgi_script_name;
        fastcgi_buffer_size 128k;
        fastcgi_buffers 256 4k;
        fastcgi_busy_buffers_size 256k;
        fastcgi_temp_file_write_size 256k;
        fastcgi_intercept_errors on;
        }
        location ~* ^/phpmyadmin/(.+\.(jpg|jpeg|gif|css|png|js|ico|html|xml|txt))$ {
        root /usr/share/;
}
}
        location /phpMyAdmin {
        rewrite ^/* /phpmyadmin last;
        }
        ##

Une idée ? Merci pour la réponse en tout cas !