Problème avec les accents en console


#1

Bonsoir tout le monde.
J’ai un problème assez déconcertant. Pas moyen de taper un seul caractère accentué lorsque je suis en console alors ça marche très bien quand le système me demande mon login.
Je m’explique :

  • au prompt "login: ", les accents marchent bien, je peux taper un “é” sans problème, il s’affiche
  • après m’être logué, plus rien, en appuyant sur la touche “é”, il ne se passe rien…

Ca fait déjà un petit bout de temps que je tourne en rond, si quelqu’un pouvait me proposer une solution…

Merci.


#2

tu peux nous montrer ce que donne comme résultat la commande echo $LANG ?


#3

Voici le résultat de la commande :

[code]leeno:~# echo $LANG

leeno:~#
[/code]


#4

essayes un :

export LANG=fr_FR@euro

si ca fonctionne correctement, tu pourras rajouter cette ligne dans ton ~/.bashrc


#5

C’est bon, j’y suis arrivé !! J’ai trouvé je ne sais plus où qu’on pouvait créer un fichier ~/.inputrc
Le mien donne ceci :

set meta-flag on set convert-meta off set input-meta on set output-meta on

Merci pour ton aide Sylvain, je ne sais pas si c’est ta commande bash ou le fichier .inputrc qui a joué un grand rôle … mais le principale c’est que ça fonctionne correctement.


#6

[quote=“fogoh”]Ca fait déjà un petit bout de temps que je tourne en rond, si quelqu’un pouvait me proposer une solution…

Merci.[/quote]

As tu installe le package locales ? De plus, meme si c’est le cas, sur une woody, il faut savoir que le package est bugge, il faut refaire un dpkg-reconfigure locales apres l’install

choisis FR 8859-1 et posittionne tes variables d’environnement comme il faut (cf man locale(1) )

++


#7

tznt qu’à faire prend l’utf8 (c’est bien TM :wink: