Probleme avec make


#1

bonjour,
je débute sous debian, et j’ai besoin de la commande make pour installer pas mal de choses. J’ai essayé apt-get install make, mais ca ne marche pas, ça me dit

"erreur de traitement de /var/cache/apt/archives/fileutils_4.1-10_i386.deb (–unpack) : tentative de remplacement de " /bin/chgrp “, qui appartient aussi au paquet coreutils”

y a-t-il un moyen d’arranger ça ? ou un autre moyen pour avoir la commande make ? javascript:emoticon(’:roll:’)

merci d’avance


#2

j’ai bien une solution, mais c’est un peu crade et j’ai peur de me faire incendier par les puristes.
tu fais un dpkg --force-all --install /var/cache/apt/archives/fileutils_4.1-10_i386.deb et ça t’installera ton paquet, en gueulant un peu certe, mais ça a l’avantage de marcher :wink:


#3

as tu essayé d’installer un autre make, compatible, plutot que de casser les dependances ?
euh… gmake, je crois.


#4

euh, la solution que je propose ne casse pas les dépendances. Ben oui, le message d’erreur n’a rien à voir avec les dépendances, mais vient d’un fichier présent dans plusieurs package (et g l’impression que ça arrive de plus en plus souvent)


#5

Tu as raison BobX (mais ki c ce bob :laughing: ), j’ai fait mon technoide…
J’ai aussi eu quelques “recouvrements” de paquetages, mais je suis en testing (pour l’instant, cf post sur mon downgrade), je ne sais pas si il y en a beaucoup avec une stable.
Sinon, j’evite de proceder au forcage, j’ai eu des problemes penibles de désinstallation aprés ca (script post remove qui plante, et incapacité a réinstaller) C’etait il y a longtemps, mais ca m’a bien fait #’$% !!!.