Problème clavier sur menu grub

Tags: #<Tag:0x00007feddca1fbb8> #<Tag:0x00007feddca1f870>

Bonjour,
Sur mon PC j’ai une installation windows 10, sur deux disques (0 et 2).
sur le disque 1 j’avais installé une debian, que j’ai du supprimer suite à un probleme sur le disque.
j’ai installé une Debian 10.9 sur un disque dur nvme.
Tout s’est bien passé, y compris l’installation de grub.
seulement voilà, impossible d’utiliser le menu grub.
le clavier ne réagit pas. Il est systématiquement bloqué. Il se lance sur le système par defaut, windows, et ensuite tout va bien.

Si je lance directement le disque debian avec le boot manager, je tombe sur un shell grub (qui me permet quand même de lancer debian, mais c’est loin d’etre convivial.

Je n’ai pas réussi à comprendre d’où venait le blocage du clavier (filaire relier à port usb 3 ou usb 2).
pas de souris non plus.

Tout marche bien en dehors du grub.

Quelqu’un aurait-il une piste?
merci d’avance.

Par défaut GRUB sélectionne la première entrée de menu, qui est celle du système l’ayant installé, Debian ici. Est-ce toi qui as modifié l’entrée par défaut de GRUB ? Comment ?

Quel boot manager ? Celui de Windows ? Celui du BIOS ?
Est-ce un amorçage BIOS ou UEFI ?

Comment fais-tu pour ancer Debian à partir de ce shell ?

je l’ai modifié via grub-organizer, juste l’ordre d’affichage du menu.

le boot manager du BIOS pardon. UEFI uniquement sur mon PC

ls pour savoir les disques
je fait un ls du disque pour etre sur que c’est le bon
puis le truc habituel:

root=(hdx,1)
linux /vmlinuz.xxxx root=/dev/mapper/vg00-root
initrd /initrd-xxxx
boot

et là j’ai mon debian qui demarre impec

Est-il possible que ce soit cela qui bloque le clavier ?
Peux-tu remettre l’entrée Debian par défaut ?

Que sélectionnes-tu exactement ? Une entrée libellée « debian » ou un disque ?

Si le comportement de GRUB est différent selon que tu laisses le PC démarrer tout seul ou tu forces avec le menu de boot UEFI; pour moi il n’y a qu’une explication possible : ce n’est pas le même GRUB. Un GRUB sans menu est typiquement un reste d’une ancienne installation supprimée.

Pourrais-tu exécuter

efibootmgr -v

dans les deux cas ?
Tu peux aussi installer boot-info-script et exécuter bootinfoscript pour générer un rapport sur l’amorçage.

en fait non, j’avais eu le problème déjà juste avant. j’ai cru que j’avais fait une erreur alors j’ai réinstallé le système. Mais j’avais eu des problems sur une autre installation sur un autre disque;
Sur l’installation précédente, j’avais contourné le problème en mettant le grub surt le disque debian et en modifiant le boot manager pour demarrer sur le disque debian plutot que sur le disque 0 qui est windows 10.

j’ai essayé les deux, soit l’entrée debian, soit le disque, avec le disque j’ai le shell grub avec l’entrée debian, je n’ai rien.

si je laisse le PC demarrer tout seul j’ai le shell grub.
Actuellement j’ai mi en demarrage bios le boot manager windows, car c’est windows que j’utilise le plus.

Il faut que j’essaye, je ferais ça demain car vu l’heure, pas trop envie maintenant.

Comment fais-tu apparaître le menu de GRUB où le clavier est inopérant ?

Quand je demarre sur l’entrée « debian » j’ai le menu grub clavier bloqué
Quand j’utilise l’entrée disque debian, j’ai le shell grub
Quand j’utilise l’entrée Windows boot manager, j’ai directement windows

Que voulais-tu dire par « avec l’entrée debian, je n’ai rien » ?

C’est une erreur, l’entrée debian me donne le menu grub bloqué (sauf entrée)

Tu veux dire que la touche Entrée fonctionne dans le menu ?

je n’en suis pas certain, vu que le delai d’attente est très court

Tu peux l’augmenter.

Bonjour,
moi aussi j’ai le même soucis de clavier inopérant sous le menu Grub. Aucune touche n’est prise en compte pas même le touche « entrée ».
Cela ne me gène pas outre mesure étant donné que je démarre windows 3 fois par an. Dans ce cas je place le disque dur de windows en premier dans le bios (windows est sur un disque à part).
j’ai le problème depuis 2 ans environ, cela remonte à peu près à mon passage vers Bullseye/testing. (mais pas sûr qu’il y ai un lien)
cela vient peut être du clavier car j’en ai changé à la même époque et suis passé d’un clavier avec port PS2 vers port Usb.

j’ai essayé plusieurs claviers différents (sauf PS/2)

mais avant j’avais fait une installation identique sur la même machine sur un disque hybrid ou sata sans avoir ce problème

Je doute que cela provienne du type de clavier ou de la configuration du BIOS (option USB legacy) car le clavier fonctionne bien avec l’autre GRUB (en ligne de commande).

le /etc/default/grub ne me semble pas avoir quoique ce soit qui pose problème pourtant:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="video=1024x768 quiet splash"
GRUB_CMDLINE_LINUX="apparmor=1 security=apparmor audit=1 audit_backlog_limit=8192"
GRUB_TERMINAL_INPUT=at_keyboard

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console
GRUB_TERMINAL_INPUT=at_keyboard

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=1024x768
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Et si tu commentes toutes les occurrences de ce cette ligne et exécutes update-grub pour reconstruire grub.cfg ?

en fait j’ai fait une reinstallation (sur mon pc une install full Cinnamon ne prend que 12 minutes.)
je n’ai plus qu’un debian, mais quand je le demarrage je me retrouve sur un shell grub, je n’ai meme plus le menu grub… Pourtant le grub s’est bien installé sur le disque debian.

j’ai du faire une erreur lors de l’installation, je n’ai plus qu’à recommencr

Plutôt que réinstaller, il vaudrait mieux comprendre ce qui ne va pas. Comme on l’a vu, il y avait au moins deux GRUB différents, et il est probable que c’est encore un ancien GRUB lié à une précédente installation qui se lance au lieu de celui de la dernière installation.

Ma proposition de générer un rapport avec bootinfoscript tient toujours.