Probleme d'affichage/clavier Xorg


#1

Bonjour

Suite à un upgrade de ma distribution (debian unstable), mon xorg et un
peu HS : chaque pression sur une touche de mon clavier semble changer la
résolution de l’ecran sans pour autant ecrire quoi que ce soit (donc
impossible de se logguer avec gdm par exemple).

Jai essayer de changer les drivers graphiques (jai tester les nvidia, nv
et vga), jai desinstaller xorg, enlever les fichier de conf, et
reinstaller le tout, sans succes.

Quelqu’un à t’il deja eu le meme probleme ?


#2

tu as essayé un dpkg-reconfigure gdm
Ca te fait la meme chose avec un autre windows manager?
essaye quand meme dpkg-reconfigure xserver-xorg


#3

jai fait le dpkg-reconfigure de gdm et xorg mais aucune difference.
Jai essayé de lancer directement xfce avec un startxfce4 et jai le meme probleme.

jai essayer aussi avec kdm et pareil …


#4

[quote=“Ashgenesis”]tu as essayé un dpkg-reconfigure gdm
Ca te fait la meme chose avec un autre windows manager?
essaye quand meme dpkg-reconfigure xserver-xorg[/quote]
Ash: regardes un peu, et tu verra qu’Xorg en sid est salement eclaté en petits paquets, et que l’organisation a beaucoup bougé. Je ne crois pas que le nom du paquet server de la nouvelle suite xorg soit xserver-xorg.
Nao: il est possible que tu essayes d’installer les paquets sid en te basant sur les noms que les paquets avaient avant. Essayes un truc: desinstalles tout se qui concerne xorg, puis tu apt-get install xorg. Juste xorg, et rien d’autre. Sinon, toujours en sidregardes s’il n’y a pas un paquet xorg specifique à ta carte graphique (il m’a semblé que les serveurs spécifiques étaient dans des paquets séparés).
Et sinon, je te rappelle qu’xorg fonctionne en général trés bien en autodetection, c.à. d. sans xorg.conf du tout. A tester.
Ceci étant dit, j’ai installé cette suite xorg sur une machine au bureau (je crois, mais j’etais un peu pressé, et c’est une sid, alors…), mais je n’ai pas encore eu l’occasion de la tester.
Je regarderais demain si j’ai un peu de temps.


#5

En effet, je viens de me déplacer sur une Sid et c’est vrai qu’il y a maintenant un paquet
xorg
chez moi, c’est tjrs le
xserver-xorg qui est installé et qui fonctionne alors je me demande ce qu’il convient de faire ?
Pour répondre à notre ami, à qui je souhaite la bienvenue, je lui dirais déjà qu’il devrait tenir compte des post-it en début de forum et ds le cas présent, il ns aurait envoyé son
/etc/X11/xorg.conf
ce qui donnerait ptet une voie.


#6

Bon, j’ai fait pas mal de changement dans ma distrib et suite à la réinstallation de tout concernant le serveur X … plus rien ne marche ^^
Maintenant si je fait un startx, il me dit :
/usr/X11R6/bin/xinit: Server error.

[EDIT]
amélioration : maintenant j’ai :
/usr/X11R6/bin/xinit: No such file or directory (errno 2): unable to connect to X server
/usr/X11R6/bin/xinit: No such process (errno 3): Server error.

jai aussi tester de lancer Xorg (avec la commande Xorg, et jai bien un affichage)
[/EDIT]
Je sens que j’ai oublier de reinstallé un truc mais je sais pas quoi…


#7

Ca sent un lien symbolique rompu, qu’y a t’il dans /var/log/Xorg.0.log ?


#8

effectivement c’est juste le lien X qui etait mal redirigé.
Donc maintenant ca marche ^^ Mai jai plus de souris :stuck_out_tongue:

et voila mon xorg.conf

[code]# xorg.conf (Xorg X Window System server configuration file)

This file was generated by dexconf, the Debian X Configuration tool, using

values from the debconf database.

Edit this file with caution, and see the xorg.conf manual page.

(Type “man xorg.conf” at the shell prompt.)

This file is automatically updated on xserver-xorg package upgrades only

if it has not been modified since the last upgrade of the xserver-xorg

package.

If you have edited this file but would like it to be automatically updated

again, run the following commands as root:

cp /etc/X11/xorg.conf /etc/X11/xorg.conf.custom

md5sum /etc/X11/xorg.conf >/var/lib/xfree86/xorg.conf.md5sum

dpkg-reconfigure xserver-xorg

Section "Files"
FontPath “unix/:7100” # local font server
# if the local font server has problems, we can fall back on these
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/CID"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
EndSection

Section "Module"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option “XkbRules” "xorg"
Option “XkbModel” "pc105"
Option “XkbLayout” "fr"
Option “XkbVariant” "latin9"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option “Device” "/dev/input/mice"
Option “Protocol” "Auto"
Option “Emulate3Buttons” "true"
Option “ZAxisMapping” "4 5"
EndSection

Section "Device"
Identifier "NVIDIA Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro]"
Driver "nv"
VideoRam 128000
EndSection

Section "Monitor"
Identifier "Écran générique"
Option "DPMS"
HorizSync 28-49
VertRefresh 43-72
EndSection

Section "Screen"
Identifier "Default Screen"
Device "NVIDIA Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro]"
Monitor "Écran générique"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes “1024x768” “800x600” “720x400” "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes “1024x768” “800x600” “720x400” "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes “1024x768” “800x600” “720x400” "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes “1024x768” “800x600” “720x400” "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes “1024x768” “800x600” “720x400” "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes “1024x768” “800x600” “720x400” "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection
[/code]


#9

[quote=“MattOTop”]Ash: regardes un peu, et tu verra qu’Xorg en sid est salement eclaté en petits paquets, et que l’organisation a beaucoup bougé. Je ne crois pas que le nom du paquet server de la nouvelle suite xorg soit xserver-xorg.[/quote]Oups :blush:, répondu trop vite vais aller jeter un oeil a xorg en sid :slightly_smiling: