Problème d'affichage des polices fichiers pdf

Tags: #<Tag:0x00007fd6e661e418> #<Tag:0x00007fd6e661e1e8>

Bonjour,

J’ai un problème d’affichage des polices sur les pdf. Je suis sous la suite gnome sous debian 11
Ceux-ci ont été créés par latex sous la version pdf 1.2.
Les logiciels debian tels que document-viewer ou atril-document ouvrent les documents mais refusent d’afficher le contenu des polices. Les hyperliens fonctionnent parfaitement, seul les polices refusent de s’afficher. Pourtant quand je les charge par firefox aucuns problèmes d’encodage de polices.

Les propriétés d’un fichier pdf :
pdf properties

Un exemple de la non prise en charge des polices :
exemple
Ici les images contenues dans le pdf sont affichées mais pas les polices, le carré rouge correspond à un hyperlien.

Des idées pour afficher les polices via les applications ?

Merci d’avance pour vos retours.

Bonjour,
Je ne suis pas sûr que cela te soit utile, mais c’est très intéressant.
https://linuxfr.org/users/pied/journaux/pdf-mais-que-fait-la-police
Bonne soirée !

2 J'aime

Bonjour,

As-tu essayé de générer un PDF plus récent (1.5 par exemple) ?
Quelles polices utilises-tu ?

Je n’ai pas créé le pdf, ce sont de vieux cours datant de 2006.

Je ne connais pas les polices :
polices
Ni firefox ni les logiciels ne connaisent les polices.

Merci beaucoup pour l’article, je vais regarder ça de plus près !

1 J'aime

As-tu essayé de l’ouvrir avec Libre Office ?

Oui même résultat
Merci de ton intérêt

A condition que tu aies installé ghostscript, le fichier ayant été généré avec dvips et ghostscript, tu peux tenter de l’afficher avec la commande :

gs -dSAFER -dBATCH cours_reseau.pdf 

Voir How to Use Ghostscript pour plus d’infos.

gitlab.gnome/evince ont résolu le problème :

  • Evince 40 qui se trouve dans les dépôts testing permet d’afficher les polices
  • XPDF permet également d’afficher les polices avec la version debian stable