Problème de boot avec Grub

Tags: #<Tag:0x00007fae528f4ed8> #<Tag:0x00007fae528f4de8>

Bonjour le monde,
suite à une panne de courant électrique, ma Debian 9.6 ne veux plus booter. J’ai bien essayé d’utiliser un cd boot-repair, mais pas moyen. Je ne sais plus quoi faire.
Merci de vos lumières.

Mais encore ? Que se passe-t-il ?

C’est-à-dire ? Essayé d’utiliser comment ? Pas moyen que quoi ?

Fournir des descriptions claires et explicites plutôt que de vagues interprétations serait un bon début.

premier réflexe: chrooter la partition debian et réinstaller grub en utilisant les commandes:
#update-grub
et installer grub sur le disque choisi pour booter en premier(si il y a deux disques installés)

Non. Premier réflexe : analyse et diagnostic. On ne touche à rien.
Au passage, update-grub ne réinstalle pas GRUB.

@Pascal: << et installer grub sur le disque choisi pour booter en premier(si il y a deux disques installés) >>

C’est le seule commande que tu as donnée.

j’ai bien donné la commande "grub-install =/dev/
mais la commande n’est pas apparue après envoi

Ma Debian 9.6 ne veux plus booter, c-à-d qu’après l’allumage de l’ordinateur, le message suivant s’affiche à l’écran : ERROR: No boot disk has been detected or the disk has failed.

J’ai bien essayé d’utiliser un cd boot-repair : pour cela, j’ai effecturer une réparation standard comme indiquer dans la page https://doc.ubuntu-fr.org/boot-repair.

Le système ne bootait pas. J’ai donc suivi la partie Utilisation avancée de la page.
J’ai laissé les options par défaut et fait vérifier le système de fichier avec fdisk.
Boot repair m’a fourni un http://paste.ubuntu.com/p/s2d9Sq2yfr/

Merci.

Ce n’est pas Debian qui ne veut pas booter, c’est le firmware BIOS ou UEFI de l’ordinateur qui ne veut plus amorcer le disque, soit parce qu’il ne le détecte pas, soit parce que le disque ne figure pas dans la liste des périphériques d’amorçage, soit parce que firmware considère que le disque n’est pas bootable.

A moins que la configuration du disque dans les réglages BIOS/UEFI soit soudainement passée à “none”, lui faisant ignorer le disque, la première hypothèse est peu probable, et serait facilement infirmée par la possibilité de sélectionner le disque dans le menu de boot manuel du firmware.

La seconde hypothèse est à vérifier dans les réglages BIOS/UEFI.

J’observe dans le rapport de bootinfoscript que tu as posté que le disque est installé pour être amorcé en mode BIOS/legacy. Cependant on peut voir que le système live lancé à partir de la clé USB a été amorcé en mode EFI (donc l’ordinateur a un firmware UEFI), et que /boot/grub/grub.cfg contient une entrée de menu “UEFI firmware” qui n’est créée que lorsqu’on exécute update-grub/grub-mkconfig en mode EFI. Est-ce que cette action faisait partie des opérations que tu dis avoir essayées ?

Il faudrait vérifier dans les paramètres de boot UEFI si l’amorçage en mode de compatibilité BIOS (parfois désigné “legacy” ou CSM) est activé, et si le disque est bien présent dans la liste d’amorçage legacy.

1 J'aime

Le BIOS reconnaît bien l’unique disque dur :
AHCI Port 1: WDC WD10EZEX-08WN4A0

Les options de boot mentionnement un ordre de priorité de boot :

  • 1st boot device [Hard Disk]
  • 2nd boot device [Removable Device]

on exécute update-grub/grub-mkconfig en mode EFI. Est-ce que cette action faisait partie des opérations que tu dis avoir essayées ?
Clairement non.

En revanche, j’ai activé l’amorçage en mode de compatibilité BIOS et là le firmware UEFI a pu amorcer le disque.

Merci beaucoup pour ces explications claires.