Problème de configuration d'un LAMP


#1

Bonjour à tous !
Je vais essayer de donner le plus de détail sur mon problème qui est surement tout con comme à chaque fois …

Alors j’ai installé un LAMP en suivant la méthode de ce site
libordux.org/debian-docs/deb-lamp.php
qui ma foi est très bien expliqué, mais arrivé à la fin del’installation de phpmyadmin et mysql 4.1, j’ai donc voulu tester si le serveur répondait à l’adresse : localhost/phpmyadmin

et pas moyen de joindre le site !!
je relance les service tout va bien. toujours pas de site alors je redémarre le pc, et là une multitude de problème lié aux socket de mysql ! BOAAH!

je relance les services et je regarde avec netstat -nat:
le socket d’écoute fonctionne sur la boucle locale donc pas d’erreur avec le demon mysql
bizarre
je redémarre mon pc: et il me dit :
checking for crached mysql tables in the background
beuah ! je sais pas ou vérifier ça…

J’ai aussi eu du mal à configurer le password de mysql et j’y suis finalement arrivé en faisant un truc comme ca je crois:

                         mysql > SET PASSWORD
                                  ->FOR '...'@'....' = ....

est-ce un pb si j’essaye d’aller à localhost/phpmyadmin si ma base est vide?
Serait-ce possble que j’ai mal configuré des fichiers de config?

en tout cas le serveur apache me renvoie une erreur 404 preuve que les étapes que j’ai suivie avant grace au site cité en haut fontionne bien…

voila
bisou :smiley:
merci d’avance


#2

pardon jeai oublié de mentionner ma distrib:

c’est une ubuntu
2.6.12-9-386
si d’autres info vous désirez n’hésitez pas
:slightly_smiling:


#3

Est-ce que quelqu’un pourrait me confirmer si c’est parce que la bas de donnée mysql est vide que je n’arrive pas à accéder à la page d’accueil localhost/phpmyadmin

???
yep yep merci


#4

Je n’ai pas tous lu mais normalement lors de l’install de ta bases de données tu doit avoir quelques bases déjà préinstallé si tu n’en as pas du tout ca peut effectivement venir de la.

Essaye une reinstall de mysql


#5

ouais ben c’est finalement ce que j’ai fait

j’ai aussi configuré une d’autre maniere le passw

en faisant mysqladmin -u root password mypassswordddd

voila
bon béé merci a tous ! c’etait un super topic !!ouaii
:unamused: :laughing: :wink: :exclamation: