Problème de connexion SSH entre 2 serveurs

Tags: #<Tag:0x00007f78b984b4d8>

Bonjour tout le monde

J’ai un petit soucis entre 2 de mes serveurs depuis 3 mois :

J’ai deux serveurs (on appellera X & Y) sous debian, les deux en version 11.2

Quand j’essaye de me connecter en SSH de X vers Y (avec un utilisateur spécifique) le prompt SSH me rend pas la main et il reste bloqué après la banner

Je vois pas la connexion passé chez Y.

Le mode verbose ne me donne pas grand chose comme information…

$ ssh backuppc@monserveurY.domain.tld -vvvv
OpenSSH_8.4p1 Debian-5, OpenSSL 1.1.1k  25 Mar 2021
debug1: Reading configuration data /var/lib/backuppc/.ssh/config
debug1: /var/lib/backuppc/.ssh/config line 1: Applying options for monserveurY.domain.tld
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: include /etc/ssh/ssh_config.d/*.conf matched no files
debug1: /etc/ssh/ssh_config line 21: Applying options for *
debug3: expanded UserKnownHostsFile '~/.ssh/known_hosts' -> '/var/lib/backuppc/.ssh/known_hosts'
debug3: expanded UserKnownHostsFile '~/.ssh/known_hosts2' -> '/var/lib/backuppc/.ssh/known_hosts2'
debug2: resolving "monserveurY.domain.tld" port 22
debug2: ssh_connect_direct
debug1: Connecting to monserveurY.domain.tld [ip] port 22.
debug1: Connection established.
debug1: identity file /var/lib/backuppc/.ssh/id_rsa type 0
debug1: identity file /var/lib/backuppc/.ssh/id_rsa-cert type -1
debug1: identity file /var/lib/backuppc/.ssh/id_dsa type -1
debug1: identity file /var/lib/backuppc/.ssh/id_dsa-cert type -1
debug1: identity file /var/lib/backuppc/.ssh/id_ecdsa type -1
debug1: identity file /var/lib/backuppc/.ssh/id_ecdsa-cert type -1
debug1: identity file /var/lib/backuppc/.ssh/id_ecdsa_sk type -1
debug1: identity file /var/lib/backuppc/.ssh/id_ecdsa_sk-cert type -1
debug1: identity file /var/lib/backuppc/.ssh/id_ed25519 type -1
debug1: identity file /var/lib/backuppc/.ssh/id_ed25519-cert type -1
debug1: identity file /var/lib/backuppc/.ssh/id_ed25519_sk type -1
debug1: identity file /var/lib/backuppc/.ssh/id_ed25519_sk-cert type -1
debug1: identity file /var/lib/backuppc/.ssh/id_xmss type -1
debug1: identity file /var/lib/backuppc/.ssh/id_xmss-cert type -1
debug1: Local version string SSH-2.0-OpenSSH_8.4p1 Debian-5
debug1: Remote protocol version 2.0, remote software version OpenSSH_8.4p1 Debian-5
debug1: match: OpenSSH_8.4p1 Debian-5 pat OpenSSH* compat 0x04000000
debug2: fd 3 setting O_NONBLOCK
debug1: Authenticating to monserveurY.domain.tld:22 as 'backuppc'
debug3: put_host_port: [monserveurY.domain.tld]:22
debug3: hostkeys_foreach: reading file "/var/lib/backuppc/.ssh/known_hosts"
debug3: record_hostkey: found key type ECDSA in file /var/lib/backuppc/.ssh/known_hosts:1
debug3: load_hostkeys: loaded 1 keys from [monserveurY.domain.tld]:22
debug3: order_hostkeyalgs: have matching best-preference key type ecdsa-sha2-nistp256-cert-v01@openssh.com, using HostkeyAlgorithms verbatim
debug3: send packet: type 20
debug1: SSH2_MSG_KEXINIT sent
debug3: receive packet: type 20
debug1: SSH2_MSG_KEXINIT received
debug2: local client KEXINIT proposal
debug2: KEX algorithms: curve25519-sha256,curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group16-sha512,diffie-hellman-group18-sha512,diffie-hellman-group14-sha256,ext-info-c
debug2: host key algorithms: ecdsa-sha2-nistp256-cert-v01@openssh.com,ecdsa-sha2-nistp384-cert-v01@openssh.com,ecdsa-sha2-nistp521-cert-v01@openssh.com,sk-ecdsa-sha2-nistp256-cert-v01@openssh.com,ssh-ed25519-cert-v01@openssh.com,sk-ssh-ed25519-cert-v01@openssh.com,rsa-sha2-512-cert-v01@openssh.com,rsa-sha2-256-cert-v01@openssh.com,ssh-rsa-cert-v01@openssh.com,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521,sk-ecdsa-sha2-nistp256@openssh.com,ssh-ed25519,sk-ssh-ed25519@openssh.com,rsa-sha2-512,rsa-sha2-256,ssh-rsa
debug2: ciphers ctos: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com
debug2: ciphers stoc: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com
debug2: MACs ctos: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: MACs stoc: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: compression ctos: none,zlib@openssh.com,zlib
debug2: compression stoc: none,zlib@openssh.com,zlib
debug2: languages ctos: 
debug2: languages stoc: 
debug2: first_kex_follows 0 
debug2: reserved 0 
debug2: peer server KEXINIT proposal
debug2: KEX algorithms: curve25519-sha256,curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group16-sha512,diffie-hellman-group18-sha512,diffie-hellman-group14-sha256
debug2: host key algorithms: rsa-sha2-512,rsa-sha2-256,ssh-rsa,ecdsa-sha2-nistp256,ssh-ed25519
debug2: ciphers ctos: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com
debug2: ciphers stoc: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com
debug2: MACs ctos: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: MACs stoc: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: compression ctos: none,zlib@openssh.com
debug2: compression stoc: none,zlib@openssh.com
debug2: languages ctos: 
debug2: languages stoc: 
debug2: first_kex_follows 0 
debug2: reserved 0 
debug1: kex: algorithm: curve25519-sha256
debug1: kex: host key algorithm: ecdsa-sha2-nistp256
debug1: kex: server->client cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: kex: client->server cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug3: send packet: type 30
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug3: receive packet: type 31
debug1: Server host key: ecdsa-sha2-nistp256 SHA256:KVVTEupXlPOU6jh1NFjvSlQ2qrdcj5FvbD46fDs/ANw
debug3: put_host_port: [ip]:22
debug3: put_host_port: [monserveurY.domain.tld]:22
debug3: hostkeys_foreach: reading file "/var/lib/backuppc/.ssh/known_hosts"
debug3: record_hostkey: found key type ECDSA in file /var/lib/backuppc/.ssh/known_hosts:1
debug3: load_hostkeys: loaded 1 keys from [monserveurY.domain.tld]:22
debug3: hostkeys_foreach: reading file "/var/lib/backuppc/.ssh/known_hosts"
debug3: record_hostkey: found key type ECDSA in file /var/lib/backuppc/.ssh/known_hosts:2
debug3: load_hostkeys: loaded 1 keys from [IP]:22
debug1: Host '[monserveurY.domain.tld]:22' is known and matches the ECDSA host key.
debug1: Found key in /var/lib/backuppc/.ssh/known_hosts:1
debug3: send packet: type 21
debug2: set_newkeys: mode 1
debug1: rekey out after 134217728 blocks
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug3: receive packet: type 21
debug1: SSH2_MSG_NEWKEYS received
debug2: set_newkeys: mode 0
debug1: rekey in after 134217728 blocks
debug1: Will attempt key: /var/lib/backuppc/.ssh/id_rsa RSA SHA256:yUhNbXzOl2ELfqybwVeWrdDylSUBI55gDuA9wgHsOAU
debug1: Will attempt key: /var/lib/backuppc/.ssh/id_dsa 
debug1: Will attempt key: /var/lib/backuppc/.ssh/id_ecdsa 
debug1: Will attempt key: /var/lib/backuppc/.ssh/id_ecdsa_sk 
debug1: Will attempt key: /var/lib/backuppc/.ssh/id_ed25519 
debug1: Will attempt key: /var/lib/backuppc/.ssh/id_ed25519_sk 
debug1: Will attempt key: /var/lib/backuppc/.ssh/id_xmss 
debug2: pubkey_prepare: done
debug3: send packet: type 5
debug3: receive packet: type 7
debug1: SSH2_MSG_EXT_INFO received
debug1: kex_input_ext_info: server-sig-algs=<ssh-ed25519,sk-ssh-ed25519@openssh.com,ssh-rsa,rsa-sha2-256,rsa-sha2-512,ssh-dss,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521,sk-ecdsa-sha2-nistp256@openssh.com,webauthn-sk-ecdsa-sha2-nistp256@openssh.com>
debug3: receive packet: type 6
debug2: service_accept: ssh-userauth
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug3: send packet: type 50
debug3: receive packet: type 51
debug1: Authentications that can continue: publickey
debug3: start over, passed a different list publickey
debug3: preferred gssapi-with-mic,publickey,keyboard-interactive,password
debug3: authmethod_lookup publickey
debug3: remaining preferred: keyboard-interactive,password
debug3: authmethod_is_enabled publickey
debug1: Next authentication method: publickey
debug1: Offering public key: /var/lib/backuppc/.ssh/id_rsa RSA SHA256:yUhNbXzOl2ELfqybwVeWrdDylSUBI55gDuA9wgHsOAU
debug3: send packet: type 50
debug2: we sent a publickey packet, wait for reply
debug3: receive packet: type 60
debug1: Server accepts key: /var/lib/backuppc/.ssh/id_rsa RSA SHA256:yUhNbXzOl2ELfqybwVeWrdDylSUBI55gDuA9wgHsOAU
debug3: sign_and_send_pubkey: RSA SHA256:yUhNbXzOl2ELfqybwVeWrdDylSUBI55gDuA9wgHsOAU
debug3: sign_and_send_pubkey: signing using rsa-sha2-512 SHA256:yUhNbXzOl2ELfqybwVeWrdDylSUBI55gDuA9wgHsOAU
debug3: send packet: type 50
debug3: receive packet: type 52
debug1: Authentication succeeded (publickey).
Authenticated to monserveurY.domain.tld ([IP]:22).
debug1: channel 0: new [client-session]
debug3: ssh_session2_open: channel_new: 0
debug2: channel 0: send open
debug3: send packet: type 90
debug1: Requesting no-more-sessions@openssh.com
debug3: send packet: type 80
debug1: Entering interactive session.
debug1: pledge: network
debug3: receive packet: type 80
debug1: client_input_global_request: rtype hostkeys-00@openssh.com want_reply 0
debug3: receive packet: type 4
debug1: Remote: /home/backuppc/.ssh/authorized_keys:1: key options: user-rc x11-forwarding
debug3: receive packet: type 4
debug1: Remote: /home/backuppc/.ssh/authorized_keys:1: key options: user-rc x11-forwarding
debug3: receive packet: type 91
debug2: channel_input_open_confirmation: channel 0: callback start
debug2: fd 3 setting TCP_NODELAY
debug3: ssh_packet_set_tos: set IP_TOS 0x10
debug2: client_session2_setup: id 0
debug2: channel 0: request pty-req confirm 1
debug3: send packet: type 98
debug1: Sending environment.
debug3: Ignored env SUDO_GID
debug3: Ignored env MAIL
debug3: Ignored env USER
debug3: Ignored env SHLVL
debug3: Ignored env HOME
debug3: Ignored env SUDO_UID
debug3: Ignored env LOGNAME
debug3: Ignored env _
debug3: Ignored env TERM
debug3: Ignored env PATH
debug1: Sending env LANG = en_US.UTF-8
debug2: channel 0: request env confirm 0
debug3: send packet: type 98
debug3: Ignored env LS_COLORS
debug3: Ignored env SUDO_COMMAND
debug3: Ignored env SHELL
debug3: Ignored env SUDO_USER
debug3: Ignored env PWD
debug3: Ignored env LS_OPTIONS
debug2: channel 0: request shell confirm 1
debug3: send packet: type 98
debug2: channel_input_open_confirmation: channel 0: callback done
debug2: channel 0: open confirm rwindow 0 rmax 32768
debug3: receive packet: type 100
debug2: channel_input_status_confirm: type 100 id 0
PTY allocation request failed on channel 0
debug2: channel 0: rcvd adjust 2097152
debug3: receive packet: type 99
debug2: channel_input_status_confirm: type 99 id 0
debug2: shell request accepted on channel 0
Linux monserveurY.domain.tld 4.9.0-3-amd64 #1 SMP Debian 4.9.30-2+deb9u5 (2017-09-19) x86_64

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.

À savoir que je n’ai se soucis que depuis l’user « backuppc ». Si je fais une connexion au serveur Y avec un autre user alors ça fonctionne.

Est-ce quelqu’un aurait une solution ?

Merci d’avance,

Bonjour,

c’est probablement lié à la configuration du compte backuppc.
Sur le serveur Y, peux-tu donner le retour de getent passwd backuppc ?
Regarde aussi s’il existe des règles spécifiques à ce compte dans la configuration ssh (dans le fichier /etc/ssh/sshd_config)

En lançant

sudo less /home/backuppc/.ssh/authorized_keys 

vous devriez voir si la clé est valable pour tous usages (c-à-d lance un shell) ou pour une seule commande précisée dans la clé.
On aurait dans ce cas le type de la clé précédé par des options dont l’option
command="…"

man -s 5 authorized_keys 

Cordialement,
Regards,
Mit freundlichen Grüßen,
مع تحياتي الخالصة


F. Petitjean
Ingénieur civil du Génie Maritime.

« On ne perd pas son temps en aiguisant ses outils. »
Proverbe français

« Moi, lorsque je n’ai rien à dire, je veux qu’on le sache. » (R. Devos)

backuppc:x:1002:1002::/home/backuppc:/bin/sh

@littlejohn75 Nop, je n’ai rien de ça dans mon authorized key.

cependant j’ai :

from="IP_DE_X",no-agent-forwarding,no-port-forwarding,no-pty ssh-rsa AAAA....

Merci

man authorized_keys, nous dit :

no-pty

Prevents tty allocation (a request to allocate a pty will fail).

2 J'aime

Effectivement sans le no-pty ça fonctionne…

Merci @Bruno1