Problème de DHCP


#1

Bonjour,
Je suis nouveau sous Debian.
Je viens de l’installer avec les options par défaut et je n’ai pas pu faire une netinstall car mon dhcp n’est pas reconnu.
J’ai FreeBSD, Windobe et maintenant Debian sur mon ordinateur et sous les autres systèmes le dhcp est reconnu sans problème mais sous Debian rien !
J’ai ma carte qui est bien reconnue mais quand j’essaye dhclient j’ai :
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval X
où X est un nombre qui change suivant les … beaucoup de lignes comme ça avant que je fasse ^C.
Je ne sais vraiment pu quoi faire, quequ’un aurait-il une idée ?
Merci de votre aide.
Sethy


#2

(j’ai déplacé le fil dans le bon forum).
quel noyau as tu installé ?
as tu essayé d’en changer ?
Je crois qu’outre dpcp3-client, le paquet pump fournit un autre client dhcp pour tester.
Sinon, as tu essayé de voir si ça marchait en statique ?
Parceque le module chargé n’est peut être pas le plus adapté à ta carte.
C’est quoi ta carte.


#3

c’est un noyau 2.4
et une carte "Realtek RTL8169/8110 Family Gigabit Ethernet NIC"
je n’ai pas essayé d’autre client dhcp car je ne sais pas comment en installer sans le net.
j’ai regardé mon dhcp et il recoit bien les paquets DHCPDISCOVER et revoie bien DHCPOFFER en réponse.
je vais essayer de voir le module du noyau (même si je ne sais pas comment faire)


#4

je crois surtout que si tu peux il vaut mieux passer en 2.6: il y a un gap dans la gestion du matériel entre les 2.4 et les 2.6 (et surtout les derniers).
En plus, le noyau 2.6.8-2 doit être sur le CD.
Que donne
aptitude search kernel-image
?

si tu as bien une liste de noyaux, aprés avoir choisi un noyau correspondant à ton processeur tu peux directement en installer un (ou plusieurs) avec
aptitude install kernel-image-


#5

Si il reçoit les paquets DHCP, c’est que la carte fonctionne. J’ai déjà vu des problèmes de ce type avec dhcp3-client. Le pbm est résolu avec pump. Le pbm: comment l’installer. pump est très simple d’emploi, je te suggère de télécharger un binaire pump ici:

boisson.homeip.net/pump

(c’est le pump de sarge)

Puis après la merdouille de dhcp et ton controle C, tu te débrouilles pour récupérer pump (disquette par exemple, c’est assez petit: 33K) et tu le lances:

pump

Je te parie une Guiness que ça marcheras!


#6

Je pense que tu ferais bien, en premier, de te charger un noyau plus récent.

apt-get update

Si ce n’est fait, installe synaptic

apt-get install synaptic

va ds synaptic soit par ton bureau soit en console :

synaptic

cherche les
kernel-image
que tu as et choisi le plus récent que tu trouveras, selon ta distrib : Sarge, Etch ou Sid (2.6.12 sous Etch)
Clique sur ce paquet et sur 'installer’
ensuite, en console, vérifie la bonne prise en compte :
$ uname -r
Là, tu seras déjà plus ‘neuf’


#7

Bon, j’ai été dépassé par le “patron” = doublon :confused:


#8

yeah !!!
j’ai recommencé mon install avec le noyau 2.6 et tout à marché du premier coup !!!
merci de m’avoir aidé.

Sethy


#9

[quote=“Sethy”]yeah !!!
j’ai recommencé mon install avec le noyau 2.6 et tout à marché du premier coup !!!
merci de m’avoir aidé.

Sethy[/quote]je ne t’ai pas aidé à réinstaller. Certainement pas.
Il suffisait d’installer juste le paquet du noyau.
Mais bon, je ne vais pas une fois de plus gueuler contre les ceusse qui reinstallent sous n’importe quel pretexte, ce sont eux qui passent leur temps à reconfigurer, c’est leur problême :laughing:


#10

[quote]j’ai recommencé mon install avec le noyau 2.6 [/quote] dommage que tu n’aies pas lu mon post (plus haut) avant de réinstaller car il te suffisait d’installer une image . :unamused: