problème de MdP sous KDE 3.4


#1

A l’ouverture de :
menu KDE 3.4 / centre de config / admisitration du système / gestionnaire de connexion / mode superutilisateur / mot de pass root.
J’entre ce mdp et je me retrouve sur l’écran de départ (bleu).
Je croyais donc que le mdp n’est pas accepté, bien que ça n’est pas dit. Ce n’est pas le cas d’ailleurs car si je mets un autre pass, là j’ai un msg de pass incorrect
Impossible donc de modifier le gestionnaire de connexion (kdm)
Ds la fenêtre de demnade du pass, la commande est marquée comme : kcmshell kdm et je tente donc de la faire en console.

[code]ricardo:/home/ricardo# kcmshell kdm
DCOPClient::attachInternal. Attach failed Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed

It looks like dcopserver is already running. If you are sure
that it is not already running, remove /root/.DCOPserver_ricardo__0
and start dcopserver again.

DCOPClient::attachInternal. Attach failed Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
WARNING: DCOP communication problem!
DCOPClient::attachInternal. Attach failed Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
FATAL: DCOP communication problem!
kdeinit: Communication error with launcher. Exiting!
I couldn’t enable notifications at the dcopserver!
I couldn’t enable notifications at the dcopserver!
QImage::smoothScale: Image is a null image
ricardo:/home/ricardo#
[/code]
Malgré cette réponse, la fenêtre du gestionnaire de connexion s’ouvre quand m^ et je peux modifier les données.
Je n’ai pas ce problème avec KDE 3.3
Je suis allé ds DCOPserver et le propriétaire est ricardo les droits en 644.
J’ai tenté de modifier ces droits et ça fonctionne une fois sur deux. De ttes façons, il n’y a pas pérénité car ils reviennent en 644 au reboot.
Une idée ?


#2

UP, des fois que qq’un n’aurait pas lu ce post :wink:


#3

et pourquoi c’est un prompt de root, dans ton exemple ?


#4

Ben il faut être le superutilisateur pour modifier ce gestionnaire de connexion.
En ‘user’, j’ouvre bien la fenêtre mais c’est en grisé et on ne peut pas modifier.


#5

bon, déjà, ton root n’a pas par défaut les droits sur le serveur X, mais même en lancant en user, normelement, même grisé, tu as un bouton pour passer en mode administrateur.


#6

Oui, bien sûr que je oeux lancer en user mais ensuite, pour modifier qq chose, il me faut passer en mode superutilisteur et là, macache, retour à la m^ fenêtre grisée.
Voici l’url où tu pourras voir ce qui apparaît avec la commande :
$ kcmshell kdm
ricardo.free.fr/captures/capture2.png
Le problème est le m^ en graphique, à partir du centre de config de kde qu’en console en entrant
Si je passe avec ‘su -’ , ça n’ouvre pas :

kcmshell: cannot connect to X server

Par contre, si j’entre avec ‘su’ (sans le ‘-’), j’ai le msg suivant :

[quote]FATAL: DCOP communication problem!
DCOPClient::attachInternal. Attach failed Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
[/quote]
MAIS la fenêtre s’ouvre quand m^ et je peux modifier ce que je veux. ???