Problème de résolution avec ma Ati Radeon 9700 Mobility


#1

Hello tout le monde
Voici mon problème : j’installe Debian sur mon Asus A4000… Tout roule, le son fonctionne, l’affichage aussi. Seulement dans le menu Gnome Préférences Résolution de l’écran.
Comme choix j’ai ou bien 800600 (choix actuel :’( )
ou bien 640
480 (ce qui ne sera jamais mon choix :wink: )
Voila merci de votre coup de main… autant la config de Jack Ardour et tout le tralala pour l’audio sous Linux, ça va, mais alors dès qu’il s’agit de problèmes de ce genre… hum… Merci tout le monde!


#2

apt-get install xdebconfigurator discover kudzu hwinfo hwtools

Ensuite:
xdebconfiguration -diklr
dexconf

la commande xdebconfigurator va utiliser les outils de détection hardware installés plus haut et dexconf te générera un XF86Config-4 tout neuf, avec toutes les résolutions supportées par ton matériel.

Comme je suis un grand fainéant, j’utilise systématiquement cette méthode pour reconfigurer Xwindow. Ca fait tout le boulot automatiquement… :slightly_smiling:

Résultat miracle garanti dans au moins 90 % des cas :wink:


#3

et bien je te remercie c’est super sympa! Je m’attendais à avoir une réponse beaucoup plus compliquée :slightly_smiling: On dit que Asus ne fait presque rien pour le support sous Nux de leur matos, mais moi à part un lecteur SD/MMC et un écran LCD qui clignote au moment des installs (j’ai quand même sur m’occuper de ça en bootant avec “linux vga=771”…) tout va bien!

Bon j’arrête de raconter ma ptite vie :wink: Remerci!
Guillaume


#4

rhaaaa cela me renvoie
"Failed to determine video card driver or xserver at /usr/sbin/xdebconfigurator line 1201." Bon je vais faire ça “a la mano” :wink: on verra bien! Déjà j’ai réussi à passer en 1024768, mais l’idéal pour mon écran c’est le 12801024, là, l’écran il adore :wink: merci quand même, je te donne des nouvelles!


#5

Content que ca aie au moins partiellement fonctionné :slightly_smiling:
Ensuite tu peux aussi essayer le package suivant pour affiner tes réglages:

jeannot@burp:~$ apt-cache search xresprobe
xresprobe - X Resolution Probe
jeannot@burp:~$

Je l’ai jamais testé donc je sais pas ce que ca vaut …


#6

ou sinon tu peux faire un :
$ dpkg-reconfigure xserver-xfree86
Et faire bien attention à sélectionner les bonnes options au niveau des définitions disponibles et des propriétés de l’écran.


#7

Ou encore éditer en tant que root ton
/etc/X11/XF86Config-4
Là, ds la section Screen, tu ajoutes manuellement les résolutions que tu désires :
"1280x1024"
avec un espace entre chaque résolution
Ensuite, reboot, bien sûr et choix de la résolution ds ton KDE ou Gnome ou autre, selon


#8

[quote=“Ricardo”]Ou encore éditer en tant que root ton
/etc/X11/XF86Config-4
Là, ds la section Screen, tu ajoutes manuellement les résolutions que tu désires :
"1280x1024"
avec un espace entre chaque résolution
Ensuite, reboot, bien sûr et choix de la résolution ds ton KDE ou Gnome ou autre, selon[/quote]

Le redémarrage du serveur X suffit (Ctrl+Alt+Backspace), et ça fait gagner du temps :wink:


#9

et sinon, aprés modification manuelle, ne pas oublier la commande:
md5sum /etc/X11/XF86Config-4 > /var/lib/xfree86/XF86Config-4.md5sum
Parceque sinon, debian refuse ensuite de modifier le fichier, et ‘dpkg-reconfigure xserver-xfree86’ ne fonctionne plus .