Problème démarrage interface graphique


#1

Bonjour,

Marre, marre et marre des problèmes, j’ai passé au moins 80 heures à installer cette machine et j’aimerais bien l’utiliser …mais bon

Ben voila, j’ai probablement du faire une petite erreur mais je ne me souviens pas ce que j’ai fait de travers.
Je n’arrive plus à démarrer ma session graphique KDE ni GNOME, la seule chose que j’obtiens est le 'terminal’
quand je fais kdesktop, j’obtiens :
KUniqueApplication : Can’t determine DISPLAY. ABORTING.

Qui saurais me dire ce que je dois faire ?? -quel fichier regarder.

Merci


#2

Et si avant de lancer ton kdesktop tu tapes :

export DISPLAY=:0.0 .

( Je ne sais pas si ça va résoudre ton problème ).


#3

c’est quoi: “je fais kdesktop” ?
tu passes par un login manager (xdm, kdm, gdm, etc…), ou tu lances xwindows à la main avec “startx” ?


#4

[quote=“MattOTop”]c’est quoi: “je fais kdesktop” ?
tu passes par un login manager (xdm, kdm, gdm, etc…), ou tu lances xwindows à la main avec “startx” ?[/quote]

Réflex d’ex-windowsien probablement mais j’ai éteint puis ralumé ma machine et au lieu de me montrer une belle page de login, l’écran noir et le prompt de login. Alt+Ctrl F7 mais pas moyen d’avoir une session graphique.

Alors j’ai essayé le export DISPLAY :0.0 [rien]
Puis encore une fois kdesktop =>

kdeinit : Can’t connect to the X Server
kdeinit : Might not terminte at end of session
kded : cannot connect to X server : 0.0
DCOP aborting call from anonymous-12906 to kded
kded : ERROR: Communication problem with kded, it probably crashed
kdesktop : cannot connect to X server : 0.0
DCOP aborting call from nonymous-12906 to kdesktop
ERROR: Communication problem with kdesktop, it probably crashed.

Vwala, j’ai également chai tun chown stephane * parce que certains fichiers ont filé sous propriétaire root…
Ce qui est marrant( enfin moyennement) , c’est que j’arrive encore à me logger sur la machine via client nx - freenx en session kde mais sous un autre compte ‘test’ que j’ai eu l’intelligence de créer…

Merci de votre aide.

windmill


#5

bon ecoutes, je n’ai jamais lancé kdesktop manuellement, mais si tu n’as pas de serveur X qui tourne sur ton ecran principal, aucune chance que quoi que ce soit se lance.

Déjà, avant toutes choses, vérifies que tu es bien à jour de tes paquets:
apt-get update
apt-get upgrade
si tu as des paquets “CONSERVES”, tu affiches ici le résultat de ta commande, et on t’aidera.

Ensuite, premiere verification, à faire en mode console:
tu vérifies que tu peux lancer xwindows, avec ‘startx’

si ça marche, tu choisis un gestionnaire de login (kdm, gdm, ou xdm), tu l’installes:
apt-get install
et tu rebootes.
(notes que tu peux prendre gdm même si tu es sous kde, etc, mais que c’est plus facile à gèrer si tu installes kdm, comme tu es sous kdm.

SI CA NE MARCHE PAS AVEC startx:
tu fais
dpkg-reconfigure xserver-xorg
et si tu n’utilises pas xorg, l’alternative, c’est
dpkg-reconfigure xserver-xfree86

VALA 8)

PS: freeNX utilise son propre serveur X indépendant de celui qui gère ton ecran/clavier/souris.


#6

[quote=“MattOTop”]bon ecoutes, je n’ai jamais lancé kdesktop manuellement, mais si tu n’as pas de serveur X qui tourne sur ton ecran principal, aucune chance que quoi que ce soit se lance.

Déjà, avant toutes choses, vérifies que tu es bien à jour de tes paquets:
apt-get update
apt-get upgrade
si tu as des paquets “CONSERVES”, tu affiches ici le résultat de ta commande, et on t’aidera.

Ensuite, premiere verification, à faire en mode console:
tu vérifies que tu peux lancer xwindows, avec ‘startx’

si ça marche, tu choisis un gestionnaire de login (kdm, gdm, ou xdm), tu l’installes:
apt-get install
et tu rebootes.
(notes que tu peux prendre gdm même si tu es sous kde, etc, mais que c’est plus facile à gèrer si tu installes kdm, comme tu es sous kdm.

SI CA NE MARCHE PAS AVEC startx:
tu fais
dpkg-reconfigure xserver-xorg
et si tu n’utilises pas xorg, l’alternative, c’est
dpkg-reconfigure xserver-xfree86

VALA 8)

PS: freeNX utilise son propre serveur X indépendant de celui qui gère ton ecran/clavier/souris.[/quote]

Startx me donne malheureusement toujours (après dpkg-re… et apt-get)
Fatal server error

AddScreen/ScreenInit failed for driver 0
XIO : fatal IO error 104 (connection reset by peer) on X server “0:0” after 0 request (0 known processed) with 0 events remaining

Merci


#7

Tu n’as malheureusement recopié ici que le texte général d’erreur, et pas le contenu de l’erreur elle même.
il faudrait que tu donnes ici le contenu de /var/log/Xorg.0.log , ou à défaut, parceque j’imagine que ça serait long à recopier :wink: , les lignes avec “(EE)” (ce sont les erreurs précises du serveur X).

Est ce que par hasard, tu n’as pas touché avec un editeur le fichier /etc/X11/xorg.conf ?


#8

[quote=“MattOTop”]
Est ce que par hasard, tu n’as pas touché avec un editeur le fichier /etc/X11/xorg.conf ?[/quote]

:blush: si pour régler mon problème de clavier avec freenx - nx
mais par contre j’ai recommencé le dpkg et j’ai tout laissé comme proposé …et miracle, tout refonctionne !! Merci beaucoup à toi,MattOTop !!!

Je vais encore tester 2 -3 trucs et je te tiens au courant de mes erreurs dans le ficheir log.

Encore merci !!! (je comptait recommencer l’installation depuis le début…)

Par contre mon problème de clavier est à rerégler. Mais cette fois, j’ai trouvé le fauteur de troubles : c’est le clienbt nomachine qui envoie comme commande de départ --kbtype=pc102/be alors que çà doit être un pc105 nondidju !!

windmill


#9

Comme dit Manatane, notre maitre à tous: JAMAIS AU GRAND JAMAIS, vous ne devez réinstaller une debian. Vous seriez alors condamné à trouver une nouvelle série de configuration au moins aussi complexe que celle qui vous reste à trouver…


#10

Formatage + réinstall = réflexes de windowsiens !


#11

oui, windows à fait beaucoups de tord face à l’utilisation des micros. En particulier le fameux rebootage après installation. Un reflex windowsien pas facile à enlever.


#12

[quote=“Damsss”]oui, windows à fait beaucoups de tord face à l’utilisation des micros. En particulier le fameux rebootage après installation. Un reflex windowsien pas facile à enlever.[/quote]Ca m’arrive tout de même de le faire, quand j’ai fais trop de modif et que je ne sais plus si j’ai testé, redémarré les services auxquels j’ai touché.
Même sur des serveurs en prod :confused:

PS: Damsss… Tort, pas tord. A moins que tu n’aies voulu dire: “windows a fait beaucoup de tordus…”. Et pendant que j’y suis (mais je sors aprés), dans la même phrase, pas “à” pour avoir, et “beaucoup” n’a pas de pluriel :unamused:
Et dire que c’'est moi qui râle d’habitude contre les pinailleurs orthographiques :cry:


#13

oui, les dictées m’ont fait beaucoup de tort. :laughing: